Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-03-11, 07:57 AM   #1
RAMChYLD
Registered User
 
Join Date: Feb 2005
Location: Malaysia
Posts: 95
Default 96.43.19 and XOrg 1.10.1

Hi all,

Recently, Debian has upgraded it's XOrg to 1.10.1, and after the upgrade I'm no longer able to start X on my older Debian box with the 96.43.19 drivers. A quick google with the error message shows that it's because the ABI has changed and the drivers are no longer working under the new XOrg.

May I know when a patch to fix this problem or a new version of drivers for the GeForce4 cards will be released? Upgrading the vidcard is not an option for now.

Attached is my XOrg log, just in case.

Thanks.
Attached Files
File Type: log Xorg.0.log (6.7 KB, 169 views)
__________________
Rigs:
  • "Edison" - Phenom II X4 925 AM3 (Deneb), M4N98TD-EVO (nForce980a SLI), ENGTS450 DirectCU 1GB (GeForce GTS450) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 8GB DDR3-1600
  • "Sally" - Athlon64 x2 5000+ AM2 (Brisbane), M4N72-E (nForce750a SLI), ENGTS250 Dark Knight 1GB (GeForce GTS250) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 4GB DDR2-1066
  • "Dongwa" - Phenom II X4 945 AM3 (Deneb), M4N75TD (nForce750a SLI), ENGTX260-216SP 896MB (GeForce GTX260 216SP) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Fatal1ty Champion, 8GB DDR3-1600
  • "Helen" - Athlon64 x2 6400+ AM2 (Windsor), M4N78 Pro (GeForce8300), ENGT520 1GB (GeForce GT520), integrated GeForce8300, AuzenTech Prelude X-Fi, 4GB DDR2-1066.
  • "Clementine" - Athlon64 x2 3800+ AM2 (Windsor), TF560A2+ (nForce560), V8402GL26 (GeForce 8400GS), SoundBlaster Live! 5.1, Sonnet Allegro FW400 PCIe, 2GB DDR2-800
RAMChYLD is offline   Reply With Quote
Old 05-04-11, 02:07 PM   #2
radixx11
Registered User
 
Join Date: May 2011
Posts: 2
Default Re: 96.43.19 and XOrg 1.10.1

Hi! i have the same problem with nvidia 96.43.19 drivers in ubuntu 11.04 (xorg 1.10). i need it for a GeForce 4 MX 440. please release an update soon. thanks.
radixx11 is offline   Reply With Quote
Old 05-10-11, 07:17 AM   #3
zekica
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: 96.43.19 and XOrg 1.10.1

Any news on 96.43.xx release with Xorg 1.10 support?
zekica is offline   Reply With Quote
Old 05-12-11, 10:20 AM   #4
RAMChYLD
Registered User
 
Join Date: Feb 2005
Location: Malaysia
Posts: 95
Default Re: 96.43.19 and XOrg 1.10.1

Frankly, I've already given up. I'm planning to overhaul my Media Center PC soon, and the old Linux box can have the old MCPC's mobo, video card, CPU and RAM. It's a shame tho, the box is still usable as ever even though the CPU and GPU is a bit on the slouchy side (Athlon XP 1800+ and GeForce4 440MX 8X respectively). Sure, I have a new Linux box, but the idea was to use this new one heavily for virtualization experiments, and the other one for development tasks.

The one thing I hate about the above plan is that I have to reinstall everything- It requires a new HDD since the current machine runs off rather ancient ATA-IDE hard disks and the MCPC mobo uses SATA instead, and that I need to change distro to x86_64 from x86, so using Clonezilla is a no-go.

And oh, I hope the video card works with the 270.26 drivers. It has trouble working with drivers newer than 197.45 in Windows, hence the decision to overhaul. Card is a Biostar GeForce G210.
__________________
Rigs:
  • "Edison" - Phenom II X4 925 AM3 (Deneb), M4N98TD-EVO (nForce980a SLI), ENGTS450 DirectCU 1GB (GeForce GTS450) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 8GB DDR3-1600
  • "Sally" - Athlon64 x2 5000+ AM2 (Brisbane), M4N72-E (nForce750a SLI), ENGTS250 Dark Knight 1GB (GeForce GTS250) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 4GB DDR2-1066
  • "Dongwa" - Phenom II X4 945 AM3 (Deneb), M4N75TD (nForce750a SLI), ENGTX260-216SP 896MB (GeForce GTX260 216SP) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Fatal1ty Champion, 8GB DDR3-1600
  • "Helen" - Athlon64 x2 6400+ AM2 (Windsor), M4N78 Pro (GeForce8300), ENGT520 1GB (GeForce GT520), integrated GeForce8300, AuzenTech Prelude X-Fi, 4GB DDR2-1066.
  • "Clementine" - Athlon64 x2 3800+ AM2 (Windsor), TF560A2+ (nForce560), V8402GL26 (GeForce 8400GS), SoundBlaster Live! 5.1, Sonnet Allegro FW400 PCIe, 2GB DDR2-800
RAMChYLD is offline   Reply With Quote
Old 05-17-11, 12:06 PM   #5
zekica
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: 96.43.19 and XOrg 1.10.1

Any news?

Bump.
zekica is offline   Reply With Quote
Old 05-20-11, 09:56 AM   #6
ss123
Registered User
 
Join Date: Mar 2005
Posts: 8
Default Re: 96.43.19 and XOrg 1.10.1

I also await an update for this driver to support 1.10
ss123 is offline   Reply With Quote
Old 05-20-11, 10:53 AM   #7
RAMChYLD
Registered User
 
Join Date: Feb 2005
Location: Malaysia
Posts: 95
Default Re: 96.43.19 and XOrg 1.10.1

Still no news. Which is okay. I've done the transfer and now won't bother anymore.

Although I still had to downgrade the video card since the Biostar GeForce 210 doesn't want to work with 270.45 for whatever reason (in fact, it won't even work with 270.45, or anything newer than 197.45 under Windows). In the end I'm using an older Biostar 8400GS which works like a charm.

Now in the market for the required mobo/vidcard for my MCPC. Difficult because I can't find the Asus M4N78 Pro anywhere!
__________________
Rigs:
  • "Edison" - Phenom II X4 925 AM3 (Deneb), M4N98TD-EVO (nForce980a SLI), ENGTS450 DirectCU 1GB (GeForce GTS450) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 8GB DDR3-1600
  • "Sally" - Athlon64 x2 5000+ AM2 (Brisbane), M4N72-E (nForce750a SLI), ENGTS250 Dark Knight 1GB (GeForce GTS250) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Titanium Fatal1ty Pro, 4GB DDR2-1066
  • "Dongwa" - Phenom II X4 945 AM3 (Deneb), M4N75TD (nForce750a SLI), ENGTX260-216SP 896MB (GeForce GTX260 216SP) x2 (SLI), integrated GeForce8200, SoundBlaster X-Fi Fatal1ty Champion, 8GB DDR3-1600
  • "Helen" - Athlon64 x2 6400+ AM2 (Windsor), M4N78 Pro (GeForce8300), ENGT520 1GB (GeForce GT520), integrated GeForce8300, AuzenTech Prelude X-Fi, 4GB DDR2-1066.
  • "Clementine" - Athlon64 x2 3800+ AM2 (Windsor), TF560A2+ (nForce560), V8402GL26 (GeForce 8400GS), SoundBlaster Live! 5.1, Sonnet Allegro FW400 PCIe, 2GB DDR2-800
RAMChYLD is offline   Reply With Quote
Old 05-25-11, 05:30 AM   #8
sveterv2
Registered User
 
Join Date: Mar 2006
Posts: 5
Default Re: 96.43.19 and XOrg 1.10.1

My Debian (testing) is now without 3D acceleration, no Google Earth

Please guys, update 96.xx.xx drivers for Linux.
sveterv2 is offline   Reply With Quote

Old 05-26-11, 09:45 AM   #9
utanja
Debian All the Way
 
Join Date: May 2004
Location: Salzburg Austria & Orlando Florida
Posts: 59
Default Re: 96.43.19 and XOrg 1.10.1

I have reverted back to the stable XORG and company for my legacy MX440 to work...
__________________
utanja
i am female and i don't do windows.. and i don't do macs ..i fly a Lear Jet
"Wer fremde Sprachen nicht kennt, weiss nichts von seiner eigenen."
- Goethe, Maximen und Reflexionen
Intel 3I-core 2d.gen -3.1GHz;8 gig ram;PureDebian SID[3.2[custom kernel] 8 Debian workstations
plus HP Win7 64bit Wireless Laptop Network/Citrix/NX/VMware
Mozilla/Firebird browsers
my american friends call me tonya
utanja is offline   Reply With Quote
Old 05-27-11, 09:40 PM   #10
hdfdav
Registered User
 
Join Date: May 2011
Posts: 3
Default Re: 96.43.19 and XOrg 1.10.1

I have exactly the same problem. If I only knew WHEN an updated 96.xx driver will be out. I am thinking of deleting my laptop's HDD and installing old distro from scratch .. what is really a lot of work .. but I need 3D support.
hdfdav is offline   Reply With Quote
Old 05-27-11, 11:24 PM   #11
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 96.43.19 and XOrg 1.10.1

I can't promise a date, but I'm working on getting a new release out as soon as I can.
AaronP is offline   Reply With Quote
Old 05-28-11, 06:19 AM   #12
hdfdav
Registered User
 
Join Date: May 2011
Posts: 3
Default Re: 96.43.19 and XOrg 1.10.1

Thank you very much AaronP. It is very good to know someone is working on it.

Aside of promising exact date or anything, can you estimate the time frame it would take?
I mean days, weeks, months ... at least a rough estimation please. Thank you for your time!
hdfdav is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.