Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-11, 12:17 PM   #1
napopa
Registered User
 
Join Date: Jun 2011
Posts: 2
Default Nvida module fails to load for Quadro FX 3700

Hi,
I'm trying to install the Nvidia driver form my Nvidia Quadro FX 3700 (10de:061a) on an ArchLinux system. The card is listed as supported both on Nvidia website and in the README.txt that comes with the driver.

I disabled the "nouveau" module system-wide and I compiled the Nvidia module flawlessly but when I try to load the it I got this

#modprobe nvidia

Code:
FATAL: Error inserting nvidia (/lib/modules/2.6.38-ARCH/kernel/drivers/video/nvidia.ko): No such device.
#dmesg

Code:
[ 3175.210636] nvidia 0000:03:00.0: PCI INT A -> Link[APC5] -> GSI 16 (level, low) -> IRQ 16
[ 3175.210647] nvidia 0000:03:00.0: setting latency timer to 64
[ 3175.210651] vgaarb: device changed decodes: PCI:0000:03:00.0,olddecodes=none,decodes=none:owns=io+mem
[ 3175.210676] NVRM: The NVIDIA GPU 0000:03:00.0 (PCI ID: 10de:061a) installed
[ 3175.210677] NVRM: in this system is not supported by the 275.09 NVIDIA Linux
[ 3175.210678] NVRM: graphics driver release.  Please see 'Appendix A -
[ 3175.210679] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 3175.210680] NVRM: available on the Linux graphics driver download page at
[ 3175.210681] NVRM: www.nvidia.com.
[ 3175.210688] nvidia 0000:03:00.0: PCI INT A disabled
[ 3175.210695] nvidia: probe of 0000:03:00.0 failed with error -1
[ 3175.210712] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 3175.210714] NVRM: None of the NVIDIA graphics adapters were initialized!
As I said, the card is listed as supported by the driver...
I tried several recent versions of the driver itself (even the beta) but I can't pick up too old ones since I need the 3d Stereo mode support.

Is there a way to force the driver to load anyways? or to disable the revision control of the card?
thanks!
napopa is offline   Reply With Quote
Old 06-02-11, 10:45 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Nivida module fails to load for Quadro FX 3700

This sounds a lot like a problem reported recently on Ubuntu: https://bugs.launchpad.net/ubuntu/+s...rs/+bug/661248

This is not an NVIDIA driver bug; rather, the kernel or system BIOS is breaking access to the GPU somehow before the NVIDIA driver is even loaded. This manifests itself as a "this GPU is unsupported" error but the real problem is that the GPU is simply accessible to the driver.
AaronP is offline   Reply With Quote
Old 06-03-11, 04:19 PM   #3
napopa
Registered User
 
Join Date: Jun 2011
Posts: 2
Default Re: Nivida module fails to load for Quadro FX 3700

Hi,
thanks for your answer.

Flipping through the comments on the bug report on launchpad i found a link to this topic

http://www.nvnews.net/vbulletin/showthread.php?t=134271

it looks like the same problem I'm having here but i have different values for the memory addresses

Code:
(...)
[virtual] Memory at f8000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at f6000000 (64-bit, non-prefetchable) [size=32M]
[virtual] Expansion ROM at f9fe0000 [disabled] [size=128K]
(...)
applying the same solution proposed in that topic allows me to load the module, but if I try to start the X server I end up with now graphics and I cant go back to the console.

Should I set another memory address via the setpci command given my situation ?

EDIT:
I think i figured out that the command I should give is

Code:
setpci -s 03:00.0 BASE_ADDRESS_0=0xf8000000
with this command the [virtual] in the previous output goes away for the first line, but not for the Expansion ROM.
the results modprobing the nvidia modules are the same as before. the module gets loaded now but I lose all the graphics and i have to reboot the machine via ssh.

Last edited by napopa; 06-03-11 at 06:07 PM. Reason: added information
napopa is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.