Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-17-11, 11:29 PM   #1
hdclark
Registered User
 
Join Date: Jun 2011
Posts: 5
Default 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

This is an odd bug. In fact, I'm not even sure if it is a bug.

I have a scene with about 200 polygons being drawn using FreeGlut and default shaders. Each polygon can optionally have face normals superimposed, using something simple like

Code:
    glDisable(GL_LIGHTING);
    glDisable(GL_TEXTURE_2D);
    glLineWidth(blkwid/10.0);
    glColor3f(1.0,1.0,1.0);
    glBegin(GL_LINES);

    glVertex3f( (VA.x)*A+a,  (VA.y)*A+b, (VA.z)*A+c);
    glVertex3f( (VB.x)*A+a,  (VB.y)*A+b, (VB.z)*A+c);

    glEnd();
    glEnable(GL_LIGHTING);
    glEnable(GL_TEXTURE_2D);
    glLineWidth(blkwid/10.0);
    glColor3f(1.0,1.0,1.0);

on each polygon face, which point outward along the normal. Prior to the 275.09.07 driver, showing the normals slowed my frame rate by about 30%.

Since a fresh update of X, nvidia, and a kernel26 reinstall, when I run the code without showing the normals, the mouse and keyboard input become extremely choppy, the scene update becomes choppy, but my overall framerate does not drop.

If I run the code with showing normals, the choppiness nearly disappears. The code has a much higher framerate compared with no normals. There is a slight degradation in framerate compared with prior nvidia driver, but it is at least useable.


Candidly, It 'feels' like the buffer has been pushed onto hard disk when I run without showing the normals.


I have no noticeable effects running my desktop manager or glxgears. As I mentioned, I just reinstalled X*, nvidia, and my kernel because of issues loading the the 'glx' module (the solution to this problem was to remove an old version of libglx.so.)

I'm at a loss here. I don't even know where to ask, really. I could probably make a video showing what I am talking about, but I doubt it would help diagnose what the issue is.

Thanks.
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.7 KB, 76 views)
File Type: txt Xorg.0.log.old.txt (20.5 KB, 97 views)
File Type: txt glxinfo.txt (23.6 KB, 85 views)
hdclark is offline   Reply With Quote
Old 06-18-11, 02:35 PM   #2
hdclark
Registered User
 
Join Date: Jun 2011
Posts: 5
Default Re: 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

My experiences here are probably related to http://www.nvnews.net/vbulletin/showthread.php?t=160566 .
hdclark is offline   Reply With Quote
Old 06-19-11, 04:36 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

Can you attach your program or send us a link to where we can get it, please?
AaronP is offline   Reply With Quote
Old 06-20-11, 05:30 PM   #4
hdclark
Registered User
 
Join Date: Jun 2011
Posts: 5
Default Re: 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

Here are two programs which seem to be doing this. They use most of the same code, though.

(Sorry about including everything - I didn't have time to write a makefile or detailed instructions.)

Program requires:
Code:
    Linux environment, 
    libao, 
    libogg,
    libvorbis, 
    magick++ (fedora: ImageMagick-c++, arch: imagemagick)
    Freeglut
Download from:
http://nonsen.es/testprog.tar.bz2

Unpacking/compiling:
Code:
    bunzip2 testprog.tar.bz2
    tar -xf testprog.tar
    cd testprog

    chmod 777 compile.sh
    ./compile.sh
    ./compile.sh texmaker
Running:
Code:
    ./texmaker  tex_model_HJ6T2_5gTwMVmMWt

    press 'F2'  and then toggle normals with 'w'. Move around with the mouse to see choppiness. Exit with 'ESC'.
OR (the second program)
Code:
     cd Audio
      chmod 777 compile.sh
     ./compile.sh
     cd ..
     ./Audio/sndsrv &
     ./backend &
    ./globe
now just move around (wasd and space) to see choppiness. This is of less relevance because I cannot compare it to anything to show you, but prior to my upgrade on Thrusday there was no choppiness .
Code:
      *After exiting with 'ESC', kill sndsrv with:
         killall sndsrv
Extra info:
I have not included any license info because I have not decided which to use yet.
Please do not use any part of this program before asking me to clarify the license.

---------------
This program has run fine with every nvidia driver released on Fedora and Arch for the past year, but the recent driver makes things choppy.
hdclark is offline   Reply With Quote
Old 06-20-11, 05:46 PM   #5
hdclark
Registered User
 
Join Date: Jun 2011
Posts: 5
Default Re: 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

Also - no laughing at the 'quality' of the program, please
hdclark is offline   Reply With Quote
Old 06-20-11, 07:22 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

I gave your test app a try and it works fine for me on the hardware I have available here. I'll have to try to match your configuration a little more closely the next time I have access to a wider range of hardware.
AaronP is offline   Reply With Quote
Old 06-20-11, 10:37 PM   #7
hdclark
Registered User
 
Join Date: Jun 2011
Posts: 5
Default Re: 275.09.07 (extreme) choppiness using FreeGlut with ArchLinux

Thanks for trying. It seems like it only happens on one of my computers, whilst it works fine on another two (with previous Nvidia drivers.)

I uploaded a video to http://www.youtube.com/watch?v=Lt-YLuA0Qqg , but unfortunately my screen-capturing rate was highly distorted by drawing the normals so the frame rate shoots up when I disable them. It is hard to see the choppiness, but it is there.

I should clarify again that the frame rate has never been the problem; it feels very sluggish to respond to the peripherals.
hdclark is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.