Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-26-11, 08:50 PM   #1
DBabo
Registered User
 
Join Date: Dec 2010
Posts: 15
Default mplayer -vc - no vdpau

Hello,
i'm trying to get vdpau to work with mplayer. I'm sure this was answered, probably a dozen times, but my search yields nothing.
here is the situation:
Code:
 uname -a
Linux server.home 2.6.32-131.2.1.el6.i686 #1 SMP Thu Jun 2 10:08:29 CDT 2011 i686 i686 i386 GNU/Linux
[az@server Downloads]$ cat /etc/redhat-release 
Scientific Linux release 6.0 (Carbon)
Code:
[az@server Downloads]$ mplayer -vo help | grep vdp
[az@server Downloads]$ mplayer -vc help | grep vdp
ffmpeg12vdpau ffmpeg    working   FFmpeg MPEG-1/2 (VDPAU)  [mpegvideo_vdpau]
ffwmv3vdpau ffmpeg    problems  FFmpeg WMV3/WMV9 (VDPAU)  [wmv3_vdpau]
ffvc1vdpau  ffmpeg    problems  FFmpeg WVC1 (VDPAU)  [vc1_vdpau]
ffh264vdpau ffmpeg    working   FFmpeg H.264 (VDPAU)  [h264_vdpau]
ffodivxvdpau ffmpeg    working   FFmpeg MPEG-4,DIVX-4/5 (VDPAU)  [mpeg4_vdpau]
Now two attempts to play video:
Code:
mplayer -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau, /mnt/Cannon/orig/00022.mts 
MPlayer SVN-r31628-4.4.4 (C) 2000-2010 MPlayer Team

Playing /mnt/Cannon/orig/00022.mts.
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)!  PROGRAM N. 1
FPS seems to be: 29.970030
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 256.0 kbit/16.67% (ratio: 32000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.4 (01.3) of 4661.9 ( 1:17:41.9)  1.1%                                                                                      

MPlayer interrupted by signal 2 in module: play_audio
A:   1.4 (01.4) of 4661.9 ( 1:17:41.9)  1.1%                                                                                      
Exiting... (Quit)
no video displayed.

Code:
mplayer -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau, /mnt/Cannon/orig/00022.mts 
MPlayer SVN-r31628-4.4.4 (C) 2000-2010 MPlayer Team

Playing /mnt/Cannon/orig/00022.mts.
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)!  PROGRAM N. 1
FPS seems to be: 29.970030
==========================================================================
Forced video codec: ffmpeg12vdpau
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Cannot find codec 'h264_vdpau' in libavcodec...
VDecoder init failed :(
Forced video codec: ffwmv3vdpau
Forced video codec: ffvc1vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 256.0 kbit/16.67% (ratio: 32000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1440x1080 => 1920x1080 Planar YV12 
[h264 @ 0x88baa00]Reference 8 >= 2 0.039  10/ 10 ??% ??% ??,?% 5 0                                                                
[h264 @ 0x88baa00]error while decoding MB 74 46, bytestream (5123)
A:   2.6 V:   1.4 A-V:  1.198 ct:  0.785  59/ 59 99% 13%  2.7% 50 0                                                               

           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A:  15.2 V:   6.7 A-V:  8.478 ct:  6.090 377/377 101%  9%  2.8% 366 0                                                             
Exiting... (Quit)
in this last situation the video is displayed, but it's slow and my CPU is 100% utilized.

Please advise.
Andrew

Last edited by DBabo; 06-26-11 at 08:52 PM. Reason: added linux version.
DBabo is offline   Reply With Quote
Old 06-27-11, 03:33 PM   #2
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: mplayer -vc - no vdpau

To use vdpau you have to have mplayer compiled with vdpau video output:
Your machine have mplayer compiled without vdpau output:
Code:
[az@server Downloads]$ mplayer -vo help | grep vdp
[az@server Downloads]$
Having just vdpau accelerated codecs is not enough. You have to have vdpau output to close the decoding chain by displaying decoded movie.

My mplayer with vdpau compiled in output:
Code:
zbyszek@desktop $ mplayer -vo help | grep vdp
        vdpau   VDPAU with X11
You use: Scientific Linux release 6.0 (Carbon) - this is RHEL6 clone designed for server purposes/scientific workstation. This is probably the reason why mplayer was build without vdpau. Maybe using any external repository with vdpau mplayer will help.

Try any popular desktop distribution - ask people here (better in new topic) what distros have mplayer with vdpau out of the box.
zbiggy is offline   Reply With Quote
Old 06-27-11, 11:07 PM   #3
DBabo
Registered User
 
Join Date: Dec 2010
Posts: 15
Default Re: mplayer -vc - no vdpau

Quote:
Originally Posted by zbiggy View Post
To use vdpau you have to have mplayer compiled with vdpau video output:
Your machine have mplayer compiled without vdpau output:
Code:
[az@server Downloads]$ mplayer -vo help | grep vdp
[az@server Downloads]$
Having just vdpau accelerated codecs is not enough. You have to have vdpau output to close the decoding chain by displaying decoded movie.

<skip>
Uhh, stupid me, thought that changing just one top line in the spec file of srpm will do the trick. Had to dig deeper.

zbiggy,
thank you very much for pointing to my error. I explicitly added vdpau to the call of the configure and now i enjoy my movies with ~20% CPU usage.

Full disclosure:
I run redhat clone (Scientific Linux 6) it's rpm based. I got mplayer src.rpm (mplayer-1.0-0.46.svn20100703.el6.src.rpm) from rpmforge.
To enable the vdpau i had to modify the spec file. Here is the diff:
Code:
diff -h mplayer.spec mplayer.spec00
19a20
> %define _without_dvdnav 1
144c145
< %{?_without_vdpau:BuildRequires: libvdpau-devel}
---
> %{!?_without_vdpau:BuildRequires: libvdpau-devel}
247d247
< %{?_without_vdpau:--enable-vdpau} \
hope it will be useful to someone.

Please mark as "resolved"
DBabo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.