Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-17-11, 04:40 AM   #49
bastian_knight
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: Desktop freeze with 270.x/275.x drivers, KDE 4 and Compiz

275.09.07 didn't fix the problem on GeForce 7300 LE.
bastian_knight is offline   Reply With Quote
Old 06-19-11, 09:10 AM   #50
mike501
Registered User
 
Join Date: Jun 2011
Posts: 2
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

Until NVIDIA gets around to fixing this issue, the only options seems to go back to driver version 260.19.44 - as long as you don't require the support for newer X.Org servers.

To get the kernel module to compile with kernel 2.6.39, you need to apply the attached patch.

This worked for me on an openSUSE-11.4 system running kernel 2.6.39.1 and X.Org 1.9.3.
Attached Files
File Type: gz NVIDIA-Linux-x86_64-260.19.44-k2.6.39.diff.gz (393 Bytes, 144 views)
mike501 is offline   Reply With Quote
Old 06-19-11, 01:11 PM   #51
karabaja4
Registered User
 
Join Date: Jun 2011
Posts: 2
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I also have this bug on my 7300GT... any composite desktop or 3D application stalls within seconds.

Using driver 275.09.07.

I also tried using legacy 173.14.30 but it freezes exactly the same.
karabaja4 is offline   Reply With Quote
Old 06-24-11, 06:03 PM   #52
rang501
Registered User
 
Join Date: Apr 2011
Posts: 9
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I really hope that someone finally fixes it and they have not forgot us with 7xxx cards.
rang501 is offline   Reply With Quote
Old 06-25-11, 05:28 PM   #53
mdeggers
Registered User
 
Join Date: Apr 2003
Posts: 17
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I'm running the following on Fedora 15 and not experiencing any problems:

OS: Fedora 15 2.6.38.8-32.fc15.i686
Video: 512 MB 7600 GS AGP 4 (overclocked)
Screen: Samsung SyncMaster 23" at 1680x1050x24
Driver: 275.09.07
KDE: 4.6.3-1
Xorg: 1.10.2-1

I am running the default settings for desktop effects, which include:

Composting Type: OpenGL
OpenGL Mode: Texture from PixMap
Enable Direct Rendering: Checked
Use VSync: Checked

I have some tweaks set up in /etc/modprobe.d/nvidia (linked to
/etc/modprobe.d/nvidia.conf) which enable some AGP options.

options nvidia NVreg_EnableAGPFW=1 NVreg_EnableAGPSBA=1

I have the following set up to run from ~/.xinitrc

nvidia-settings -a GPUOverclockingState=1 \
-a GPU2DClockFreqs=432,345 \
-a GPU3DClockFreqs=432,345
nvidia-settings -a InitialPixmapPlacement=2
nvidia-settings -a GlyphCache=1

In my xorg.conf file under Section "ServerFlags" I have:

Option "Xinerama" "0"
Option "AIGLX" "on"

In my xorg.conf file under Section "Device" I have:

Option "Coolbits" "1"
Option "AddARGBGLXVisuals" "True"
Option "BackingStore" "True"

There are some issues reported in Xorg.0.log that I probably need to address (unused
options, cannot connect to the ACPI daemon), but I don't think they bother my current
operation.

The most notable things I see compared to other people:

I'm running Xorg server 1.10.2-1
I'm running a 7600 GS (as opposed to a 7200/7300) card
I'm running a 32 bit OS

For those experiencing the recent Fedora 15 Gnome 3 shell problems, the upgrade sitting in
testing (3.0.2-4) seems to have addressed those (Fedora) issues.

. . . . just my two cents.
mdeggers is offline   Reply With Quote
Old 06-27-11, 10:37 AM   #54
SanskritFritz
Registered User
 
Join Date: Apr 2011
Posts: 15
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

Quote:
Originally Posted by mdeggers View Post
I'm running a 7600 GS (as opposed to a 7200/7300) card
Exactly. I fail to see the point you are trying to make.
SanskritFritz is offline   Reply With Quote
Old 06-29-11, 08:22 AM   #55
rando
Registered User
 
Join Date: Jun 2011
Posts: 1
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

Same problem here running kubuntu 11.04 (7300 go) .

Upgrading to the packages in this ppa:

https://launchpad.net/~xorg-edgers/+archive/ppa

(nvidia 275.09.07, Xorg 1.10.2)

didn't help at all, problem persists.

Does anyone know a trouble-free (ppa?) way of downgrading to 260.x and xorg 1.9 ?
rando is offline   Reply With Quote
Old 06-30-11, 06:16 PM   #56
karabaja4
Registered User
 
Join Date: Jun 2011
Posts: 2
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

This still happens on newest 280.04 drivers with xorg-server 1.10.2.
I also tried xorg-server 1.10.99.901 but couldn't get it up.

Please nvidia, fix this in next offical release
karabaja4 is offline   Reply With Quote

Old 07-26-11, 03:11 PM   #57
ma.tangaro
Registered User
 
Join Date: Dec 2008
Posts: 8
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

any news on this side?
Please nvdia give us an answer!
ma.tangaro is offline   Reply With Quote
Old 07-26-11, 04:57 PM   #58
majlo
Registered User
 
Join Date: Jun 2009
Posts: 13
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

I'm out, I bought new card.... from AMD. No tearing, open source driver, I'm happy.
Bye.
majlo is offline   Reply With Quote
Old 08-07-11, 02:05 AM   #59
SanskritFritz
Registered User
 
Join Date: Apr 2011
Posts: 15
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

Quote:
Originally Posted by majlo View Post
I'm out, I bought new card.... from AMD. No tearing, open source driver, I'm happy.
Bye.
Maybe you're still reading this, which AMD card exactly? I'm having similar plans.
SanskritFritz is offline   Reply With Quote
Old 08-07-11, 07:21 AM   #60
rang501
Registered User
 
Join Date: Apr 2011
Posts: 9
Default Re: Desktop freeze with 270.x drivers, KDE 4 and Compiz

kde 4.7, nvidia 280.13, still happens. Something have been changed in kde 4.7 and blurring works. After enabling direct rendering, everything still freezes.
rang501 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.