Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-11-11, 10:16 AM   #1
flomuc
Registered User
 
Join Date: Jul 2011
Posts: 2
Exclamation Linux for Tegra release 12 alpha 1 XServer Problems

Hi,

I just tried to get the Linux for Tegra release 12 alpha 1 on my Harmony running. Flashing, setting up the rootfs and also booting the system works well!

However, I am unable to show anything on my HDMI attached Display. The reason for this seems to be known: Login via console or ssh and start an X session. Here comes the problem: I could not get the X server to launch;( I attached the log from the X server.

Hope anybody could help to solve this.
Thanx in advance...
Attached Files
File Type: log Xorg.0.log (6.3 KB, 64 views)
flomuc is offline   Reply With Quote
Old 07-11-11, 11:32 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Linux for Tegra release 12 alpha 1 XServer Problems

You're using the wrong kernel and/or kernel config. First, you need to compile the kernel with support for consoles. I think the relevant config options are
CONFIG_HW_CONSOLE=y
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
and maybe
CONFIG_VT_HW_CONSOLE_BINDING=y

Second, you need to use a kernel that has the CONFIG_TEGRA_DC_EXTENSIONS option. Are you using the recommended chromeos-2.6.38 kernel and config provided in the L4T release package?
AaronP is offline   Reply With Quote
Old 07-12-11, 09:10 AM   #3
flomuc
Registered User
 
Join Date: Jul 2011
Posts: 2
Default Re: Linux for Tegra release 12 alpha 1 XServer Problems

Hi,

thanks for the answer! I flashed the kernel provided in the package and did not build my own. I followed the instructions provides by the pdf document in the L4T.ER1 release.

Anyway, I just re-compiled the kernel (chromeos-2.6.38 from GIT) with all config options you recommended. Still the same problem...
Find attached a kernel log (don't know if that helps).

By the way: there seems to be no support for the onboard ethernet controller!? At least in both kernel I've tried...

Thanx.
Attached Files
File Type: log kernel.log (33.1 KB, 53 views)
flomuc is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:36 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.