Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-22-11, 02:16 AM   #1
mpkossen
Registered User
 
Join Date: Jul 2011
Posts: 1
Default GT 555M Device ID

I've recently gotten a new notebook with an nVidia GT 555M in it (Optimus-enabled with a Core i7). I'm running Ubuntu and I've installed bumblebee on it (which installed the nVidia 275.19 drivers). Even though the nVidia website lists the card as supported, but it appears not to be. Unfortunately, there are 2 types of the GT 555M: the GDDR3 and the GDDR5 versions. I've got the GDDR5 version. I'm unsure as to which is supported, but I guess it's not mine. Why? Because the kernel module doesn't get inserted. Upon trying that (via an acpi_call), it throws the following error:

Code:
FATAL: Error inserting nvidia_current (/lib/modules/2.6.38-10-generic/updates/dkms/nvidia-current.ko): No such device
Here's what my syslog says:

Code:
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   12.659741] acpi_call: Call successful: 0x0
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005611] nvidia 0000:01:00.0: power state changed by ACPI to D0
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005614] nvidia 0000:01:00.0: power state changed by ACPI to D0
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005621] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005627] nvidia 0000:01:00.0: setting latency timer to 64
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005631] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005655] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0dce) installed
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005655] NVRM: in this system is not supported by the 275.19 NVIDIA Linux
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005656] NVRM: graphics driver release.  Please see 'Appendix A -
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005656] NVRM: Supported NVIDIA GPU Products' in this release's README,
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005657] NVRM: available on the Linux graphics driver download page at
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005657] NVRM: www.nvidia.com.
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005662] nvidia 0000:01:00.0: PCI INT A disabled
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005667] nvidia: probe of 0000:01:00.0 failed with error -1
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005681] NVRM: The NVIDIA probe routine failed for 1 device(s).
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.005682] NVRM: None of the NVIDIA graphics adapters were initialized!
Jul 22 08:48:09 mpkossen-W150HRM kernel: [   13.066740] acpi_call: Calling \_SB.PCI0.PEG0.PEGP._OFF
Jul 22 08:48:11 mpkossen-W150HRM kernel: [   14.558834] acpi_call: Call successful: 0x0
I've been looking at the devide support details for the nVidia drivers. The GT 555M is listed with Device ID 0x0DCD (Source: http://uk.download.nvidia.com/XFree8...rtedchips.html). My device, however, has device ID 0x0DCE. This Device ID is known to nVidia (Source: http://developer.download.nvidia.com..._ids_may11.txt). However, the drivers thus appear not to be available for my device.

Does anybody know anything about drivers supporting my device? Or where I can find a new nVidia driver version which does support my device? Or whom I can contact to request support for my device? I'm a bit lost here and Google hasn't been much of a friend in this case.

I appreciate any help I can get! So, thank you in advance for any help!
mpkossen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.