Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-12-03, 01:57 AM   #1
tierra
Registered User
 
Join Date: Dec 2003
Posts: 2
Send a message via ICQ to tierra
Default X Lock up with Geforce FX 5200

I'm currently in X using the default nv driver in 1280x1024 resolution with my monitor refresh rates set according to manufacturer specs. But when I switch the driver out to nvidia and enable glx in XF86Config, X locks up with a black screen, and the only thing I can do is <ctrl><alt><del> to restart (not even <ctrl><alt><bksp> works). I've tried with the latest stable nvidia drivers, and also with the beta drivers (4620). I've also tried setting my resolution down also as the XFree86 log file shows it stopping at "(II) NVIDIA(0): Setting mode "1024x768"".

I'm running Gentoo Linux (2.4.20-gentoo-r8 kernel)
AthlonXP 2400 (2.0ghz)
KT133 chipset
Code:
root@sensei root # cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module  1.0-4496  Wed Jul 16 19:03:09 PDT 2003
GCC version:  gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r3, propolice)
root@sensei root # cat /proc/driver/nvidia/cards/0
Model:           GeForce FX 5200
IRQ:             11
Video BIOS:      ??.??.??.??.??
Card Type:       AGP
The logs show Xfree being able to load glx, and the nvidia driver without a problem, along with being able to set 8X AGP (which the MB does support).
Attached Files
File Type: log xfree86.0.log (25.9 KB, 125 views)
tierra is offline   Reply With Quote
Old 12-12-03, 09:44 AM   #2
rednuht
GeForce FX5600 (1.0-5336)
 
rednuht's Avatar
 
Join Date: Sep 2003
Location: uk
Posts: 164
Default try the readme file

search the readme file (a gold mine of information) for "nopentium" that made my Athlon Kt133 setup work
rednuht is offline   Reply With Quote
Old 12-12-03, 10:03 PM   #3
tierra
Registered User
 
Join Date: Dec 2003
Posts: 2
Send a message via ICQ to tierra
Default

noted, and added, but still didn't work. I'll be keeping that in there though, thanks.

On another note, I realized I forgot to comment out GLX in XF86Config the last time I changed it back to the nv driver, and it still booted up fine. XScreenSaver doesn't give me GLX errors, but still doesn't draw GL to the screen either. But probably means though that it doesn't have anything to do with GLX either.
tierra is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 04:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.