Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-14-03, 05:15 PM   #1
joeljkp
Registered User
 
Join Date: Dec 2002
Posts: 7
Default Lots of graphics lag when playing games

I've noticed then when I play 3d games, I get frequent distinct periods of really slow motion, almost like the graphics are lagging. The effect is if the game had entered some kind of slow-motion mode for a few seconds before it snaps back to normal speed. This occurs freqently, at regular intervals, and lasts for a few seconds each time. There is no apparent relationship to the complexity of the environment when it happens. It happens the same way when playing at 1600x1200 with all details turned on as when playing at 1024x768 with all details turned off. It also happens with several different games, including Max Payne through WineX and native Unreal Tournament. And yes, I know Max Payne has a slow-motion mode, but this isn't related.

I'm using the 4496 drivers on Gentoo with kernel 2.4.23. I've tried both agpgart and nvidia's agp driver, and the problem is still there. I have a Mobile Pentium 4 3.06 Ghz with a GeForce FX Go5200.

There's no relation to background processes either, as it happens when running a full-featured gnome session as well as a bare twm session with no bacground processes.

Does anyone have any ideas?

Thanks in advance.
joeljkp is offline   Reply With Quote
Old 12-14-03, 05:31 PM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Is your kernel compiled with support for CPU freq scaling? If it were to scale it certainly could create that effect, although it shouldn't while under loads (no guarantees).
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 12-14-03, 05:47 PM   #3
joeljkp
Registered User
 
Join Date: Dec 2002
Posts: 7
Default

Hmm, perhaps. How do I find out? What option is this?

Thanks for the advice.
joeljkp is offline   Reply With Quote
Old 12-14-03, 06:01 PM   #4
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

These are the all the kernel config variables that control the scaling (I think, I grep'd em afterall).

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_PROC_INTF=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_24_API=y

The option for CPU scaling is in the section (in menuconfig):
Processor type and features --->
CPU Frequency scaling --->

If your kernel source / config isn't available, check if the config is included in the running kernel .config support (you'll find it at /proc/config.gz). There may be other indicators about this in the proc filesystem, but I do not know how to identify or control the scaling, only turn if off.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 12-14-03, 06:31 PM   #5
joeljkp
Registered User
 
Join Date: Dec 2002
Posts: 7
Default

Well, I don't have a CPU frequency scaling menu under Processor type and features, and I don't have those lines in my .config.

I do have ACPI compiled as a module, but those modules aren't loaded.
joeljkp is offline   Reply With Quote
Old 12-14-03, 08:02 PM   #6
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Hmm, thats a 2.4.22 kernel those come from, I haven't built the 2.4.23, so its possible they moved the configuration (but I'm sure its there somewhere). I've been using 2.6 for some time now, you might give it a try if you don't get any other things to look for.. I really have no idea since background processes aren't to blame (and assuming the hardware is actually still good).
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 12-14-03, 08:32 PM   #7
joeljkp
Registered User
 
Join Date: Dec 2002
Posts: 7
Default

Yeah, I guess I'll see what 2.6 brings. This all works fine under Windows, so it's not a hardware problem.
joeljkp is offline   Reply With Quote
Old 12-14-03, 08:40 PM   #8
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Be sure to select the "Preemptible kernel" option in 2.6, its been off by default in alot of the versions I've built but is definitely an effective addition.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote

Old 12-14-03, 10:15 PM   #9
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

You could try installing the 4620 beta drivers. They removed that 1-2 sec pause in UT2K3. As it reponds much faster now with those drivers. Note of course that these are only beta's, but they solved that problem for me.

There's a sticky in the main section to those drivers.

Wolf

edit: Better still here is the link:
http://www.nvnews.net/vbulletin/show...threadid=21848
Wolfman [TWP] is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 09:43 AM

All times are GMT -5. The time now is 10:34 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.