Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-02-11, 10:16 AM   #13
brebs
Registered User
 
Join Date: Jul 2007
Posts: 38
Default Re: New system and ut2004 stutters

Quote:
Originally Posted by kriko View Post
report
It's already been reported about a million times, spanning several years, e.g. this 60-page thread.

The stutter-free workaround is DirectX-only:

Code:
UseHardwareTL=False
UseHardwareVS=True
MaxPixelShaderVersion=1
Apparently a problem around dynamic lighting, with nvidia's drivers (ATI cards don't have this problem, apparently).

Care to install Windows' UT2004 inside WINE running on Linux, and try with that DirectX setting UseHardwareTL=False?
brebs is offline   Reply With Quote
Old 06-02-11, 11:27 AM   #14
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: New system and ut2004 stutters

@brebs
I've tried under wine and it stutters, even with those settings - probably
because DX gets translated into OpenGL calls and there is the problem.

It works smooth here in windows under directX without any tweaking, however OpenGL is same stuttery under both OS.
kriko is offline   Reply With Quote
Old 06-04-11, 01:25 PM   #15
khetzal
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: New system and ut2004 stutters

With my ubuntu, i have to replace the libsdl and the lib openal from ut2004 with the ones from ubuntu, and all work perfectly after that (simply remove or backup openal.something.so and libsdl.so for your ut2004/System folder by a link to the ones from the os)
khetzal is offline   Reply With Quote
Old 06-04-11, 02:25 PM   #16
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: New system and ut2004 stutters

This is the first thing I've done - you haven't stated your card.
However this seems a driver issue on certain model, multiple OS.
kriko is offline   Reply With Quote
Old 06-05-11, 06:56 AM   #17
Henni
Registered User
 
Join Date: Mar 2004
Posts: 3
Default Re: New system and ut2004 stutters

Just a hunch - but could it be that a cpufreq governor is changing the frequency of the CPU while you are playing the game?
Disable the ondemand governor and set the CPU to highest frequency (either by changing to performance governor or userspace governor and setting to highest freq.). If that helps you can write a script that changes the frequency (where I believe you won't need the highest one - probably the second lowest should be enough) for the game or try to use the conservative governor.
Henni is offline   Reply With Quote
Old 09-24-11, 10:42 AM   #18
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: New system and ut2004 stutters

I've traced the problem to fixed pipeline lightning with gDEBugger. Disabling all static pipeline lightning operations results in normal smooth gameplay - guns only loose light reflections and they are dark.

I've reported this to customer help as feedback #110924-000031.
kriko is offline   Reply With Quote
Old 09-27-11, 04:23 AM   #19
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: New system and ut2004 stutters

There are some threads about a regression in opengl code on linux and windows 7 (only windows 7?)
Nvidia devs said they have reproduced the issue and are working on it, but I don't know if this is related.

http://www.nvnews.net/vbulletin/show...2&postcount=21
kokoko3k is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.