Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-16-11, 11:33 AM   #25
valdis
Registered User
 
Join Date: Apr 2003
Posts: 48
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Confirming - downgrading from glibc 2.14.90 back to 2.14. fixed the SIGSEGV issue.
valdis is offline   Reply With Quote
Old 09-28-11, 09:15 AM   #26
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Post Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Hello!

I just upgraded my Debian's X.org to v11.1 today through its daily apt-get update and upgrade. I also recompiled the latest NVIDIA driver (v280.13). X wouldn't start because of it/them. I searched the logs (attached AntDebianBoxLogs09282011.txt including its apt-get results), this forum, saw this forum thread, and added this part to my /etc/X11/xorg.conf file:

Section "ServerFlags"
Option "IgnoreABI" "true"
EndSection

I was able to startx from my bash command line to start my old KDE v3.5.10 with Compiz. So far, things seem to work even in Google Earth, Mozilla's SeaMonkey, terminals, etc.?

Are there any updates to this issue? Does http://us.download.nvidia.com/XFree8...x86-285.03.run fix this problem without this work around? Its release notes didn't mention about this issue.

Thank you in advance.
Attached Files
File Type: txt AntDebianBoxLogs09282011.txt (11.6 KB, 110 views)
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 09-29-11, 03:48 AM   #27
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

@ant:
Quote:
*Added support for xserver ABI 11 (xorg-server 1.11).
*Fixed a bug that caused the GLSL built-in uniforms gl_FrontMaterial and gl_BackMaterial to not be updated properly when calling glMaterial from a display list.
*Fixed an error handling bug that caused the OpenGL driver to crash while running certain WebGL applications.
*Fixed a bug in VDPAU that caused a glibc assertion when a call to VdpDeviceCreateX11 failed in certain ways.
Release Notes for 275.28
Licaon is offline   Reply With Quote
Old 09-29-11, 08:21 AM   #28
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Question Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by Licaon View Post
@ant:
Release Notes for 275.28
Huh? Why doesn't v280.13 work then that is newer than 275.28?
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 09-29-11, 08:35 AM   #29
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by ant View Post
Huh? Why doesn't v280.13 work then that is newer than 275.28?
Wrong. It's not newer.
Gusar is offline   Reply With Quote
Old 09-29-11, 08:42 AM   #30
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by Gusar View Post
Wrong. It's not newer.
Um, bigger numbers are newer than smaller numbers for version numbers. Like v1 versus/vs. v2.
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 09-29-11, 09:13 AM   #31
Ahmad Samir
Registered User
 
Join Date: Nov 2009
Posts: 13
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by ant View Post
Um, bigger numbers are newer than smaller numbers for version numbers. Like v1 versus/vs. v2.
Normally, yes, but the 275.28 driver was released after 280.13 as the 275.28 is from the new long-lived branch release c.f. http://www.nvnews.net/vbulletin/show...70&postcount=7
Ahmad Samir is offline   Reply With Quote
Old 09-29-11, 09:40 AM   #32
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by Ahmad Samir View Post
Normally, yes, but the 275.28 driver was released after 280.13 as the 275.28 is from the new long-lived branch release c.f. http://www.nvnews.net/vbulletin/show...70&postcount=7
Ah interesting. It's sure confusing! I wonder why 280 didn't get this fix.
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote

Old 10-01-11, 12:54 AM   #33
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

ETA on an official stable driver that's been fixed?
primerib is offline   Reply With Quote
Old 10-01-11, 06:47 AM   #34
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by primerib View Post
ETA on an official stable driver that's been fixed?
There is already one: 275.28
Gusar is offline   Reply With Quote
Old 10-01-11, 09:00 AM   #35
towo|
Registered User
 
Join Date: Feb 2007
Posts: 113
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

I wouldn't call that realy a fix, since there are massive slowdowns and high cpu usage in x with this driver and xserver 1.11.x.
towo| is offline   Reply With Quote
Old 10-01-11, 07:00 PM   #36
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: 285.03: X Server 1.11.0 IgnoreABI required to work

Quote:
Originally Posted by towo| View Post
I wouldn't call that realy a fix, since there are massive slowdowns and high cpu usage in x with this driver and xserver 1.11.x.
I haven't noticed anything, it works fine here. This is on an old 6600 though. Tomorrow I'll get to see how a Fermi card works with 275.28 and xorg-1.11.1
Gusar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.