Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-01-11, 12:45 PM   #1
Jailbird
Registered User
 
Join Date: Oct 2011
Posts: 3
Unhappy Can no longer use native 2560x1600 resolutin of U3011 after upgrading(?) to GT520

Hi, all.

Thanks in advance for any help. I used to have a 7600GS-based card on Kubuntu Natty (11.04) and it saw and used 2560x1600 on my Dell U3011 with no problems. I'm sorry that I can't remember which NVidia driver was in use, I've re-installed since then. I do think (vaguely) that there were no specific mode lines in xorg.conf back then, but I can't prove it.

Now, I recently purchased an ASUS, GT520 based card (why that one? it's the most recent fanless/silent one I found.). The mode the NVidia driver is set to is nvidia-auto-select but 2560 x 1600 is NOT an option. That much is clear from the logs, (bug report attached) but I'm unsure as to how to debug it.

I've tried a number of things (note that the last attempt was a full re-install of Natty, so it wiped out anything prior)
1) save the monitors EDID (it had 2560x1600!) , force x.org to use it
2) re-install this old driver versions, new ones, etc. The new ones do say they support my GT520.
3) Decided I'm not savvy enough with uninstalling and reinstalling NVidia drivers and the appropriate kernel-based pieces, so....let's let the Natty installer handle that Full re-install.

I've noticed that others in the forum seem to have the Dell U3011 detected at its native resolution....

Oh, I'm using the DVI connection and a DVI cable, so I think I've got all the appropriate/necessary dual-link goodness in place.

Any help, or other information that might help?
It seems like it should "Just Work" since it used to, right?
The new card is a complete superset of capabilities of the old card, right?

Thanks,

-Jailbird
Attached Files
File Type: gz nvidia-bug-report.log.gz (40.1 KB, 50 views)
Jailbird is offline   Reply With Quote
Old 10-01-11, 02:07 PM   #2
Jailbird
Registered User
 
Join Date: Oct 2011
Posts: 3
Default Re: Can no longer use native 2560x1600 resolutin of U3011 after upgrading(?) to GT520

A quick follow-up:

A different search , about the card itself (!) turned up what seems to be a relevant thread:
http://www.nvnews.net/vbulletin/showthread.php?t=163625

I'll go about seeing if there's an easy PPA or something for newer NVidia drivers for Natty and report back. It's worth a shot.
Jailbird is offline   Reply With Quote
Old 10-01-11, 02:34 PM   #3
Jailbird
Registered User
 
Join Date: Oct 2011
Posts: 3
Smile Re: Can no longer use native 2560x1600 resolutin of U3011 after upgrading(?) to GT520

Solved!

Thanks to the thread I found, I added the x-swat PPA for Natty and upgraded to the 280.13 drivers.

SWEET.

A final snippet from /var/log/Xorg.0.log

Code:
[    24.470] (II) NVIDIA(0): Validated modes:
[    24.470] (II) NVIDIA(0):     "nvidia-auto-select"
[    24.470] (II) NVIDIA(0): Virtual screen size determined to be 2560 x 1600
[    24.493] (--) NVIDIA(0): DPI set to (101, 101); computed from "UseEdidDpi" X config
Well since, I took up space on nvnews' hard drives, I hope this can at least be of help to someone else later!

-Jailbird
Jailbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.