Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-10-11, 02:20 AM   #1
NickLion
Registered User
 
Join Date: Jun 2011
Location: Ukraine
Posts: 8
Default Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

Good day!
I have a problem with installing 285.05.09.
My OS is openSuSE 11.4 with Tumbleweed, so I have kernel 3.0.4. Now is nvidia 280.13 drivers installed.
What I do:
0) go to tty and run 'init 3' to stop kdm (and Xorg)
1) run NVIDIA-Linux-x86_64-285.05.09.run (downloaded from site), all seems 'ok', installer log see in attachment
2) do nvidia-bug-report.sh (see nvidia-bug-report.log.1-before-no-x.gz)
3) run 'init 5' or 'startx' - it's looks 'ok' (see nvidia-bug-report.log.2-after-no-restart.gz)
4) restart computer.... and no X at all (see nvidia-bug-report.log.3-after-restart.gz)
So as I see, after restart old kernel module (from 280.13) is loaded, and new libraries can't work with it.
Why it's not replaced with new one?

Hope this info is helpful. Or maybe any other info needed?
Attached Files
File Type: log nvidia-installer.log (58.1 KB, 33 views)
File Type: gz nvidia-bug-report.log.1-before-no-x.gz (74.1 KB, 33 views)
File Type: gz nvidia-bug-report.log.2-after-no-restart.gz (96.7 KB, 35 views)
File Type: gz nvidia-bug-report.log.3-after-restart.gz (80.1 KB, 39 views)
NickLion is offline   Reply With Quote
Old 10-10-11, 02:35 AM   #2
towo|
Registered User
 
Join Date: Feb 2007
Posts: 113
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

make sure, there is no nvidia-package installed from any suse-repo
boot to tty
rmmod nvidia
update-initramfs
startx
towo| is offline   Reply With Quote
Old 10-10-11, 08:13 AM   #3
NickLion
Registered User
 
Join Date: Jun 2011
Location: Ukraine
Posts: 8
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

I've never installed nvidia rpms from repo (in this OS installation)
NickLion is offline   Reply With Quote
Old 10-10-11, 10:43 AM   #4
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

I didn't read the logs, but you can try this:

Edit the file "/etc/modprobe.d/99-local.conf" adding the following:
Code:
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
Then run "mkinitrd". Reboot.
DeiF is offline   Reply With Quote
Old 10-10-11, 01:43 PM   #5
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

Quote:
Originally Posted by NickLion View Post
So as I see, after restart old kernel module (from 280.13) is loaded, and new libraries can't work with it.
Why it's not replaced with new one?

Hope this info is helpful. Or maybe any other info needed?
Sounds like you didn't run 280.13's uninstall option (--uninstall) before installing the new ones.
Deanjo is offline   Reply With Quote
Old 10-11-11, 01:16 AM   #6
NickLion
Registered User
 
Join Date: Jun 2011
Location: Ukraine
Posts: 8
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

Quote:
Originally Posted by Deanjo View Post
Sounds like you didn't run 280.13's uninstall option (--uninstall) before installing the new ones.
Yes. But with previous versions upgrade proceeded well. Installation of 285.05.09 detects old version and says that 280.13 would be removed.
NickLion is offline   Reply With Quote
Old 10-11-11, 12:32 PM   #7
Nv5-SMURF
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

Its said before u need to do 'mkinitrd' , why cuz in /boot is a initrd-file wich has the nvidia driver inside wich is loaded at boot

if u try to start X in init3 and do xinit u get bounced back in console with the remark older driver version incompatible with the library version

u should check also /etc/sysconfig/kernel if NO_KMS_IN_INITRD="yes" is set
Nv5-SMURF is offline   Reply With Quote
Old 10-11-11, 12:34 PM   #8
Nv5-SMURF
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

And yes unfortunaly u must reboot

Last edited by Nv5-SMURF; 10-11-11 at 12:38 PM. Reason: double post
Nv5-SMURF is offline   Reply With Quote

Old 10-14-11, 02:03 AM   #9
NickLion
Registered User
 
Join Date: Jun 2011
Location: Ukraine
Posts: 8
Default Re: Can't upgrade from 280.13 to 285.05.09 (openSuSE Tumbleweed)

Quote:
Originally Posted by Nv5-SMURF View Post
Its said before u need to do 'mkinitrd' , why cuz in /boot is a initrd-file wich has the nvidia driver inside wich is loaded at boot

if u try to start X in init3 and do xinit u get bounced back in console with the remark older driver version incompatible with the library version

u should check also /etc/sysconfig/kernel if NO_KMS_IN_INITRD="yes" is set
Why this is needed in new version and wasn't needed in previous upgrades?
NickLion is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.