Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-04-02, 06:29 AM   #1
brand
Registered User
 
Join Date: Oct 2002
Posts: 5
Lightbulb Reproducable Hard Lockup - RH 8.0 & 3123

I can lock my system up at will under RH 8.0 and the 3123 kernel module/GLX. Here's my system:

Athlon XP 2100+
Gigabyte GZ-7VRXP (VIA KT333 chipset)
512 megs
Gainward geforce 4 4400
Sound is (ack!) onboard Creative CT5880
Running RedHat 8.0.

cat /proc/driver/nvidia/agp/status:
Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

I've tried running the stock RH 2.4.18-14 and my own vanilla 2.4.19 with the same results. Nvidia stuff compile from source rpms without issue. Okay, the reproducable lock is done by running the GFlux (which is part of XScreenSaver ) screensaver that comes with Gnome under RH 8.0. I'm sure GFlux comes with alot of other things too, so maybe someone else can produce this. After 5-10 minutes of running GFlux, my system locks hard and is gone from the network. CPU temp is okay - mid 60's C. System has good ventilation and power. I ran the UT 2003 demo great on this hardware, though I had Gentoo 1.2 before I put RH 8 on. Now running UT 2003 (retail) locks hard after 5 minutes or so of play, and this screensaver thing.

Anyone have a remotely similar experience?

brand
brand is offline   Reply With Quote
Old 10-04-02, 08:28 AM   #2
becoming
Guest
 
Posts: n/a
Default

pass mem=nopentium to your kernel at boot.
  Reply With Quote
Old 10-04-02, 10:05 AM   #3
brand
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

I've done mem=nopentium, still locks up. That and isn't that fixed in 2.4.19?

brand
brand is offline   Reply With Quote
Old 10-04-02, 11:13 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Which AGP handler code are you using, nVidia's or the kernel's agpgart?

You choose between them in your XF86Config-4 file, with Option "NvAgp" "<number>", where <number> goes from 0 to 3. 3 is the default if there is no option specified, and 3 is what I run my system at (same motherboard chipset as you). If you're using anything else, you might want to try 3.

Otherwise, if you're passing the option "NVreg_EnableVia4x" to the NVdriver, see if not doing that helps at all. Unload the driver, change the system (modules.conf file) so it doesn't pass that option, and reload the driver, and see if that helps at all. Although I do pass it, and it works just fine, so I'm not sure if it'll help or not.

When it locks, double-check the temperature of the video card (I assume the fan will still be running? Just feel the temp of the air it's blowing, as compared to normal use). I've seen a couple times where that can cause lockups, even if the CPU is cool.

Edit: Does the UT 2003 demo still work fine? Could you install it again to check?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-04-02, 11:28 AM   #5
brand
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

Thanks for the tips so far... I'm at work or I'd post my entire XF86Config, but it's pretty standard. I explicitly have it use Nvidia's AGP handler with Option "NvAGP" "1".

I don't know if NVdriver is being passed "NVreg_EnableVia4x" or not. Same goes for the video card temperature and the UT2k3 demo. I'll check those 3 things later tonight and get back with the results. Thanks again...

brand
brand is offline   Reply With Quote
Old 10-04-02, 11:02 PM   #6
brand
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

Okay, 2 out of 3 answers so far....

NvReg_EnablerVia4x is not being passed to NVdriver.

Unreal Tournament 2003 DEMO holds up really well. Damn well. Damn.

Haven't checked vid card temp yet. Will do tomorrow.

There's still the GFlux thing tho...

brand
brand is offline   Reply With Quote
Old 10-05-02, 03:48 PM   #7
brand
Registered User
 
Join Date: Oct 2002
Posts: 5
Default

Alright! Fixed it!

First though, my vid card temp never got very high. It was warm, but nothing unusual.

The problem was something I should have tried a looong time ago, and I feel a little dumb that I didn't. For some reason I didn't think it would have any reason to break things. I was using TwinView with two monitors. Here is what my XF86Config "Device" section:

Section "Device"
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
Option "NvAGP" "1"
Option "UseEdidFreqs" "true"
Option "TwinView" "true"
Option "MetaModes" "1600x1200, 1600x1200; 1280x1024, 1280x1024; 1024x768, 1024x768; 1024x768, NULL; 800x600, NULL; 640x480, NULL"
EndSection


I commented out the TwinView and MetaModes options and I play forever. The GFlux screensaver crashes still, but just drops to a window saying the window was destroyed unexpectedly, so I'm presuming theres a bug with GFlux too.

Thanks for the help to everyone who kicked in with ideas...

brand
brand is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba hatches a hybrid hard drive News Archived News Items 0 09-26-12 12:20 PM
Saturday Crapshoot: Hard Time News Gaming Headlines 0 07-14-12 05:10 AM
GeForce4 hard lockup with games under Windows XP Snap NVIDIA GeForce 7, 8, And 9 Series 6 09-27-02 02:37 PM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM

All times are GMT -5. The time now is 08:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.