Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-05-02, 07:59 AM   #1
dmp
Guest
 
Posts: n/a
Default RH 8 Problem when insmod'ing NVdriver

I have compiled the kernel module src rpm on RH 8 ok, but when I try to insmod it I get the following error:

[root@localhost root]# insmod NVdriver
Using /lib/modules/2.4.18-14/kernel/drivers/video/NVdriver
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: The module you are trying to load (/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver) is compiled with a gcc
version 2 compiler, while the kernel you are running is compiled with
a gcc version 3 compiler. This is known to not work.
[root@localhost root]#

The odd thing is that I DID compile the module on my RH8 system (which only has gcc3.2 on)!

Does anybody have any ideas about ways to get round this problem?

Many thanks,

David
  Reply With Quote
Old 10-05-02, 09:09 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

What does cc -v tell you, and what about echo $CC? If the $CC one prints something other than nothing and other than cc, then try <that executable> -v. For example, if it prints gcc-i868-pc-linux-gnu or something like that, then do a gcc-i686-pc-linux-gnu -v instead.

I know gcc 3.2 is the default on RH 8, but it might be that 2.96 was also installed, for some (strange) reason.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-05-02, 08:19 PM   #3
dmp
Guest
 
Posts: n/a
Default

Both those indicated 3.2, which surprised me slightly.

However, I remember that part of the NVidia kernel module is closed source (compiled) with an open source wrapper, so I was wondering if perhaps the closed source bit was gcc 2.9x compiled.

However, I tried again tonight with the newer kernel src rpm (3123) and had no problems at all. Before I had 2960, and I wonder if that was the cause, as I can't think of anything else..

Thanks for your suggestions though - much appreciated
  Reply With Quote
Old 10-05-02, 09:14 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I don't know what Module-nvkernel is compiled with, but it worked for you with gcc 3.2, and it works here with the same, so I think it's OK.

Oh, actually, this might have been a problem a while ago (just before 3123) with RedHat's version of modutils. If that was the issue, then using the latest stable version of modutils (off ftp.kernel.org somewhere, I believe) fixed the problem. But if you got it working, then it wasn't that.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 10:17 AM
kswapd kernel problem and the NVdriver kwaz NVIDIA Linux 2 09-25-02 09:33 PM
Mandrake 8.2 cannot get NVdriver to load. dbhost NVIDIA Linux 20 08-18-02 12:35 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 11:58 AM

All times are GMT -5. The time now is 01:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.