Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-28-11, 01:48 AM   #1
coder270
Registered User
 
Join Date: Jul 2011
Posts: 3
Default 290.10 - Black windows problem

Hello.

I have two systems: Ubuntu 10.04/32-bit and Kubuntu10.04/32-bit. First system is a media PC, it runs OpenBox WM and VDR+XBMC, VDPAU is in use. NVidia drivers have been updated to 290.10 on the both systems.

On the first system, after several hours of use any launched window (including its title, frame and menus) has black background. Restarting of X server helps.

The second system is a desktop computer. Windows and menus become black rectangles there after intensive use and logoff/logon. Restarting of X server also helps there.

Looks like memory leak?

Please help.
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.8 KB, 50 views)
coder270 is offline   Reply With Quote
Old 11-28-11, 11:48 AM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: 290.10 - Black windows problem

I've got almost the same problem - when I log off, KDM (from KDE 3.5.10) screen is all black. X restart also helps.

However no other applications are affected (and I rarely log off so it doesn't bother me much).
artem is offline   Reply With Quote
Old 11-30-11, 12:58 PM   #3
coder270
Registered User
 
Join Date: Jul 2011
Posts: 3
Default Re: 290.10 - Black windows problem

So nobody cares? Switching off KDE desktop effects did not help. The systems became unusable. Still looking for the work-around.
coder270 is offline   Reply With Quote
Old 12-12-11, 05:36 AM   #4
purdeaandrei
Registered User
 
Join Date: Dec 2011
Posts: 1
Default Re: 290.10 - Black windows problem

Quote:
Originally Posted by artem View Post
I've got almost the same problem - when I log off, KDM (from KDE 3.5.10) screen is all black. X restart also helps.

However no other applications are affected (and I rarely log off so it doesn't bother me much).
If it only happens after logout, then you can fix it by adding TerminateServer=true into kdmrc. That will
restart X on each logout.
purdeaandrei is offline   Reply With Quote
Old 12-15-11, 05:24 PM   #5
tecknurd
Registered User
 
Join Date: Mar 2011
Posts: 11
Default Re: 290.10 - Black windows problem

The "black background" is not caused by nVidia modules. It it is caused by a bug in some drawing library. I have the problem too and it started years ago. I use Xfce. The work around that I found that always works is change the window decoration to a different one and then back.
tecknurd is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.