Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-10-11, 06:21 AM   #1
bardo
Registered User
 
Join Date: Dec 2011
Location: Milano, Italy
Posts: 1
Question [GeForce 9400M] External monitor blanks when reaching lowest power state

Hi all,
I'm experiencing a blanking problem which I didn't find referenced anywhere, looking for help

Hardware
  • laptop: MacBook 5,1 (late 2008, aluminium, non-Pro, no audio support over DisplayPort)
  • video card: GeForce 9400M using the DisplayPort output
  • cabling: DisplayPort→HDMI adapter
  • external monitor: Samsung SyncMaster P2370HD

Software
  • distro: Arch Linux x86_64 (fully updated to [testing] repo)
  • kernel: Linux 3.1.4 (distro-packaged)
  • driver version: 290.10
  • xorg server version: 1.11.2
  • desktop environment: Gnome 3

Kernel
Code:
[bardo@antani ~]$ uname -a
Linux antani 3.1.4-1-ARCH #1 SMP PREEMPT Tue Nov 29 08:55:45 CET 2011 x86_64 Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz GenuineIntel GNU/Linux
Xorg configuration
Code:
Section "Device"
	Identifier "Nvidia 9400M"
	Driver "nvidia"
	VendorName "NVIDIA Corporation"
	Option "NoLogo" "1"
	#Option "ConnectedMonitor" "DFP"
	Option "TripleBuffer" "1"
	Option "DPMS" "1"
	Option "RegistryDwords" "PerfLevelSrc=0x3333"
	Option "Coolbits" "1"
	Option "OnDemandVBlankInterrupts" "1"
	Option "RandRRotation" "true"
	Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection
Using the nvidia-settings application, with powermizer set to adaptive mode, I noticed that every time the frequency drops to the minimum (100MHz) the external monitor loses signal. There are several workarounds (switching tty7→tty1→tty7, blindly launching an opengl app like glxgears, blindly launching nvidia-bug-report.sh...), but all do the same thing: raise the graphics clock frequency.

When running in maximum performance mode the problem doesn't (obviously) happen, but this is less than ideal on a laptop, especially one with not-so-great cooling like the MacBook.

Each time the external monitor "cycles" three lines get spit out in Xorg.0.log:
Code:
[288268.284] (II) Open ACPI successful (/var/run/acpid.socket)
[288268.288] (II) NVIDIA(0): Setting mode "DFP-1:nvidia-auto-select@1920x1080+0+0"
[288268.375] (--) synaptics: bcm5974: touchpad found
(The first one can be suppressed by stopping the acpid daemon, the second one seems to be the relevant one.)

The problem didn't show up when I used Xfce, so it's probably related to Gnome 3.

When I'm on the external monitor I disable the internal one.

It's hard to do some good debugging because I'm hit by the "invisible console" bug (as soon as the nvidia driver is loaded I can't see ttys anymore since the backlight turns off when switching to a real console).

Attached is the bug report log, which I ran while the screen was blank, but running it raised the clock frequency middle-way, so I don't know how much it can be trusted.

Right now I'd be happy to find any good workaround which doesn't involve the maximum performance mode. If there was a way to just disable the lowest frequency while keeping the adaptive mode it would be great while waiting for a real solution!


Thanks for getting to here
Attached Files
File Type: gz nvidia-bug-report.log.gz (83.5 KB, 26 views)
bardo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.