Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-26-11, 04:44 AM   #1
wonderland
Registered User
 
Join Date: Dec 2011
Posts: 3
Default Separate X screens + custom EDID file not being used

Hello,

I have a Samsung TV and a Geforce 8600GT. I've connected my PC to my TV by a DVI to HDMI cable and I'm using a 3.5mm cable for audio (no spdif). I modified my EDID file so I can have sound on the TV. It works fine with TwinView, but I experience a tiny bit of tearing with playback. (I may be completely wrong here, but I believe it's because my monitor runs at 60.02Hz and my TV runs at 60Hz?)

So I searched around a little to solve this and found that separate X screens was a possible solution. I now have two separate X screens running without tearing, but now I can't get audio on the TV! It's as if I've botched up my config file somehow and the driver is just ignorning said EDID file.

Below is my xorg.conf for convenience's sake; I've also attached the output produced by nvidia-bug-report.

Thank you and happy holidays!

Code:
Section "Device"
    Identifier  "nvidia0"
    Driver      "nvidia"
    BusID       "PCI:2:0:0"
    Screen      0
EndSection

Section "Device"
    Identifier  "nvidia1"
    Driver      "nvidia"
    BusId       "PCI:2:0:0"
    Screen      1
EndSection

Section "Monitor"
	Identifier "Monitor0"
EndSection

Section "Monitor"
	Identifier "Monitor1"
EndSection

Section "Screen"
    Identifier  "Screen0"
    Device      "nvidia0"
    Monitor     "Monitor0"
EndSection

Section "Screen"
    Identifier      "Screen1"
    Device          "nvidia1"
    Monitor         "Monitor1"
    Option          "CustomEDID"             "DFP:/etc/X11/out.bin"
EndSection

Section "ServerLayout"
    Identifier	   "DualScreen"
    Screen         0 "Screen0" 
    Screen         1 "Screen1" RightOf "Screen0"
    Option         "Xinerama" "0"
EndSection
Attached Files
File Type: gz nvidia-bug-report.log.gz (83.5 KB, 26 views)
wonderland is offline   Reply With Quote
Old 12-28-11, 12:44 AM   #2
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Separate X screens + custom EDID file not being used

I think entry should be like :

Option "CustomEDID" "DFP-1:/etc/X11/out.bin"

or

Option "CustomEDID" "CRT-0:/etc/X11/out.bin"
sandipt is offline   Reply With Quote
Old 12-28-11, 11:45 AM   #3
wonderland
Registered User
 
Join Date: Dec 2011
Posts: 3
Default Re: Separate X screens + custom EDID file not being used

Quote:
Originally Posted by sandipt View Post
I think entry should me like :

Option "CustomEDID" "DFP-1:/etc/X11/out.bin"

or

Option "CustomEDID" "CRT-0:/etc/X11/out.bin"
Hi,

Thanks for replying! I believe I read on this forum that DFP will default to the appropriate one if there is only one DFP connected. That is the case with my setup. In any case, I've switched it back to DFP-1 and I'm afraid it's still not working.

Here's why I believe my hunch that the EDID file is being ignored is true: in nvidia-settings, all of the flat panel information is listed (as opposed to being listed as unknown).



When I tried it with TwinView and a custom EDID file, it listed a lot of things as unknown (and the sound worked).

My temporary fix, for now, is to just disable CRT-0. It's a bit inconvenient, though.
wonderland is offline   Reply With Quote
Old 12-28-11, 01:26 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Separate X screens + custom EDID file not being used

Could you please try moving the CustomEDID command to the "Screen0" section?

X doesn't have a good way of specifying per-GPU options, so the driver has to pick the options up from one of the two Device or Screen sections. It can lead to counter-intuitive situations like this one.
AaronP is offline   Reply With Quote
Old 12-28-11, 01:35 PM   #5
wonderland
Registered User
 
Join Date: Dec 2011
Posts: 3
Default Re: Separate X screens + custom EDID file not being used

Quote:
Originally Posted by AaronP View Post
Could you please try moving the CustomEDID command to the "Screen0" section?

X doesn't have a good way of specifying per-GPU options, so the driver has to pick the options up from one of the two Device or Screen sections. It can lead to counter-intuitive situations like this one.
That worked! Thank you very much.
wonderland is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.