Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-26-03, 06:53 AM   #1
Xaero
Registered User
 
Join Date: Dec 2003
Posts: 5
Default Slow Graphics in Fedora Core 1 -- help?

Hello
Finally, I actually completed the innstalation of the drivers.
But....
Even after I've installed the drivers (hopyfully?), games like Tux Racer VERY slow.
I got a GF4 Ti4200 video card, so it should run smooth.
Is there a way to check if the drivers really are loaded. (Yes, the nVidia-logo pops up when X starts.)
Maybe I forgot something. If so, what could it be?
I would appreciate some help.

Click here to see my XF86Config
System Info:
Motherboard: MSI KT3 Ultra (kt333)
Video Card: Abit Siluro GF4 Ti4200
CPU: AMD XP2000+

Merry Christmas -
Xaero

Last edited by Xaero; 12-26-03 at 07:14 AM.
Xaero is offline   Reply With Quote
Old 12-26-03, 07:55 AM   #2
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Ok, First, in your XF86Config file remove the following:-

Section "DRI"
Group 0
Mode 0666
EndSection

Remove all of it. Then in the (Section "device") add the following:-

Option "NvAGP" "1"
Option "RenderAccel" "True"

And possibly to help the Video performance you can add the following line to your /etc/modules.conf file

options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1

Then restart X to make these changes active. If you booted into command mode (init 3) you can simply exit X. then type rmmod nvidia, to remove the nvidia module. Then restart X, which will reload it with the new settings. If you boot into Graphics Mode, simply reboot the system.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 12-26-03, 08:12 AM   #3
Xaero
Registered User
 
Join Date: Dec 2003
Posts: 5
Default

Hello

I did that now, and when I load Tux Racer now, X restarts...
I saw an error, can't remember when, the error was something like "cannot load glx"

Hmm, I think I should uninstall all nVidia drivers and reinstall everything. Or simply reinstall Fedora
Why is it so hard to just install drivers? nVidia should make it easier so more ppl use Linux

Last edited by Xaero; 12-26-03 at 08:18 AM.
Xaero is offline   Reply With Quote
Old 12-26-03, 12:16 PM   #4
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

How are you installing them? All I had to do was "sh NVIDIA...", make the modifications to my XF86Config per the readme and it was all good.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 12-26-03, 05:31 PM   #5
Xaero
Registered User
 
Join Date: Dec 2003
Posts: 5
Default

I downloaded kernel-src, then sh NVIDIA* and fixed some **** in XF86Config...
Xaero is offline   Reply With Quote
Old 12-26-03, 10:16 PM   #6
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

If you're getting errors like "cannot load glx, you missed something in the install. Uninstall the drivers and reinstall them. Make sure they're loading in X by su'ing to root and running lsmod. You should see nvidia loaded as a module. You should've also installed all the Mesa packages for your distribution. If you'll state the distro, we might be able to be more effective in helping. Also, the XFree86 log file from /var/log would be a lot of help.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 12-27-03, 08:12 AM   #7
Xaero
Registered User
 
Join Date: Dec 2003
Posts: 5
Default

Know what?
I'll reinstall Fedora. I've messed it up...
I don't even know how to remove ALL Nvidia drivers, help?
Xaero is offline   Reply With Quote
Old 12-27-03, 08:15 AM   #8
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

nvidia-installer --uninstall, run it as root.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote

Old 12-27-03, 05:49 PM   #9
Xaero
Registered User
 
Join Date: Dec 2003
Posts: 5
Talking Problem Fixed

Hey, guys.
I reinstaled Fedora, installed some RPMs I found, and u know what? It worked!!!
Thanks.
Xaero is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 08:43 AM

All times are GMT -5. The time now is 11:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.