Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-11-12, 12:41 PM   #1
andreu
Registered User
 
Join Date: Jan 2012
Posts: 7
Default NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Dear all,

0. I've a laptop ASUS , with the GeForce GT520M graphics card.
1. I've recently installed the NVIDIA-Linux-x86-285.05.09.run file on my Ubuntu 11.10 (32 bits).
2. At the end I did not accept to execute nvidia-xconfig, to be sure to manually backup my current xorg.conf.
3. After a manual backup of the xorg.conf, I executed $sudo nvidia-xconfig, and it generated a nice xorg.conf file where the new "nvidia" entry appeared.
4. Moreover, I read at /usr/share/doc/NVIDIA_GLX-1.0/README.txt that it is convenient to create a blacklist for the nouveau module, so I added a file named "blacklist-nouveau.conf" at /etc/modprobe.d with the following:
blacklist nouveau
options nouveau modeset=0

5. Finnally I did $sudo reboot, but it seems that the xserver no longer starts.
6. I attach the /var/log/nvidia-installer.log and the /var/log/Xorg.0.log

Thanks , all help will be of high value

best,

andreu
Attached Files
File Type: log Xorg.0.log (6.4 KB, 84 views)
File Type: log nvidia-installer.log (62.7 KB, 86 views)
andreu is offline   Reply With Quote
Old 01-15-12, 09:54 AM   #2
garbageman
Registered User
 
Join Date: Jan 2012
Posts: 5
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Please see the sticky and include the requested information so assistance is easier to come by.
http://www.nvnews.net/vbulletin/showthread.php?t=46678

4a) Please always include a copy of an nvidia-bug-report.log file, which can be generated with the `nvidia-bug-report.sh` script shipped with the NVIDIA Linux/FreeBSD graphics drivers and installed in your PATH; the log file will be placed in the current working directory. Newer versions of the script will automatically compress the log file renaming it to nvidia-bug-report.log.gz.

To make sure this log file includes as much relevant information as possible, please start the X server with `startx -- -logverbose 6` and run `nvidia-bug-report.sh` after the problem has occurred. If X can not be started or the machine appears to have crashed, please check if you can log into it remotely (e.g. via ssh or telnet) and run `nvidia-bug-report.sh` in the remote shell, if possible.

Readme file with detailed instructions
http://us.download.nvidia.com/XFree8...DME/index.html (for Reference)

===

SOLUTION FOUND: at least partial

found youtube video searching nvidia no screens found.
Suggestion is to lspci and find your video card in my case 01:00:0

# lspci |grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 1246 (rev a1)

Note: I had to add the BusID line per the youtube video
vi /etc/X11/xorg.conf

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:1:0:0" (Had to add this line after checking lspci, reduce zero's)
EndSection

Status: now I can get video on my external monitor but I am not sure how to switch to the laptop display. Any suggestions there?

http://www.youtube.com/watch?v=ReyT56rTWnA

Last edited by garbageman; 01-15-12 at 12:04 PM. Reason: Add link to docs
garbageman is offline   Reply With Quote
Old 01-15-12, 12:07 PM   #3
andreu
Registered User
 
Join Date: Jan 2012
Posts: 7
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Dear all,

Thanks garbageman for the kind reminder, I upload nvidia-bug-report.log.gz
Attached Files
File Type: gz nvidia-bug-report.log.gz (48.0 KB, 69 views)
andreu is offline   Reply With Quote
Old 01-15-12, 10:08 PM   #4
garbageman
Registered User
 
Join Date: Jan 2012
Posts: 5
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

did you see my last notes?
did you do the lspci and add the BusID? I do not see that in your xorg.conf
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
I am not sure if the EndSubSection is needed.
If you thread for my issue it has been suggested that the internal display can only be driven by the onboard intel video driver "intel"
If you can boot to windows the intel chipset identifier utility will identify the chipset and in my case told me I had intel video too.
What do you get from lspci |grep -i VGA ?

Best Wishes.
garbageman is offline   Reply With Quote
Old 01-17-12, 01:32 AM   #5
andreu
Registered User
 
Join Date: Jan 2012
Posts: 7
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Hi garbageman !

I get the same output than you when $lspci |grep -i VGA:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 1050 (rev a1)

So, I've tried to add the BusID line to the Device section as you proposed.

But, No success ... I get the same error at Xorg.0.log:
[ 22.477] (EE) No devices detected.
[ 22.516]
Fatal server error:
[ 22.516] no screens found

Thanks for the suggestion !

Andreu
andreu is offline   Reply With Quote
Old 01-18-12, 04:46 AM   #6
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Looks your notebook is optimus :

21.759] (--) PCI:*(0:0:2:0) 8086:0116:1043:16f2 rev 9, Mem @ 0xdd400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e000/64
[ 21.759] (--) PCI: (0:1:0:0) 10de:1050:1043:16f2 rev 161, Mem @ 0xdc000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288


Try changing display/graphics setting in BIOS to use nvidia GPU only.
sandipt is offline   Reply With Quote
Old 01-18-12, 05:08 AM   #7
LLStarks
Registered User
 
Join Date: Dec 2010
Posts: 66
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Optimus is not supported by the Nouveau (maybe later this year) or Nvidia driver. Unless the laptop has a BIOS switch witch is highly unlikely, you need tools like Bumblebee or asus-switcheroo (since Asus ACPI calls are bit unique).

No amount X tinkering alone will do what you guys are trying to achieve.

Installing the .run files directly from Nvidia on an Optimus machine is never a good idea. It can break 3D rendering for the Intel card which is always active. Some distros and Bumblebee has packages that permit safe installation of the Nvidia drivers. I'd also like to point out that running a 32-bit OS on Optimus is less than ideal since such systems tend to have at least 4GB of RAM. You need a 64-bit distro or a 32-bit PAE kernel to use it all.

https://github.com/Bumblebee-Project/

Use the stable Bumblebee or give the upcoming Bumblebeed release a try.
LLStarks is offline   Reply With Quote
Old 01-18-12, 06:13 AM   #8
andreu
Registered User
 
Join Date: Jan 2012
Posts: 7
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Thanks LLStarks for your comments.

My BIOS does not allow switching graphic devices (Or I've not found this feature ... BIOS: American Megatrends , U31SD 202, v2.01.1204, just in case that some BIOS guru is reading that ...)

Ok, we do not fight anymore with xorg.conf. Now, my roadmap is, as you suggest, to wait for bumblebee 3.0 (it was expected by 13/1/2012). Meanwhile, if nvidia corp. releases some novelty, this will be welcome !

I'm using 32bit-PAE kernel.

Thanks,

andreu
andreu is offline   Reply With Quote

Old 01-21-12, 03:43 AM   #9
andreu
Registered User
 
Join Date: Jan 2012
Posts: 7
Default Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

Hi all,

hopeful news, just FYK,

Bumblebee team has released a new stable version of his package:

https://lists.launchpad.net/hybrid-g.../msg02091.html

let's try it ...

Bye,

andreu
andreu is offline   Reply With Quote
Old 01-21-12, 02:46 PM   #10
andreu
Registered User
 
Join Date: Jan 2012
Posts: 7
Thumbs up Re: NVIDIA GT520M installation problem under Ubuntu 11.10. Fail when rebooting

IT WORKS !!!!!!!!!!!!!!!!!!!!!!!!!!!

Bumblebee 3.0 (release Jan 19th 2012) solves my issue !!!

Proof:
andreu@rocgros:~$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.968 FPS
299 frames in 5.0 seconds = 59.704 FPS
^C
andreu@rocgros:~$ optirun glxgears
2528 frames in 5.0 seconds = 505.597 FPS
2477 frames in 5.0 seconds = 495.146 FPS
^C

About Bumblebee project: https://launchpad.net/~bumblebee
Nice guide to install it: http://askubuntu.com/questions/36930...a-optimus-work (find the answer posted by Lekensteyn)

Thanks and best regards,

andreu
andreu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.