Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-08-12, 01:51 PM   #1
linuxrams
Registered User
 
Join Date: Feb 2012
Posts: 3
Default No GUI and only command line:

Hi all,

OS: openSUSE 10.3 (X86-64)

I am unable to login to GUI (eventhough run-level is 5) and every time i boot up the system it goes directly to command line (run-level3).
This is used to login to GUI earlier. Not sure now what happend.
I see following messages when system is booting up.

Code:
Master Resource Control: Running /etc/init.d/after.local
doneMaster Resource Control: runlevel 5 has been reached
Failed services in runlevel 5: xinetd avahi-dnsconfd
Skipped services in runlevel 5: smbfs xend xendomains
Code:
startx
xauth:  creating new authority file /root/.serverauth.6995

Fatal server error:
Can't read lock file /tmp/.X0-lock

giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
I find following in /var/log/Xorg.0.log

Code:
# egrep "EE|WW" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/local" does not exist.
(WW) The directory "/usr/share/fonts/PEX" does not exist.
(WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
(WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
(WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/baekmuk" does not exist.
(WW) The directory "/usr/share/fonts/japanese" does not exist.
(WW) The directory "/usr/share/fonts/kwintv" does not exist.
(WW) The directory "/usr/share/fonts/CID" does not exist.
(WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
(WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
(WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
(WW) The directory "/usr/share/fonts/xtest" does not exist.
(II) Loading extension MIT-SCREEN-SAVER
(WW) Jan 25 13:38:44 NVIDIA(0): TwinView requested, but only 1 display devices found.
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1920x1080+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1920x1080+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1600x1024+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1600x1024+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1400x1050+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1400x1050+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1280x1024+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1280x1024+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1280x960+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1280x960+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1152x864+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1152x864+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1024x768+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1024x768+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:800x600+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:800x600+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:640x480+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:640x480+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device

and /var/log/messages has following error on X server

Code:
cat /var/log/messages |grep kdm
Feb  8 10:51:23 bmlnx03 kdm_config[2811]: Multiple occurrences of key 'Language' in section [X-*-Greeter] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:51:23 bmlnx03 kdm_config[2811]: Multiple occurrences of key 'ShowUsers' in section [X-*-Greeter] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:51:23 bmlnx03 kdm_config[2811]: Multiple occurrences of key 'UseBackground' in section [X-*-Greeter] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:51:23 bmlnx03 kdm_config[2811]: Multiple occurrences of key 'AllowShutdown' in section [X-:*-Core] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:51:23 bmlnx03 kdm_config[2811]: Multiple occurrences of key 'AutoLoginEnable' in section [X-:0-Core] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:51:24 bmlnx03 kdm[2810]: X server died during startup
Feb  8 10:51:24 bmlnx03 kdm[2810]: X server for display :0 can't be started, session disabled
Feb  8 10:59:38 bmlnx03 kdm_config[3060]: Multiple occurrences of key 'Language' in section [X-*-Greeter] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:59:38 bmlnx03 kdm_config[3060]: Multiple occurrences of key 'ShowUsers' in section [X-*-Greeter] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:59:38 bmlnx03 kdm_config[3060]: Multiple occurrences of key 'UseBackground' in section [X-*-Greeter] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:59:38 bmlnx03 kdm_config[3060]: Multiple occurrences of key 'AllowShutdown' in section [X-:*-Core] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:59:38 bmlnx03 kdm_config[3060]: Multiple occurrences of key 'AutoLoginEnable' in section [X-:0-Core] of /opt/kde3/share/config/kdm/kdmrc
Feb  8 10:59:39 bmlnx03 kdm[3059]: X server died during startup
Feb  8 10:59:39 bmlnx03 kdm[3059]: X server for display :0 can't be started, session disabled
Thanks in advance!
linuxrams is offline   Reply With Quote
Old 02-08-12, 05:42 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: No GUI and only command line:

Please see the sticky posts about how to generate a bug report log.
AaronP is offline   Reply With Quote
Old 02-09-12, 10:46 AM   #3
linuxrams
Registered User
 
Join Date: Feb 2012
Posts: 3
Default Re: No GUI and only command line:

Hi Aaron,

I am attaching nvidia-bug-report.log here.
Thanks in advance!
Attached Files
File Type: gz nvidia-bug-report.log.gz (42.9 KB, 30 views)
linuxrams is offline   Reply With Quote
Old 02-09-12, 11:08 AM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: No GUI and only command line:

I don't see anything in your log file that explains why the X server is dying. Do you see any errors on the console if you try to start X with, for example, "startx"? Also, does the problem still reproduce if you install 295.17?
AaronP is offline   Reply With Quote
Old 02-09-12, 11:38 AM   #5
linuxrams
Registered User
 
Join Date: Feb 2012
Posts: 3
Default Re: No GUI and only command line:

Hi Aaron,

Code:
startx
xauth:  creating new authority file /root/.serverauth.6995

Fatal server error:
Can't read lock file /tmp/.X0-lock

giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
and
Code:
# ls -al /tmp/ |grep .X0-lock
ls: cannot access /tmp/.X0-lock: Permission denied
??????????  ? ?      ?            ?            ? .X0-lock
i tried to remove this file but not succeeded.
Code:
 # rm /tmp/.X0-lock
rm: cannot remove `/tmp/.X0-lock': Permission denied

#  lsof /tmp/.X0-lock
lsof: status error on /tmp/.X0-lock: Permission denied
linuxrams is offline   Reply With Quote
Old 02-09-12, 01:38 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: No GUI and only command line:

Something is wrong with your /tmp directory. Is it mounted with some weird option or with a very restrictive selinux policy or something? In any case, this is not an NVIDIA problem but a basic system configuration issue.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:42 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.