Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-14-12, 05:22 AM   #13
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

OK, with SMPlayer the problem is gone. The screen is still flashing green when switching to/from fullscreen, but it's very short and the desktop doesn't freeze.

I just noticed something however. The stuttering is not completely gone, but is directly related to the video's FPS. If I watch a 60FPS video, everything is smooth. If I watch a 30FPS video, the desktop is stuttering a bit. If I watch a 25FPS or 23.9FPS video (the majority of movies), then the desktop stutters even more. Not as bad as without the "queuetime" options set to 0 though.

And that only fixes mplayer. Which isn't really needed at all, because even with VDPAU and queuetime set to 0, Xv output is still much, much better, always resulting in a perfectly smooth video (VDPAU introduces a slight stutter/framedrops every two seconds or so.) The real problem with the VDPAU+composite slowness bug is Adobe Flash. It's useless right now.

Edit:
I should mention that this is my first NVidia graphics card. I upgraded from a Radeon 4870 and was hoping to see the VDPAU support. I'm somewhat disappointed that it's not useful on a modern Linux desktop.
RealNC is offline   Reply With Quote
Old 02-14-12, 06:19 AM   #14
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by MadCatX View Post
You might be experiencing a different issue (IIRC mine wasn't affected by compositing), but have you tried these?

- Use VDPAU in mplayer, but use "-vc ffh264" instead of "-vc ffh246vdpau"?
Btw, if you do this, then you aren't really using VDPAU. You're decoding on the CPU.
RealNC is offline   Reply With Quote
Old 02-14-12, 08:07 AM   #15
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: VDPAU and KDE 4.8 compositing = slow

Regarding the mplayer issues, I believe that at least some of those are caused by mplayer2. I've been experimenting with mplayer2 on and off for quite some time and I've always reverted back to vanilla mplayer because of all sorts of weird issues including the green flashing.
Possible freezes when toggling between FS<->window are caused by KWin unredirecting. You can either disable unredirecting for fullscreen apps (System settings->Desktop effects->Advanced) or create a rule in KWin to disable compositing when SMPlayer is running. I can't tell if it's KWin or VDPAU at fault here.

Quote:
Originally Posted by RealNC View Post
Btw, if you do this, then you aren't really using VDPAU. You're decoding on the CPU.
Even though the decoding is done on CPU, the video is still being drawn using VDPAU. Since your problems go away when you switch compositing off, it's probably a drawing problems.

I'm not having any problems with Flash on 9800M GTS, you can also disable the HW decoding altogether by adding "EnableLinuxHWVideoDecode=0" to /etc/adobe/mms.cfg. My over 3 years old laptop can handle 1080p Flash videos without VDPAU with ease.
MadCatX is offline   Reply With Quote
Old 02-14-12, 09:55 AM   #16
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by MadCatX View Post
Regarding the mplayer issues, I believe that at least some of those are caused by mplayer2. I've been experimenting with mplayer2 on and off for quite some time and I've always reverted back to vanilla mplayer because of all sorts of weird issues including the green flashing.
Just removed mplayer2/libav and installed mplayer/ffmpeg. The problem is still there. Not the green flash, I mean the real problem.

Quote:
Possible freezes when toggling between FS<->window are caused by KWin unredirecting. You can either disable unredirecting for fullscreen apps (System settings->Desktop effects->Advanced)
That kills 3D performance of games. Fullscreen really needs to be unredirected. Even Windows Aero does that.

Quote:
or create a rule in KWin to disable compositing when SMPlayer is running.
That kills the desktop experience.

The only thing that can be done is disabling VDPAU. Which in turn means the problem really needs to be fixed.

Quote:
Even though the decoding is done on CPU, the video is still being drawn using VDPAU. Since your problems go away when you switch compositing off, it's probably a drawing problems.
There's no reason to use VDPAU then. Xv is much better.

Quote:
I'm not having any problems with Flash on 9800M GTS, you can also disable the HW decoding altogether by adding "EnableLinuxHWVideoDecode=0" to /etc/adobe/mms.cfg. My over 3 years old laptop can handle 1080p Flash videos without VDPAU with ease.
The real problem is that without accelerated rendering, fullscreen Flash video is tearing very badly. Accelerated decoding doesn't matter much to me anyway, since the machine has a 2500K CPU. The problem is the tearing in fullscreen.

NVidia, please please try and fix VDPAU+composite
RealNC is offline   Reply With Quote
Old 02-15-12, 06:46 AM   #17
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: VDPAU and KDE 4.8 compositing = slow

I don't experience any tearing on FS with Flash, the plugin sometimes crashes, but that's just Adobe.

I believe that this is actually a KWin problem, when I use Compiz instead of KWin, my VDPAU experience gets much better...
MadCatX is offline   Reply With Quote
Old 02-15-12, 08:25 AM   #18
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by MadCatX View Post
I don't experience any tearing on FS with Flash, the plugin sometimes crashes, but that's just Adobe.

I believe that this is actually a KWin problem, when I use Compiz instead of KWin
It's not a KWin problem, it's a KWin feature. In FS, compositing is disabled (as it should be.) No compositing, no VSync from the compositor. Flash does not do VSync, even though it should, because Flash, for whatever crazy reason, does not use Xv, nor OpenGL for rendering. It just copies pixels to the X shared memory. That is the slowest and stupidest method of doing video, and Flash picked that. IMO, the Flash Linux devs are morons.

Unfortunately, Compiz is dead. Distros are now removing it from their repos. Gentoo, openSUSE, Fedora already did that. I'm using Gentoo.

You will not be able to use Compiz anymore in the very near future.
RealNC is offline   Reply With Quote
Old 02-15-12, 08:50 AM   #19
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: VDPAU and KDE 4.8 compositing = slow

Flash does what it does because it needs to postprocess RGB data and Xv for instance uses YUV, although I'm not saying Flash is the best piece of SW out there.

When I switch to Compiz, a lot of (if not all) my VDPAU problems (crashes on FS->window->FS toggling, high CPU load, ...) instantly disappear, so I believe that KWin is doing something wrong which causes VDPAU to malfunction. If you'd like to raise a bug report on KDE bugzilla, I'd be happy to contribute with my findings.
MadCatX is offline   Reply With Quote
Old 02-15-12, 08:55 AM   #20
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

If I open a bug report on KDE, it will be closed. You cannot just open a bug saying that KWin does something wrong. You need detail on what that is. Currently, it seems only an NVidia developer is in the position to tell what is going wrong. But given the silence here from any official mod, I'd say we might have to live with this problem for a while.
RealNC is offline   Reply With Quote

Old 02-22-12, 01:02 AM   #21
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: VDPAU and KDE 4.8 compositing = slow

I think shuttering is happing when you override any apps window with another window like terminal, file-manager, video window when desktop effects are enabled in KDE4.8(kwin). I am moving my gnome terminal on file-manager and observed shuttering and window drown is also slow.

Need your comments on this to confirm its really related to vdpau video OR kwin desktop effects. In my case its not related to vdpau video, seems related kwin.

I also observed screen flashes Green when full screen video with vdpau.
sandipt is offline   Reply With Quote
Old 02-22-12, 11:44 AM   #22
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

It stutters all the time here, not just when two windows overlap. Also, the amount of stuttering depends on the video's FPS.

Here's a video with 60FPS for testing.
RealNC is offline   Reply With Quote
Old 04-02-12, 01:07 AM   #23
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: VDPAU and KDE 4.8 compositing = slow

Please check issue with ftp://download.nvidia.com/XFree86/Linux-x86_64/295.33/
sandipt is offline   Reply With Quote
Old 04-02-12, 06:01 AM   #24
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

I've been running 295.33 since the first day they came out. Issue still there.
RealNC is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:58 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.