Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-26-12, 11:06 AM   #1
barnold
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Nvidia X GUI problem

I used the Nvidia X GUI to get a good xorg.conf. Replaced the xorg in /etc/X11 file with it. Everything's fine EXCEPT for whenever I boot up Fedora (16, Gnome) I have to open up the GUI after which the screen goes black for about a second, comes back to gnome and THEN my monitor starts getting the 120hz specified in the xorg.

Here's a copy of my xorg: http://fpaste.org/u7xS/
barnold is offline   Reply With Quote
Old 02-26-12, 01:18 PM   #2
brebs
Registered User
 
Join Date: Jul 2007
Posts: 38
Default Re: Nvidia X GUI problem

In your Gnome startup script, run:

nvidia-settings --load-config-only
brebs is offline   Reply With Quote
Old 02-26-12, 09:45 PM   #3
barnold
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: Nvidia X GUI problem

I'm trying to find the answer on google... but where is the file located?
barnold is offline   Reply With Quote
Old 02-27-12, 12:02 AM   #4
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: Nvidia X GUI problem

I'm guessing from the description the real problem is wrong scaling setting so what you probably want is to set Option "FlatPanelProperties" "Scaling = Native" in your config. This way you don't need to run nvidia-settings at all and you don't get the annoying flicker.
poltsy is offline   Reply With Quote
Old 02-27-12, 02:22 AM   #5
barnold
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: Nvidia X GUI problem

Quote:
Originally Posted by poltsy View Post
I'm guessing from the description the real problem is wrong scaling setting so what you probably want is to set Option "FlatPanelProperties" "Scaling = Native" in your config. This way you don't need to run nvidia-settings at all and you don't get the annoying flicker.
Still getting the same problem. I'd like to give the other solution a shot if I could find the file.
barnold is offline   Reply With Quote
Old 02-27-12, 04:56 AM   #6
GraveR
Registered User
 
Join Date: Nov 2008
Posts: 6
Default Re: Nvidia X GUI problem

I suppose brebs meant configuring it in 'Startup Applications' which can be found in System -> Preferences (at least under Ubuntu). Or you can run 'gnome-session-properties', add a new startup application with the command '/usr/bin/nvidia-settings --load-config-only'; that should do the trick.
GraveR is offline   Reply With Quote
Old 02-27-12, 02:40 PM   #7
barnold
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: Nvidia X GUI problem

Quote:
Originally Posted by GraveR View Post
I suppose brebs meant configuring it in 'Startup Applications' which can be found in System -> Preferences (at least under Ubuntu). Or you can run 'gnome-session-properties', add a new startup application with the command '/usr/bin/nvidia-settings --load-config-only'; that should do the trick.
That was the fix. Thanks all who helped.
barnold is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.