Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-12-12, 11:26 AM   #13
SpartanJ
Registered User
 
Join Date: May 2008
Posts: 22
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Same problem here, with GTX260M and any 295.* driver, i'm using 3.1.0 kernel. 290.10 works fine to me too.
SpartanJ is offline   Reply With Quote
Old 03-13-12, 05:00 PM   #14
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

We're actively trying to investigate this; I'll update the thread as soon as I have more information.
Plagman is offline   Reply With Quote
Old 03-17-12, 12:08 PM   #15
eserzet
Registered User
 
Join Date: Mar 2012
Posts: 2
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Can confirm this bug under gentoo ~x86 , latest updates, latest kernel (3.2.11).

/var/log/Xorg.0.log.old :

Code:
[  5942.788] 
Backtrace:
[  5942.869] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x81bc8ab]
[  5942.869] 1: /usr/bin/X (0x8048000+0x178335) [0x81c0335]
[  5942.869] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb773340c]
[  5942.869] Segmentation fault at address 0xb6e38000
[  5942.869] 
Fatal server error:
[  5942.869] Caught signal 11 (Segmentation fault). Server aborting
/var/log/messages :

Code:
[kernel] NVRM: Xid (0000:01:00): 6, PE0001
[kdm] X server for display :0 terminated unexpectedly
Driver 290.10 is the latest working for me.

Is there any official NVIDIA bugtracking system for that issue like bugzilla?

Best regards.
eserzet is offline   Reply With Quote
Old 03-17-12, 12:24 PM   #16
eserzet
Registered User
 
Join Date: Mar 2012
Posts: 2
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Oh additionally to my comment #15 :

Besides the black screen / no signal in VT[1-6] behaviour, I get randomly kicked from X (this is when I get these error message above), when I'm using latest KDE4.8.1. And it is totally random: X crashs after 2 min, X crashs after 6 hours desktop idling, X crashs after 1 hour Adobe flash video playback and then 3 days without any problems - except the black screen VT issue of course.

I am using

- xorg-server 1.11.3 resp. 1.11.4
- vesafb
- mesa 7.11.2 resp. 8.0.1
- kernel 3.2.1 and now 3.2.11

greetings
__________________
Geforce GTS 250 , gentoo ~x86
eserzet is offline   Reply With Quote
Old 03-23-12, 02:26 AM   #17
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Anybody tried with 295.33?
kokoko3k is offline   Reply With Quote
Old 03-23-12, 03:21 AM   #18
ioni
Registered User
 
Join Date: Aug 2010
Posts: 63
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Quote:
Originally Posted by kokoko3k View Post
Anybody tried with 295.33?
not fixed.
ioni is offline   Reply With Quote
Old 03-24-12, 04:36 PM   #19
pavlinux
Registered User
 
pavlinux's Avatar
 
Join Date: Feb 2006
Location: Moscow, Russia
Posts: 57
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Hey, World! Try:

DISABLE ANY FRAMEBUFFERS

1. vga=normal in bootloader prompt
2. rm or move nv.ko nvidiafb.ko all other framebuffer drivers
3. mv /etc/init.d/fb* ~/
pavlinux is offline   Reply With Quote
Old 03-25-12, 07:17 AM   #20
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

pavlinux

290.10 drivers still work just fine, why do I need this ****ty workaround on my 2560x1600 display?
artem is offline   Reply With Quote

Old 03-25-12, 04:43 PM   #21
vaccaaa
Registered User
 
Join Date: Feb 2012
Posts: 3
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Quote:
Originally Posted by pavlinux View Post
Hey, World! Try:

DISABLE ANY FRAMEBUFFERS

1. vga=normal in bootloader prompt
2. rm or move nv.ko nvidiafb.ko all other framebuffer drivers
3. mv /etc/init.d/fb* ~/
Going to try it Thank you!

Quote:
Originally Posted by artem View Post
pavlinux

290.10 drivers still work just fine, why do I need this ****ty workaround on my 2560x1600 display?
For example, if you are going to install xorg server >= 1.12 you will need nvidia > 290, and so you will need this workaround... Of course waiting that the lastest driver is fixed...
vaccaaa is offline   Reply With Quote
Old 03-25-12, 04:58 PM   #22
pavlinux
Registered User
 
pavlinux's Avatar
 
Join Date: Feb 2006
Location: Moscow, Russia
Posts: 57
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

Quote:
Originally Posted by artem View Post
pavlinux

290.10 drivers still work just fine, why do I need this ****ty workaround on my 2560x1600 display?
Try without xorg.conf, may be oldest config params not compatible with new driver.

# nvidia-bug-report.sh

And attach here file with reults.
pavlinux is offline   Reply With Quote
Old 03-26-12, 01:58 AM   #23
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

@pavlinux,
the OP (8600GT) stated:
Quote:
FYI, I just dropped vga/video parameters from kernel line and the problem persits
and i can confirm that using a text only console doesn't workaround the issue on my 9600 too.
kokoko3k is offline   Reply With Quote
Old 03-26-12, 01:43 PM   #24
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: [BUG] NVIDIA 295.17 switching to TTY display is turned off, nvidia 8600m

pavlinux

Code:
#
Section "Device"
        Identifier      "Videocard0"
        BusID           "PCI:1:0:0"
        Driver          "nvidia"
        VendorName      "NVIDIA"
        BoardName       "nVidia Corporation GeForce 8800 GT (rev a2)"
        Option          "CursorShadow" "on"
        Option          "RandRRotation" "on"
        Option          "OnDemandVBlankInterrupts" "on"
        Option          "Coolbits" "5"
        Option          "FlatPanelProperties" "Scaling = Native"
EndSection

# This is a trailing line, it is needed so that End Section is not the last line
artem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.