Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-06-12, 04:26 PM   #1
neosmatrix
Registered User
 
Join Date: Sep 2004
Posts: 60
Default Only Stereo Sound over HDMI after suspend 2 ram (updated)

Hi,

I use Debian unstable with KDE 4.7.4-1. To suspend the PC I use the command
Code:
 echo -n 'mem' > /sys/power/state
, which works perfectly for me. But I can only get Stereo sound over HDMI.
I have to stop KDE and reload the snd-hda-intel module in order to get 5.1 sound again.

I hope this can be fixed somehow.

Thanks,
neosmatrix

EDIT:

I found a small programm named hda-analyzer:

Code:
#### codec-1

Codec: 0x10de000a
Address: 1
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x10de000a
Subsystem Id: 0x10de0101
Revision Id: 0x100100
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
    formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0


#### Node [0x04] AUD_OUT
Node 0x04 [Audio Output] wcaps 0x72b1: 8-Channels Digital Stripe CP
  Converter: stream=6, channel=0
  Digital: Enabled
  Digital category: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
  Unsolicited: tag=0x00, enabled=0

#### Node [0x05] PIN
Node 0x05 [Pin Complex] wcaps 0x407381: 8-Channels Digital CP
  Control: name="HDMI/DP,pcm=7 Jack", index=0, device=0
  Control: name="IEC958 Playback Con Mask", index=1, device=0
  Control: name="IEC958 Playback Pro Mask", index=1, device=0
  Control: name="IEC958 Playback Default", index=1, device=0
  Control: name="IEC958 Playback Switch", index=1, device=0
  Control: name="ELD", index=0, device=7
  Pincap 0x09000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Unsolicited: tag=0x01, enabled=1
  Connection: 1
     0x04
maybee this helps a bit.

EDIT2:

After another suspend and wakeup sound over HDMI is stereo again and the only difference i can see ind hda analyzer is here:
Code:
Node 0x04 [Audio Output] wcaps 0x72b1: 8-Channels Digital Stripe CP
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
  Unsolicited: tag=0x00, enabled=0
Digital is off and the Converter values are different.

BTW. why are the only displayed formats PCM and AC3 ? I have a Sony STR-DG720 connected to a LG 37LF2510-ZB.
Attached Files
File Type: gz nvidia-bug-report.log.gz (72.0 KB, 41 views)
__________________
  • Debian x86_64/ 3.2.2-custom
  • ZOTAC GT 220 ZONE® 1024MB
  • NVIDIA driver 295.17
  • Xorg/XServer
  • Kde 4.7.4-1
  • QT 4.8.0-1
  • Intel Q6600
  • 8 GB Ram
  • MythTV ♥ v0.25pre

Last edited by neosmatrix; 02-08-12 at 07:11 PM. Reason: updated and new informations
neosmatrix is offline   Reply With Quote
Old 03-21-12, 08:59 AM   #2
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Only Stereo Sound over HDMI after suspend 2 ram

neosmatrix, Which audio contents you are playing Digital Dolby, 6 channel PCM etc....?
Do you have sample audio clip for testing Stereo Sound and 5.1 sound ?
Also which player you are using?
Did you tried stop and re play audio from player?


I tried with XBMC and observed similar kind of behavior. But stop audio from player and again play audio results 5.1 surround sound.

Same issue does not reproduce with VLC player. Seems like player issue.
sandipt is offline   Reply With Quote
Old 04-02-12, 02:17 AM   #3
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Only Stereo Sound over HDMI after suspend 2 ram

We have internal bug to track this issue Bug ID: 939731. Please provide requested information. Seems like this is Video Player/Application issue.
sandipt is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.