Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-06-12, 10:28 AM   #1
justmao945
Registered User
 
Join Date: Apr 2012
Posts: 2
Default How to set the minimum clock speed in adpative mode?

Hi guys, firstly I should apolagize for my poor english...
My device card is GeForce 9300M GS.
Driver: NVIDIA 295.33
And I find the performance level 0 (GPU:169MHz, Memory:100MHz, Processor:338MHz) can not satisfy the work in KDE. So I want to know how to set the specific performance level, that means to set the CPU speed to 250MHz(or higher may be) of performance level 0, or lock the mini-level to level 1 instead of level 0 in adpative mode ? Fixed to the maximum performance which heats my device, and I would perfer the adpative mode. Acctually I have done this in windows by use Nvidia Inpector, but I do not know how to do in linux.
Thanks.
MaoJianjun
justmao945 is offline   Reply With Quote
Old 04-07-12, 01:21 AM   #2
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: How to set the minimum clock speed in adpative mode?

The problem you have is quite common. Modern, over-engineered desktop environment and nvidia card in low power state don't mix well.

IIRC you can't do exactly what you'd like to do (i.e. impose a min freq). What should work is to force max performance mode and at the same time underclock. Then it should stay at the frequency you underclock it to and you might get reasonable heat/power consumption and reasonable performance. Of course it won't be adaptive any more..
ledoc is offline   Reply With Quote
Old 04-07-12, 05:11 AM   #3
justmao945
Registered User
 
Join Date: Apr 2012
Posts: 2
Default Re: How to set the minimum clock speed in adpative mode?

Quote:
Originally Posted by ledoc View Post
The problem you have is quite common. Modern, over-engineered desktop environment and nvidia card in low power state don't mix well.

IIRC you can't do exactly what you'd like to do (i.e. impose a min freq). What should work is to force max performance mode and at the same time underclock. Then it should stay at the frequency you underclock it to and you might get reasonable heat/power consumption and reasonable performance. Of course it won't be adaptive any more..
Thanks for your reply~
I think this feature is not difficult to implement, and it is really very useful.
Maybe I don't know the way to configure the driver. I have read this , and do some changes in device section in /etc/X11/xorg.conf
Code:
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3; powerMizerDefaultAC=0x2"
0x33 in PerfLevelSrc means adaptive in AC mode.
But in this mode, poserMizerDefaultAC=0x2 will be ignored... So what I have done is useless.
justmao945 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.