Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-14-12, 09:01 PM   #1
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Flash player full screen mode broken with nVidia?

Hi there,

when I play a video on Youtube and switch to fullscreen mode the video actually does not expand over the whole screen.

This did not happen with a AMD/ATI system, thus I guess this is a nVidia issue. Can someone confirm this fullscreen isssue? My nephew can perfectly switch to fullscreen with his AMD/ATI setup and it really uses the whole screen.

My setup:
GeForce 210 mobile
Firefox 11
295.40 drivers x86_64

Thanx
Malte
pinguin74 is offline   Reply With Quote
Old 04-15-12, 11:23 AM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: Flash player full screen mode broken with nVidia?

Look here.
artem is offline   Reply With Quote
Old 04-15-12, 01:11 PM   #3
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Flash player full screen mode broken with nVidia?

No this has nothing to do with 'broken' flash, it is a problem with youtube only and it is caused when used with twinview. I don't remember the exact cause - probably has to do with how twinview presents the total resolution but since it happens only on youtube I would expect youtube to fix it's code.
gbil is offline   Reply With Quote
Old 04-15-12, 03:09 PM   #4
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Re: Flash player full screen mode broken with nVidia?

Quote:
Originally Posted by gbil View Post
No this has nothing to do with 'broken' flash, it is a problem with youtube only and it is caused when used with twinview. (...)
I have a notebook, connected to an external 22" screen. How can I see, whether I use twinview? I have attached my xorg.conf, is there any sign I have twinview enabled?

What could I do different to avoid twinview? I only want to use my external 22", I do not need to use the notebook´s screen.

my xorg.conf:


Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Thu Apr 22 20:36:15 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "evdev"
    Option         "Device" "/dev/input/by-id/usb-Logitech_USB-PS_2_Optical_Mouse-event-mouse"
    Option         "CorePointer"

    #Identifier	"Mouse0"
    #Driver	"evdev"
    #Option	"Buttons" "9"
    #Option	"Name" "Logitech MX400 Mouse"
    #Option	"ButtonMapping" "1 2 3 6 7 8 9"
    #Option	"ZAxisMapping" "4 5 6 7"
    Option	"Resolution" "800"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    #Driver	"nouveau"
    #Driver	"nouveau"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce G210M"
    Option	"CursorShadow" "true"
    Option	"NoLogo" "true"
    #Option	"BackingStore" "true"
    #Option	"OnDemandVBlankInterrupts" "true"
    #Option	"AddARGBGLXVisuals" "true"
    #Option	"DamageEvents" "true"
    #Option	"UseCompositeWrapper" "true"
    #Option	"XvmcUsesTextures" "true"
    #Option	"TripleBuffer" "true"
    #Option	"AllowGLXWithComposite" "true"
    #Option	"UseEvents" "false"

    # Option         "DPI" "85 x 83"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: 1600x900_60 +0+0, CRT: 1680x1050_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
pinguin74 is offline   Reply With Quote
Old 04-15-12, 03:59 PM   #5
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: Flash player full screen mode broken with nVidia?

You can try disabling the internal panel in nvidia-settings. Or change the MetaMode in your configuration to not include your DFP. As gbil said, Youtube computes the aspect ratio of the fullscreen video using the aspect of the total desktop area rather than just the display you're maximizing on, resulting in this problem. I'm assuming the AMD configuration you were referring to was single-display?
Plagman is offline   Reply With Quote
Old 04-16-12, 01:30 PM   #6
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Re: Flash player full screen mode broken with nVidia?

Quote:
Originally Posted by Plagman View Post
You can try disabling the internal panel in nvidia-settings. Or change the MetaMode in your configuration to not include your DFP.
I did it now this way, I just have set the CRT first:

Code:
Option         "TwinViewXineramaInfoOrder" "CRT-0"
and I left the metamodes just as they were before:

Code:
Option         "metamodes" "DFP: 1600x900_60 +0+0, CRT: 1680x1050_60 +0+0"

This way it works now! I can now switch to fullscreen with flash and the whole screen of the external monitor is used!


Quote:
Originally Posted by Plagman View Post
I'm assuming the AMD configuration you were referring to was single-display?
Yes, you are right. This was a AMD C-50 based netbook with one single screen, the internal DFP.

Thanx for you hints and information!
pinguin74 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.