Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-30-12, 01:04 PM   #13
searchfgold6789
Registered User
 
Join Date: Apr 2012
Posts: 8
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

I saw a bug report for this issue in Launchpad and it was a little worrying... It seems that the most that can be done is removing it from Jockey. They're not taking it out of the repos, because there might be an update yet.
Here is the "official" bug report in Ubuntu for this problem: https://bugs.launchpad.net/ubuntu/+s...73/+bug/948053
(Note: the bug report is that the drivers are uninstallable; NVidia still needs to upgrade them.)
Here is the bug report with nVidia: http://nvidia-submit.custhelp.com/ap...il/i_id/419011 (that might just be my account's link, I'll update it when/if possible if that's the case)
searchfgold6789 is offline   Reply With Quote
Old 05-01-12, 07:04 PM   #14
searchfgold6789
Registered User
 
Join Date: Apr 2012
Posts: 8
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Yeah they said they're not gonna update it.
searchfgold6789 is offline   Reply With Quote
Old 05-02-12, 12:32 AM   #15
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Who said that, and what exactly was said? We're working on new ABI support for legacy branches right now; we're very sorry for the delays, we've been very busy with other stuff.
Plagman is offline   Reply With Quote
Old 05-02-12, 03:38 AM   #16
PenguinPower
Registered User
 
Join Date: Apr 2012
Posts: 12
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

That's very good news!
I never saw a statement by NVidia that support was dropped. On the contrary, Plagman stated before:
Quote:
Recent ABI support for the 173 legacy driver series is still on the roadmap; it hasn't been dropped.
Hopefully the 96.xx.xx won't be forgotten either.

So all in all very good news. Of course i understand that these cards won't have top-priority anymore, and i certainly don't want to sound too pushy, but should we think about weeks or months?
PenguinPower is offline   Reply With Quote
Old 05-02-12, 04:25 PM   #17
BilaRC
Registered User
 
Join Date: Mar 2012
Posts: 6
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

I hope it will be weeks not months...

Thanks for the good news!!!
BilaRC is offline   Reply With Quote
Old 05-02-12, 09:09 PM   #18
searchfgold6789
Registered User
 
Join Date: Apr 2012
Posts: 8
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Quote:
Originally Posted by Plagman View Post
Who said that, and what exactly was said? We're working on new ABI support for legacy branches right now; we're very sorry for the delays, we've been very busy with other stuff.
nVidia gave me an email saying that 173 has dropped support for the latest verison of Xorg, but the current driver (250 or something) is compatible. The latest nVidia driver, however, does not support out graphics cards.

Thank you so much, Xorg team, for working on this. I eagerly anticipate the new ABI versions!
searchfgold6789 is offline   Reply With Quote
Old 05-06-12, 06:51 AM   #19
SamanthaDL
Registered User
 
Join Date: Apr 2012
Posts: 4
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Plagman, searchfgold6789, thank you for the information.

In the meanwhile I discovered that the reason my box became so unstable after the upgrade was, because the video card fan was jammed with dust (overheating), plus the memory chip AND the power supply were breaking down fast. Reinstalled 11.10 and kept having the same issues. Oh, the fun of trying to pinpoint broken hardware when actually 2 parts are failing.

So now, it comes down to waiting for the new driver ABI versions to be fixed, then upgrading to 12.04 again.
Thank you Nvidia, for your time and efforts.

(By the way, I was wondering - to get the old drivers working with the new Xorg ABI, is it something as easy as bumping the driver ABI version, or does it actually need rewrites/adaptations due to xorg ABI calls being different in the new version?)
SamanthaDL is offline   Reply With Quote
Old 05-06-12, 07:45 AM   #20
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Quote:
Originally Posted by SamanthaDL View Post
(By the way, I was wondering - to get the old drivers working with the new Xorg ABI, is it something as easy as bumping the driver ABI version, or does it actually need rewrites/adaptations due to xorg ABI calls being different in the new version?)
Does Option IgnoreABI work? No? Then it needs actual rewrite of the driver code.
poltsy is offline   Reply With Quote

Old 05-06-12, 08:49 AM   #21
PenguinPower
Registered User
 
Join Date: Apr 2012
Posts: 12
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Quote:
Originally Posted by SamanthaDL View Post
(By the way, I was wondering - to get the old drivers working with the new Xorg ABI, is it something as easy as bumping the driver ABI version, or does it actually need rewrites/adaptations due to xorg ABI calls being different in the new version?)
XorgModuleABIVersions
As far as i know, this ABI is a virtual package provided by xorg. So you can not play around with different versions independent of the installed xorg version.
Quote:
Originally Posted by poltsy View Post
Does Option IgnoreABI work? No? Then it needs actual rewrite of the driver code.
In standard Ubuntu you can't even install it (unless you probably find some way to force it), so you don't even get to the point of trying that option in xorg.conf.
PenguinPower is offline   Reply With Quote
Old 05-08-12, 09:17 AM   #22
SamanthaDL
Registered User
 
Join Date: Apr 2012
Posts: 4
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

I have looked into what poltsy and PenguinPower said.

I managed to install the nvidia-173 drivers (on my temporary ubuntu 12.04 test install) by getting them from the nvidia website and running their script installer. That went all well, the driver installed etc.

I tried the IgnoreAbi option. The 173 drivers do load and the xorg server comes up in a whopping 640x480 resolution. I tried to force a higher resolution by throwing the correct monitor HorizSync and Vertrefresh values into xorg.conf, which did not work.

Why does it not want to go into a higher res? My very wild guess would be, because the drivers cannot set the mode in the new ABI? I honestly have no idea.

So, yes, IgnoreAbi can work (altough a *lot* of people on other forums get completely different results, like crashes), and no, it does not work all that great.
SamanthaDL is offline   Reply With Quote
Old 05-08-12, 03:58 PM   #23
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

IgnoreABI is not expected to work here; please don't recommend that people try it.

We're working on an update to 173.14.* for xservers 1.11 and 1.12.
AaronP is offline   Reply With Quote
Old 05-08-12, 05:19 PM   #24
PenguinPower
Registered User
 
Join Date: Apr 2012
Posts: 12
Default Re: NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04

Quote:
Originally Posted by AaronP View Post
We're working on an update to 173.14.* for xservers 1.11 and 1.12.
Will the 96.xx.xx driver be updated as well?
PenguinPower is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.