Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-12, 12:53 PM   #13
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by ledoc View Post
Seems to affect only nv50 family chips then?
Most likely, except there's a person in the thread who mentions GTX285.
artem is offline   Reply With Quote
Old 05-09-12, 04:36 PM   #14
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by artem View Post
Most likely, except there's a person in the thread who mentions GTX285.
Which falls into "nv50 class GPU" which basically covers
Quote:
GeForce 8, GeForce 9, GeForce 100, GeForce 200, GeForce 300
[1]
Dragoran is offline   Reply With Quote
Old 05-09-12, 10:49 PM   #15
mdriftmeyer
Registered User
 
Join Date: Feb 2009
Posts: 40
Default Re: 302.07 no resume from suspend

I'm not seeing any outputs from X or any information on which versions of X each person expressing concern about failure has installed.

I'm sure it will help Nvidia if you folks post your known configuration beyond, the GPU you have installed and which Kernel you are running it on.

After all, wouldn't this be an intercommunication issue between X and Nvidia's driver?/
mdriftmeyer is offline   Reply With Quote
Old 05-10-12, 12:51 AM   #16
ltmon
Registered User
 
Join Date: Mar 2004
Location: Melbourne, Australia
Posts: 9
Default Re: 302.07 no resume from suspend

Getting this problem myself, with drivers installed from Ubuntu Xorg edge PPA (i.e. very recent Xorg). I was assuming using this was at least part of the issue. You can see all the packages it updates from standard Ubuntu 12.04 here:

https://launchpad.net/~xorg-edgers/+...filter=precise

Quadro FX 880M
X.Org X Server 1.12.1 (Release Date: 2012-04-13)
Kernel 3.2.0-24-generic #38-Ubuntu SMP Tue May 1 16:18:50 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

The Xorg log after this problem shows nothing post suspend -- just the messages it gives when suspending. None of the other system logs show anything at all either.

Nvidia bug report attached if it's useful.

Luke.
Attached Files
File Type: gz nvidia-bug-report.log.gz (64.7 KB, 95 views)
ltmon is offline   Reply With Quote
Old 05-10-12, 04:38 AM   #17
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: 302.07 no resume from suspend

There is the only nvidia-bug-report attached to this thread.

Please, if you are affected by this bug, post your nvidia-bug-report as well.
artem is offline   Reply With Quote
Old 05-10-12, 05:20 AM   #18
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: 302.07 no resume from suspend

NVIDIA internal Bug ID: 983043 to track this issue.
sandipt is offline   Reply With Quote
Old 05-10-12, 10:31 PM   #19
ngoonee
Registered User
 
Join Date: Jul 2010
Posts: 12
Default Re: 302.07 no resume from suspend

Attaching my own, should I have reinstalled 302.07 to run it? As I understand it nvidia-bug-report.sh is mainly to provide system-specific data?
Attached Files
File Type: gz nvidia-bug-report.log.gz (51.3 KB, 75 views)
ngoonee is offline   Reply With Quote
Old 05-11-12, 05:03 AM   #20
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by ngoonee View Post
Attaching my own, should I have reinstalled 302.07 to run it? As I understand it nvidia-bug-report.sh is mainly to provide system-specific data?
It's not necessary to reinstall 302.07 to run it. You're right.
artem is offline   Reply With Quote

Old 05-14-12, 02:03 PM   #21
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by sandipt View Post
Please provide nvidia bug report

http://nvnews.net/vbulletin/showthread.php?t=180018

For another report if you need it. Thanks for working on it, I hope that there will be a fix soon.

Fuchs
NvFuchs is offline   Reply With Quote
Old 05-14-12, 07:37 PM   #22
MsTiFtS
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: 302.07 no resume from suspend

Same here, on a Lenovo T410 with nVidia Quadro NVS 3100m running Ubuntu 12.04 LTS with 302.07 driver from xorg-edgers.

Suspend to disk/RAM fails to wake up properly, displaying only a black screen, and I have to resort to sysrq to reboot it. If, however, I switch to tty1-6 before suspending, it wakes up just fine, and will only lock up as soon as I switch back to tty7 (X server). If, after suspending/resuming, I restart the X server before switching back to it, things continue to work fine. Those various pm-suspend quirks don't seem to help at all.

As soon as the problem occurs I get a couple of these messages in dmesg:
Code:
NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context.
Feel free to contact me for further details, I'm very willing to help nail this down or test beta drivers. This bug is really driving me nuts.
Attached Files
File Type: gz nvidia-bug-report.log.gz (69.0 KB, 85 views)
MsTiFtS is offline   Reply With Quote
Old 05-17-12, 10:28 AM   #23
valentine
Registered User
 
Join Date: Mar 2004
Posts: 1
Default Re: 302.07 no resume from suspend

Affects me as well.

Lenovo Thinkpad W510
01:00.0 VGA compatible controller: NVIDIA Corporation GT216 [Quadro FX 880M] (rev a2)
Ubuntu 12.04
nvidia-current 302.07-0ubuntu1~xedgers~precise1
Attached Files
File Type: gz nvidia-bug-report.log.gz (69.3 KB, 79 views)

Last edited by valentine; 05-17-12 at 10:30 AM. Reason: Forgot to attach bug-report
valentine is offline   Reply With Quote
Old 05-17-12, 12:16 PM   #24
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: 302.07 no resume from suspend

I'm seeing a similar problem, except that my system doesn't lock up while resuming, but when it's just about to power down for sleeping. All I get is a black screen with a text cursor blinking in the top left corner. Switching to other ttys has no effect.

9800M GTS, kernel 3.4-rc7, Arch Linux 64bit
Attached Files
File Type: gz nvidia-bug-report.log.gz (38.1 KB, 99 views)
MadCatX is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] NVIDIA 302.07 console restore broken ioni NVIDIA Linux 10 12-26-12 06:02 PM
ViewPortIn and ViewPortOut in 302.07 Licaon NVIDIA Linux 14 08-05-12 05:32 AM
NVIDIA 302.07 - missing apps: nvidia-settings, nvidia-installer, nvidia-xconfig zbiggy NVIDIA Linux 3 05-02-12 04:04 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM

All times are GMT -5. The time now is 02:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.