Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-16-12, 01:56 AM   #1
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Hi, I searched through the forum and couldn't found any workaround, hence starting a new thread, hopefully I'd submit sufficient information to start a bug report.

My configuration: AMD Fusion processor A4-3300 + GT520 PCI-E card, 8GB RAM, running Ubuntu 12.04 LTS, Nvidia 295.49 driver installed from Nvidia website, HDMI out to TV.

Symptom:
1) During boot -
I've got some kernel tainted message with kernel trace during boot when trying to review dmesg. This occurs during EFI boot but not BIOS boot. However, X starts up properly and everything runs properly. Tried light OpenGL stuff (XBMC, Unity), browser (chrome) and video (VDPAU). Everything runs fine. Just that the kernel trace occurs.

2) During X restart (this occurs both in EFI mode or BIOS mode)
When I try to logoff the machine, Ubuntu would quit and restart lightdm (which I believe, will subsequently restart X server). X won't come up. The machine is still responsive, Kernel tainted message and Xid messages comes up in dmesg. Xorg.0.log does not have much error message.

I tried to SSH in, sudo service lightdm restart (in ubuntu) and the symptom is exactly the same.

The 2nd symptom is obviously annoying as I can't logoff X session but have to restart whenever I want to switch to another user in console. However, I don't have any random crash (very rare, and can't really prove to be nvidia's issue) when I'm running the machine normally.

Attached is the nvidia-bug-report for both when the machine is started and when X is restarted.
Attached Files
File Type: gz nvidia-bug-report.log-boot.gz (53.2 KB, 91 views)
File Type: gz nvidia-bug-report.log-restart.gz (50.5 KB, 91 views)
mikejuni is offline   Reply With Quote
Old 05-16-12, 06:53 PM   #2
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

295.53 new driver does not resolve the issue. New bug report.
Attached Files
File Type: gz nvidia-bug-report.log.gz (59.2 KB, 86 views)
mikejuni is offline   Reply With Quote
Old 05-17-12, 07:14 AM   #3
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Reposting bug report with startx -- -logverbose 6

I've even more serious issue today that I can't even login first time to the system with Unity (XBMC seems work fine though).

Please, fix it. It is extremely annoying that the card is almost rendered useless. I did all this with SSH.
Attached Files
File Type: gz nvidia-bug-report.log.gz (75.4 KB, 79 views)
mikejuni is offline   Reply With Quote
Old 05-18-12, 12:52 AM   #4
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Got some minor updates. First time logon issue seems unrelated to Nvidia but rather gnome-session segfaulted.

However I'm still having issue with X server restart. The bug report is already updated in the last post. It is still annoying that whenever I've to switch user I've got to reboot the machine

Some further updates - Updating AMD microcode (I'm running fusion processor) doesn't help.
mikejuni is offline   Reply With Quote
Old 05-19-12, 06:38 PM   #5
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Another update after installing 302.11 beta driver. The issue is still there.

When I try to logoff (or kill X and restart X) the screen goes blank. Seems no response from Keyboard and have to reboot via SSH.

Attached is updated bug log.
Attached Files
File Type: gz nvidia-bug-report.log.gz (72.3 KB, 80 views)
mikejuni is offline   Reply With Quote
Old 05-19-12, 07:22 PM   #6
GRam
Registered User
 
Join Date: Feb 2012
Posts: 3
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Hi Mike it looks like it failing while trying to talk to HDMI based PhilipsTV display device. Can you see if same behavior is noticed when using any normal DVI based monitor.
GRam is offline   Reply With Quote
Old 05-19-12, 07:52 PM   #7
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

I don't have another monitor to test it with....

Any workaround that could potentially reset the HDMI to make it work? I don't have this problem with the on-board AMD card.
mikejuni is offline   Reply With Quote
Old 05-20-12, 04:33 AM   #8
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Some more updates:

I tried to use "ConnectedMonitor" and "UseDisplayDevice" to force the display to HDMI port. Still screen goes dark after exiting X and have it restarted (initial startup is perfectly ok, wake from sleep is ok too).

Are there any way that I can workaround by issuing some command after X started to reset HDMI port or I've to wait for a driver fix?

The same monitor doesn't have issue with AMD graphics.
mikejuni is offline   Reply With Quote

Old 05-20-12, 12:56 PM   #9
GRam
Registered User
 
Join Date: Feb 2012
Posts: 3
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

From what I can guess it is not display part of the driver that is causing the issue. It is audio part of the driver that is causing the problem. That is why I wanted to see if any other monitor without audio capability show the same behavior.
GRam is offline   Reply With Quote
Old 05-20-12, 06:29 PM   #10
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Any help from Nvidia? I know that at least 1 other people experience the same issue as well by searching through the forum. Any bug report that we can track the status?
mikejuni is offline   Reply With Quote
Old 05-21-12, 08:30 PM   #11
mikejuni
Registered User
 
Join Date: May 2012
Posts: 11
Default Re: Nvidia driver stopped working after X restart and Kernel taint msgs during boot

Another update - Putting kernel driver into persistent mode (nvidia-smi -pm 1) seems to fix the problem. So it seems the problem lies with the kernel driver not being able to reset the display properly during unload/reload.
mikejuni is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 06:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.