Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-08-12, 02:20 PM   #25
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: VDPAU and KDE 4.8 compositing = slow

NVIDIA Internal Bug ID: 941012 to track this issue. We are able to reproduce this performance drop.
sandipt is offline   Reply With Quote
Old 05-22-12, 08:47 AM   #26
rascas
Registered User
 
Join Date: May 2012
Posts: 3
Default Re: VDPAU and KDE 4.8 compositing = slow

I have the same issues as RealNC and Pie-rate.
Especially RealNC and i have a very similar machine (i5-2500k + Geforce 560 ti) although im running Arch Linux 64-bit. All the system packages are at the latest stable versions, including the geforce driver (295.53).

One more thing i notice is that playing a file with mplayer + vdpau (composition enabled), i get a high cpu load for X.org process according to top. This is particularly visible playing a big, HD video (ex: 8 Gb 1080p 23.9 fps x264 compressed video).

If i do the same above thing but with the Kwin "Suspend desktop effects for fullscreen windows" option enabled, in windowed mode the same applies (high cpu load for X, slow desktop response, frame skipping).
But if then i go fullscreen and let the video play for some seconds, the frame skipping stops. Then if i go quickly into window mode again and look to top, i briefly see that X wasnt using alot of cpu (everything looked to behave normally when the video was playing FS). But of course in window mode the problems come back. So it seems that that option does what its supposed to do (at least with mplayer) and the problem maybe between the driver communication with X and then Kwin composition.

But even the Kwin "Suspend desktop effects for fs windows" is not a option because with that enabled, flash in fullscreen has tearing. And i cant use hardware acceleration with flash because the plugin is always crashing.
And i have to use Xv or GL to watch video files.

Hope you can find a solution for this since this is a problem that exists for a quite few time.

Regards
rascas is offline   Reply With Quote
Old 05-22-12, 09:06 AM   #27
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: VDPAU and KDE 4.8 compositing = slow

All this talk of green has be thinking... Green is the default overlay color. But overlay shouldn't be used when compositing is active, in fact docs say it's automatically off when a compositor is running. But it seems that's not the case with kwin. So have you guys tried exporting
Code:
VDPAU_NVIDIA_NO_OVERLAY=1
?

Also, RealNC, Xv is not better than VDPAU when using software decoding. VDPAU has high-quality scaling.
Gusar is offline   Reply With Quote
Old 05-22-12, 09:35 AM   #28
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

Just tried it. I've set VDPAU_NVIDIA_NO_OVERLAY=1 in /etc/profile and restarted X. No go; it doesn't seem to have any effect.
RealNC is offline   Reply With Quote
Old 05-22-12, 11:55 AM   #29
rascas
Registered User
 
Join Date: May 2012
Posts: 3
Default Re: VDPAU and KDE 4.8 compositing = slow

Hi Gusar

Your advice didnt solve the video player + vdpau + composition in KDE but it helped me to fix my problems with flash.
I exported that command system wide (in ~/.bashrc for me) and now i can watch fullscreen videos in flash with HW acceleration without tearing and constant crashes in firefox and chrome. Seems to work very good!

Thank you very much

Still hope that the devs can fix the main thread problem.
rascas is offline   Reply With Quote
Old 05-23-12, 02:01 AM   #30
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: VDPAU and KDE 4.8 compositing = slow

For me VDPAU_NVIDIA_NO_OVERLAY=1 makes a little difference, other than introduce tearing in some cases.
Anyway, if you use mplayer, maybe you can try mplayer-vaapi which doesn't give that problem (if it does, you can also try -vo vaapi:gl)
You'll lose some of the vdpau output driver option, like temporal deinterlacer.
kokoko3k is offline   Reply With Quote
Old 05-23-12, 07:07 AM   #31
rascas
Registered User
 
Join Date: May 2012
Posts: 3
Default Re: VDPAU and KDE 4.8 compositing = slow

kokoko3k you are right! VDPAU_NVIDIA_NO_OVERLAY=1 makes no difference in flash. I thought that was working because some pages were working but some still not (like vimeo).

But i found another solution that works for me. In the matter of fact i found some different alternatives according to this: https://wiki.archlinux.org/index.php...#Configuration (see the last part).

The one that worked best for me was the patched libvdpau from git, i think the patches were made by one nvidia developer. The patches only affects flash operation. Only needed to install https://aur.archlinux.org/packages.php?ID=59181. Disable the option "EnableLinuxHWVideoDecode=1" in /etc/adobe/mms.cfg and thick the box to enable hardware acceleration in adobe settings while playing a embbeded video. Thats it.
No more tearing. It uses less cpu than the pepper plugin for chrome and no crashes till now.

Hope it helps.

Will test the mplayer-vaapi now.
rascas is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.