Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-14-12, 02:43 AM   #73
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 302.07 no resume from suspend

Works fine here with 304.22 (GTX 285)
Dragoran is offline   Reply With Quote
Old 07-14-12, 05:22 AM   #74
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: 302.07 no resume from suspend

Also works fine with 304.22 and GT330M Thx very much
XjCook is offline   Reply With Quote
Old 07-14-12, 05:54 AM   #75
theDOC
Registered User
 
Join Date: Jan 2004
Posts: 21
Default Re: 302.07 no resume from suspend

Works fine here, too, with 304.22 on a Quadro FX 770M
theDOC is offline   Reply With Quote
Old 07-14-12, 09:29 AM   #76
MsTiFtS
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: 302.07 no resume from suspend

Confirmed fixed (with vga=normal) on Lenovo T410 with NVS3100m, Ubuntu 12.04 xorg-edgers as of now (304.22).
I'll probably try without vga=normal soon.
MsTiFtS is offline   Reply With Quote
Old 08-03-12, 01:37 PM   #77
kpl388
Registered User
 
Join Date: Aug 2012
Posts: 4
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by Lemmiwinks View Post
@danix: You are right! It does indeed fail for an entirely different reason. It does not have anything to do with the Nvidia drivers but with grub/plymouth/Ubuntu.

I found out that selecting recovery mode in grub but then resuming the normal boot, there aren't any issues at all anymore. So what are the differences between normal boot and recovery boot except for no "quiet splash" but "recovery in the grub command line?
The answer is, some weird Ubuntu stuff in /etc/grub.d/10_linux, "Native boot entries", especially the line "gfxmode \$linux_gfx_mode". What it does: makes the boot process beautiful with plymouth, which works great as long as you use the default ubuntu kernel from the repos. When you have issues with that kernel and want to try a different one you run into serious problems like I described in the post above. Thank you Canonical!

But really thanks to nvidia for their new driver, its awesome to have dkms support inculuded.
Thanks, Lemmiwinks. I'm having the exact problem you are describing, with the system hanging and showing a purple horizontal bar on return from standby. Just to be clear, you commented out these lines from /etc/grub.d/10_linux:
Code:
#      cat << EOF
#       gfxmode \$linux_gfx_mode
#EOF
and ran

Code:
sudo update-grub
- sound right?
kpl388 is offline   Reply With Quote
Old 08-04-12, 01:18 AM   #78
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by kpl388 View Post
Thanks, Lemmiwinks. I'm having the exact problem you are describing, with the system hanging and showing a purple horizontal bar on return from standby. Just to be clear, you commented out these lines from /etc/grub.d/10_linux:
Code:
#      cat << EOF
#       gfxmode \$linux_gfx_mode
#EOF
and ran

Code:
sudo update-grub
- sound right?
Not quite, I just commented out gfxmode \$linux_gfx_mode in 10_linux, so:

Code:
      cat << EOF
#       gfxmode \$linux_gfx_mode
EOF
But maybe both work, should be safe to try out both of them, since editing the 10_linux file should not harm grub's functionality.

Then
Code:
sudo update-grub
, correct.

Maybe there is another possible solution you could try out first: there might be a problem with network-manager and the nvidia driver. Could you try to resume while network-manager is disabled?
Type
Code:
sudo service network-manager stop
and
Code:
sudo killall wpa_supplicant
in a gnome-terminal, then try to suspend and resume as often as possible.
Btw, does it also work for you with the nouveau drivers?
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 08-06-12, 06:21 AM   #79
kpl388
Registered User
 
Join Date: Aug 2012
Posts: 4
Default Re: 302.07 no resume from suspend

Thanks for the suggestions. Unfortunately though, neither seems to work for me. I don't seem to be running a process call wpa_supplicant, but disabling network manager gave me the same result with the horizontal purple bar. Commenting out the gfx_mode line in /etc/grub.d/10_linux, made the bootup process a lot uglier, as expected, but still gives me a hung system when resuming from standby. This time however, there is no purple bar, just a black screen.

Also, fwiw - I'm running the 304.22 drivers.
kpl388 is offline   Reply With Quote
Old 08-06-12, 09:12 AM   #80
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: 302.07 no resume from suspend

kpl388,

post nvidia-bug-report information please
artem is offline   Reply With Quote

Old 08-06-12, 09:52 AM   #81
kpl388
Registered User
 
Join Date: Aug 2012
Posts: 4
Default Re: 302.07 no resume from suspend

Bug report log attached. Please let me know if anything else would be helpful.
Attached Files
File Type: gz nvidia-bug-report.log.gz (71.6 KB, 59 views)
kpl388 is offline   Reply With Quote
Old 08-08-12, 03:36 AM   #82
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by kpl388 View Post
Thanks for the suggestions. Unfortunately though, neither seems to work for me. I don't seem to be running a process call wpa_supplicant, but disabling network manager gave me the same result with the horizontal purple bar. Commenting out the gfx_mode line in /etc/grub.d/10_linux, made the bootup process a lot uglier, as expected, but still gives me a hung system when resuming from standby. This time however, there is no purple bar, just a black screen.

Also, fwiw - I'm running the 304.22 drivers.
Okay did you also check whether it works with the nouveau driver? Therefore you would have to uninstall the nvidia drivers first, remove the /etc/X11/xorg.conf and make sure that the nouveau driver package is installed in your distro.
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 08-14-12, 08:40 AM   #83
kpl388
Registered User
 
Join Date: Aug 2012
Posts: 4
Default Re: 302.07 no resume from suspend

Sorry for the delayed reply - I've been trying to get a better handle on what's going on. I uninstalled the nvidia driver. I'm using the mythbuntu distro and it seems nouveau is installed already. But, I experienced the same symptoms: complete freeze on resume from standby and fresh reboot on return from hibernate. So I guess maybe my problem is not nvidia driver related and probably belongs in a different forum.

I tried using the using the uswsusp tools, but got a similar result. I also tried installing a tuxonice kernel. This gave me a bit more feedback, but still hangs on resume from standby. Interestingly, it attempts to return from hibernate, but hangs on the purple ubuntu screen that says it's resuming from /dev/disk/by-uuid/*****
Also possibly related: anytime I install a package that runs update-initramfs, I get the message:
Code:
cryptsetup: WARNING: failed to detect canonical device of /dev/sdh7
This is my swap device. The uuid in /etc/fstab (and returned by blkid) matches that in /etc/initramfs-tools/conf.d/resume.

Any suggestions or, if not, guidance on where I should seek help for this problem would be greatly appreciated!
kpl388 is offline   Reply With Quote
Old 08-14-12, 01:38 PM   #84
firesock
Registered User
 
Join Date: Jun 2012
Posts: 2
Default Re: 302.07 no resume from suspend

Quote:
Originally Posted by AaronP View Post
Could you please try the 304.22 beta release?
I can confirm this works for me too! Much thanks!
firesock is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] NVIDIA 302.07 console restore broken ioni NVIDIA Linux 10 12-26-12 06:02 PM
ViewPortIn and ViewPortOut in 302.07 Licaon NVIDIA Linux 14 08-05-12 05:32 AM
NVIDIA 302.07 - missing apps: nvidia-settings, nvidia-installer, nvidia-xconfig zbiggy NVIDIA Linux 3 05-02-12 04:04 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM

All times are GMT -5. The time now is 07:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.