Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-10-12, 11:57 AM   #1
NHOjar
Registered User
 
Join Date: Feb 2012
Posts: 9
Angry Nvidia 304.32 new xorg.conf update breaks panning

I have F16 for my laptop machine, with both Twin-View and Panning on the "laptop screen" enabled and all has well for about 1 year.
1. I performed a "yum update" and I found that xorg,conf - I believe was available as an update, and I accepted it. The Nvidia driver has not been upgraded for a while.
2. I got a new Logitech TrackBall mouse and I wanted to test it out so I rebooted my PC.
- I placed the mouse in a USB 3.0 socket, my USB 2.0 was occupied by my phone.

Since that change my Panning, only configured on the laptop screen, is half-working.
Main laptop screen: 1920x1080 , with panning: 1920x1400

On restart, the PC would not go into graphical mode on the boot console, it hung there. I removed the Logitech mouse from the USB3.0 port and my laptop booted fine. After login:
a. Its the first time that I have noticed the large Nvidia logo have a small RED "beta" label at the bottom of it
b. I found that the Gnome had started in fall-back mode and
c. The Desktop background only covered the "standard" part of the screen and not the
additional lower "panned" part of the screen.
d. The "system Tray" and the external Disks, on my Docking Station all appear at the
bottom of the lower panned area
e. Docky, set to "auto-hide", is activated at the bottom of the "standard" part of the
screen and not the additional lower "panned" part of the screen. This worked
previously prior to upgrade
f. Trying to update the nvidia-settings now produces errors, stating that entries must
have unique names and some entry names are too long and I clicked the auto-repair

Remedies tried:-
1. I removed the xorg.conf entries for the Logitech Trackball mouse and logged out/in - no change
1. Saved the original xorg.conf file and copied over the contents from the xorg-nvidia.conf, and restarted the machine, no change

Not sure what else to do ....

================================================== ===

rpm -qa *\nvidia\* *\kernel\* *xorg*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.7-3.fc16.x86_64
akmod-nvidia-304.32-2.fc16.x86_64
kernel-3.4.4-4.fc16.x86_64
kernel-3.4.6-1.fc16.x86_64
kernel-3.4.7-1.fc16.x86_64
kernel-devel-3.4.4-4.fc16.x86_64
kernel-devel-3.4.6-1.fc16.x86_64
kernel-devel-3.4.7-1.fc16.x86_64
kernel-headers-3.4.7-1.fc16.x86_64
kernel-tools-3.4.7-1.fc16.x86_64
kmod-nvidia-3.4.4-4.fc16.x86_64-304.32-2.fc16.x86_64
kmod-nvidia-3.4.6-1.fc16.x86_64-295.59-1.fc16.5.x86_64
kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64
libreport-plugin-kerneloops-2.0.10-3.fc16.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-apps-7.6-2.fc15.x86_64
xorg-x11-drivers-7.4-2.fc15.x86_64
xorg-x11-drv-acecad-1.5.0-2.fc16.x86_64
xorg-x11-drv-aiptek-1.4.1-2.fc16.x86_64
xorg-x11-drv-apm-1.2.3-8.fc16.x86_64
xorg-x11-drv-ast-0.91.10-7.fc16.x86_64
xorg-x11-drv-ati-6.14.3-4.20120201git36c190671.fc16.x86_64
xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64
xorg-x11-drv-dummy-0.3.4-7.fc16.x86_64
xorg-x11-drv-elographics-1.3.0-2.fc16.x86_64
xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16.x86_64
xorg-x11-drv-fbdev-0.4.2-2.fc16.x86_64
xorg-x11-drv-fpit-1.4.0-2.fc16.x86_64
xorg-x11-drv-glint-1.2.5-2.fc16.x86_64
xorg-x11-drv-hyperpen-1.4.1-2.fc16.x86_64
xorg-x11-drv-i128-1.3.4-9.fc16.x86_64
xorg-x11-drv-i740-1.3.2-9.fc16.x86_64
xorg-x11-drv-intel-2.19.0-3.fc16.x86_64
xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64
xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64
xorg-x11-drv-mga-1.4.13-8.fc16.x86_64
xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64
xorg-x11-drv-mutouch-1.3.0-2.fc16.x86_64
xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64
xorg-x11-drv-nv-2.1.18-8.fc16.x86_64
xorg-x11-drv-nvidia-304.32-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-304.32-1.fc16.x86_64
xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64
xorg-x11-drv-penmount-1.5.0-3.fc16.x86_64
xorg-x11-drv-qxl-0.0.21-13.fc16.x86_64
xorg-x11-drv-r128-6.8.1-11.fc16.x86_64
xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64
xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64
xorg-x11-drv-savage-2.3.3-1.fc16.x86_64
xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64
xorg-x11-drv-sis-0.10.3-7.fc16.x86_64
xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64
xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64
xorg-x11-drv-trident-1.3.4-7.fc16.x86_64
xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64
xorg-x11-drv-vesa-2.3.0-9.fc16.x86_64
xorg-x11-drv-vmmouse-12.7.0-2.fc16.x86_64
xorg-x11-drv-vmware-11.0.3-6.fc16.x86_64
xorg-x11-drv-void-1.4.0-2.fc16.x86_64
xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64
xorg-x11-fonts-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-14-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-14-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-15-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-15-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-misc-7.5-4.fc15.noarch
xorg-x11-fonts-truetype-1.0.2-1.fc16.noarch
xorg-x11-fonts-Type1-7.5-4.fc15.noarch
xorg-x11-font-utils-7.5-6.fc15.x86_64
xorg-x11-proto-devel-7.6-12.fc16.noarch
xorg-x11-resutils-7.5-2.fc15.x86_64
xorg-x11-server-common-1.11.4-3.fc16.x86_64
xorg-x11-server-utils-7.5-7.fc16.x86_64
xorg-x11-server-Xephyr-1.11.4-3.fc16.x86_64
xorg-x11-server-Xorg-1.11.4-3.fc16.x86_64
xorg-x11-utils-7.5-3.fc16.x86_64
xorg-x11-xauth-1.0.6-1.fc16.x86_64
xorg-x11-xinit-1.3.1-1.fc16.x86_64
xorg-x11-xkb-utils-7.5-5.fc16.x86_64
xorg-x11-xtrans-devel-1.2.6-2.fc15.noarch
3.4.7-1.fc16.x86_64
nvidia 11244331 45
i2c_core 33895 3 nvidia,i2c_i801,videodev
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.49 (mockbuild@builder1.ovh.rpmfusion.lan) Thu May 3 20:10:18 CEST 2012

# RPM Fusion - nvidia-xorg.conf
#

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection


Section "InputClass"
Identifier "Marble Mouse"
Driver "evdev"
MatchProduct "Logitech USB Trackball"
MatchDevicePath "/dev/input/event*"
MatchIsPointer "yes"
Option "ButtonMapping" "1 9 3 4 5 6 7 2 8"
Option "EmulateWheel" "true"
Option "EmulateWheelButton" "3"
Option "ZAxisMapping" "4 5"
Option "XAxisMapping" "6 7"
Option "Emulate3Buttons" "false"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Lenovo Group Limited"
HorizSync 56.5 - 67.8
VertRefresh 50.0 - 60.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro 2000M"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select +1920+15"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: nvidia-auto-select +1920+15; DFP-0: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

================================
NHOjar is offline   Reply With Quote
Old 08-10-12, 05:29 PM   #2
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Nvidia 304.32 new xorg.conf update breaks panning

That xorg.conf file is something you did as I have made no changes to nvidia-xorg.conf in the 304.32 RPM Fusion driver.


Code:
[root@main-pc leigh]# rpm -qf /etc/X11/xorg.conf
file /etc/X11/xorg.conf is not owned by any package
[root@main-pc leigh]# rpm -qf /etc/X11/nvidia-xorg.conf
xorg-x11-drv-nvidia-304.32-1.fc17.x86_64
[root@main-pc leigh]# cat /etc/X11/nvidia-xorg.conf
# RPM Fusion - nvidia-xorg.conf
# 
Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
EndSection
On initial of the xorg-x11-drv-nvidia package it copies /etc/X11/nvidia-xorg.conf to /etc/X11/xorg.conf



Also FYI yum doesn't change user edited config files in /etc !


P.S

Read the manual as there have many changes in 304.xx

ftp://download.nvidia.com/XFree86/Li...304.32/README/
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 08-13-12, 05:54 PM   #3
NHOjar
Registered User
 
Join Date: Feb 2012
Posts: 9
Unhappy Re: Nvidia 304.32 new xorg.conf update breaks panning

Dear Leigh,

I have reviewed the documents and I do not see anything that will not support the panning that was working up to 2 days ago. I have not changed the Kernel or graphics driver for a while, at least 1 month I would say. The kmod-nvidia for the kernel was downloaded even when I had already build it using akmods.

The panning has been working for at least 1 year. I have used the nvidia-settings utility without ever seeing an error message, not even with the "autofix"

The panning area is available, but Docky appears at the bottom of the 1920x1080 and not at the bottom of 1920x1400 level.

a. I have re-copied over the nvidia-xorg.conf and over-written the xorg.conf
b. I ran up the nvidia-settings utility, as root, and after I defined panning, while saving I got a warning that the configuration had an error, one line was too long. I chose to fix the line myself per the nvidia guide on how to setup panning.
c. The old line was too long, defining multiple un-nececessary values with "Auto". I have reduced the value to the minimum, logged out and then back in with no difference with the panning space being blank.

current stanza:-
# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0, CRT: 1680x1050 +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

========

Previous section from earlier file:-

# Removed Option "metamodes" "DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: 1680x1050 @1680x1400 +1920+0; CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1600x1000 +0+0; CRT: 1600x1000_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_72 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; DFP-0: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1600x1000 +0+0; CRT: 1600x1000_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_72 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: 1680x1050 @1680x1400 +1920+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select +1920+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select @1680x945 +1920+0"
SubSection "Display"
Depth 24
EndSubSection

================================================== =
# uname -a ; rpm -qa | grep nvidia ; cat /etc/X11/xorg.conf
Linux naipaulpc 3.4.7-1.fc16.x86_64 #1 SMP Mon Jul 30 16:37:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64
akmod-nvidia-304.32-2.fc16.x86_64
kmod-nvidia-3.4.4-4.fc16.x86_64-304.32-2.fc16.x86_64
xorg-x11-drv-nvidia-libs-304.32-1.fc16.x86_64
kmod-nvidia-3.4.6-1.fc16.x86_64-295.59-1.fc16.5.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-drv-nvidia-304.32-1.fc16.x86_64
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.49 (mockbuild@builder1.ovh.rpmfusion.lan) Thu May 3 20:10:18 CEST 2012

# RPM Fusion - nvidia-xorg.conf
#

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Lenovo Group Limited"
HorizSync 56.5 - 67.8
VertRefresh 50.0 - 60.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro 2000M"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0, CRT: 1680x1050 +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
NHOjar is offline   Reply With Quote
Old 08-13-12, 09:31 PM   #4
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Nvidia 304.32 new xorg.conf update breaks panning

Quote:
Originally Posted by NHOjar View Post
Dear Leigh,

I have reviewed the documents and I do not see anything that will not support the panning that was working up to 2 days ago. I have not changed the Kernel or graphics driver for a while, at least 1 month I would say. The kmod-nvidia for the kernel was downloaded even when I had already build it using akmods.

The panning has been working for at least 1 year. I have used the nvidia-settings utility without ever seeing an error message, not even with the "autofix"

The panning area is available, but Docky appears at the bottom of the 1920x1080 and not at the bottom of 1920x1400 level.

a. I have re-copied over the nvidia-xorg.conf and over-written the xorg.conf
b. I ran up the nvidia-settings utility, as root, and after I defined panning, while saving I got a warning that the configuration had an error, one line was too long. I chose to fix the line myself per the nvidia guide on how to setup panning.
c. The old line was too long, defining multiple un-nececessary values with "Auto". I have reduced the value to the minimum, logged out and then back in with no difference with the panning space being blank.

current stanza:-
# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0, CRT: 1680x1050 +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

========

Previous section from earlier file:-

# Removed Option "metamodes" "DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: 1680x1050 @1680x1400 +1920+0; CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1600x1000 +0+0; CRT: 1600x1000_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_72 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; DFP-0: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1680x1050_75 +0+0; CRT: 1680x1050_60_0 +0+0; CRT: 1600x1000 +0+0; CRT: 1600x1000_60 +0+0; CRT: 1440x900 +0+0; CRT: 1440x900_75 +0+0; CRT: 1440x900_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_72 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: 1680x1050 @1680x1400 +1920+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select +1920+0; DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select @1680x945 +1920+0"
SubSection "Display"
Depth 24
EndSubSection

================================================== =
# uname -a ; rpm -qa | grep nvidia ; cat /etc/X11/xorg.conf
Linux naipaulpc 3.4.7-1.fc16.x86_64 #1 SMP Mon Jul 30 16:37:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64
akmod-nvidia-304.32-2.fc16.x86_64
kmod-nvidia-3.4.4-4.fc16.x86_64-304.32-2.fc16.x86_64
xorg-x11-drv-nvidia-libs-304.32-1.fc16.x86_64
kmod-nvidia-3.4.6-1.fc16.x86_64-295.59-1.fc16.5.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-drv-nvidia-304.32-1.fc16.x86_64
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.49 (mockbuild@builder1.ovh.rpmfusion.lan) Thu May 3 20:10:18 CEST 2012

# RPM Fusion - nvidia-xorg.conf
#

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Lenovo Group Limited"
HorizSync 56.5 - 67.8
VertRefresh 50.0 - 60.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro 2000M"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: 1920x1080 +0+0, CRT: 1680x1050 +1920+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
I built the nvidia driver package your running less than ten days ago!
Code:
akmod-nvidia-304.32-2.fc16.x86_64

http://download1.rpmfusion.org/nonfr...od-nvidia.html
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 08-14-12, 04:50 AM   #5
NHOjar
Registered User
 
Join Date: Feb 2012
Posts: 9
Default Re: Nvidia 304.32 new xorg-x11-??? update breaks panning

I have updated the title of the thread to reflect the reality of the situation and not just my initial thoughts on the problem.

I have posted a similar thread on a separate Fedora forum - trying to resolve this from a Feodra angle. [Just for additional information.]
http://forums.fedoraforum.org/showth...=1#post1597242
NHOjar is offline   Reply With Quote
Old 08-14-12, 04:57 AM   #6
NHOjar
Registered User
 
Join Date: Feb 2012
Posts: 9
Default Re: Nvidia 304.32 new xorg.conf update breaks panning

Hi Leigh,

Thanks for the update on the build date of this version.
akmod-nvidia-304.32-2.fc16.x86_64

1. I built my own version from akmods when I updated the driver.
2. At some point later I downloaded the kmod-nvidia-304.32-2.fc16.x86_64
3. Then later still I updated the xorg-x11-???

Which all shows that the source source of problem is very recent, and I have been using panning for a comparatively very long time without issue.
NHOjar is offline   Reply With Quote
Old 08-14-12, 04:59 AM   #7
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Nvidia 304.32 new xorg-x11-??? update breaks panning

Quote:
Originally Posted by NHOjar View Post
I have updated the title of the thread to reflect the reality of the situation and not just my initial thoughts on the problem.

I have posted a similar thread on a separate Fedora forum - trying to resolve this from a Feodra angle. [Just for additional information.]
http://forums.fedoraforum.org/showth...=1#post1597242
I know (Yellowman is my aka there).

Try the 304.37 release driver in testing

http://download1.rpmfusion.org/nonfr...iew/index.html

http://www.nvidia.com/object/linux-d...37-driver.html
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 08-21-12, 05:54 PM   #8
NHOjar
Registered User
 
Join Date: Feb 2012
Posts: 9
Default Re: Nvidia 304.32 & new 304.37 update breaks panning

Corrected History:-

After upgrade to 295.59 on Fedora 16, my panned area had some undesirable characteristics:-

The desktop background no longer covered the panned area
Some applications did not recognise the extended area as usable - Docky
Turning the CRT off/on would sometimes disable panning
The nvidia-settings utility would not manage the merging of new settings to the xorg.conf file


I had configured the following:-
a. Twinview over laptop screen and external CRT Display [1920x1080 + 1780x1050]
b. Setup panning only on the laptop screen to extend the screen from 1920x1080 to 1920x1400

The issues seen are compared to the previously correct working of panning since first using Fedora 16, about 7 months ago

Open applications can be :-
a. Moved to the newly define panned area
b. Application windows can be re-sized to occupy the newly define panned area
- with a Docky menu triggered when the mouse crosses into the panned area

Issues:-
a. The Docky menu would camp at the end of the main area and not at the end of the panned area - menus are now appearing in the "middle" of the screen.
b. Newly detected USB disk devices would appear at the lower of the panned area
c. System tray and bin would appear at the lower of the panned area
d. I have replaced the current xorg.conf with the minimalist nvidia-xorg.conf, then configured panning using the nvidia-settings utility
========================================

I have since upgraded the kernel and the nvidia driver on Aug-21 and the situation has been "normalised" to most of the applications do not recognise the defined panning area

New configuration: 304.37

grep nvidia /var/log/yum.log | grep drv-nvidia-libs

Feb 18 22:36:40 Installed: 1:xorg-x11-drv-nvidia-libs-290.10-1.fc16.x86_64
Apr 02 13:32:18 Updated: 1:xorg-x11-drv-nvidia-libs-295.33-3.fc16.x86_64
Apr 16 23:43:02 Updated: 1:xorg-x11-drv-nvidia-libs-295.40-1.fc16.x86_64
May 05 02:50:17 Updated: 1:xorg-x11-drv-nvidia-libs-295.49-1.fc16.x86_64
May 23 11:45:58 Updated: 1:xorg-x11-drv-nvidia-libs-295.49-2.fc16.x86_64
May 29 21:54:04 Updated: 1:xorg-x11-drv-nvidia-libs-295.53-1.fc16.x86_64
Jun 14 23:27:42 Updated: 1:xorg-x11-drv-nvidia-libs-295.59-1.fc16.x86_64
--------- start of issues -----
Aug 09 14:07:13 Updated: 1:xorg-x11-drv-nvidia-libs-304.32-1.fc16.x86_64
Aug 21 03:31:47 Updated: 1:xorg-x11-drv-nvidia-libs-304.37-1.fc16.x86_64



a. Docky does not recognise the defined panned area
b. Newly discovered devices are now displayed at the start of the defined panned area and not at the end
c. The system tray now does not recognise the newly defined panned area
d. The desktop background does not cover the newly defined panned area
e. On login the panned area is correctly defined on the laptop screen - on recovery from sleep or extended screen saver activity either both displays have the same panned area OR neither have the panned area
f. Defining the pan area in the nvidia-settings tool and then attempting to apply, causes both screens to blink and flash for about 10 seconds and then fail to apply the panned area, but the xorg.conf has the panned area defined correctly
g. Logoff, then login correctly defines the panned area on the laptop, but it now suffers from the same issues

====================================
rpm -qa *\nvidia\* *\kernel\* *xorg*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf;grep nvidia /var/log/yum.log
====================================

abrt-addon-kerneloops-2.0.7-3.fc16.x86_64
akmod-nvidia-304.37-1.fc16.x86_64
kernel-3.4.6-1.fc16.x86_64
kernel-3.4.7-1.fc16.x86_64
kernel-3.4.9-1.fc16.x86_64
kernel-devel-3.4.6-1.fc16.x86_64
kernel-devel-3.4.7-1.fc16.x86_64
kernel-devel-3.4.9-1.fc16.x86_64
kernel-headers-3.4.9-1.fc16.x86_64
kernel-tools-3.4.9-1.fc16.x86_64
kmod-nvidia-3.4.6-1.fc16.x86_64-304.37-1.fc16.x86_64
kmod-nvidia-3.4.7-1.fc16.x86_64-304.37-1.fc16.x86_64
kmod-nvidia-3.4.9-1.fc16.x86_64-304.37-1.fc16.x86_64
libreport-plugin-kerneloops-2.0.10-3.fc16.x86_64
nvidia-settings-1.0-20.fc16.x86_64
nvidia-xconfig-1.0-18.fc16.x86_64
xorg-x11-apps-7.6-2.fc15.x86_64
xorg-x11-drivers-7.4-2.fc15.x86_64
xorg-x11-drv-acecad-1.5.0-2.fc16.x86_64
xorg-x11-drv-aiptek-1.4.1-2.fc16.x86_64
xorg-x11-drv-apm-1.2.3-8.fc16.x86_64
xorg-x11-drv-ast-0.91.10-7.fc16.x86_64
xorg-x11-drv-ati-6.14.3-4.20120201git36c190671.fc16.x86_64
xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64
xorg-x11-drv-dummy-0.3.4-7.fc16.x86_64
xorg-x11-drv-elographics-1.3.0-2.fc16.x86_64
xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16.x86_64
xorg-x11-drv-fbdev-0.4.2-2.fc16.x86_64
xorg-x11-drv-fpit-1.4.0-2.fc16.x86_64
xorg-x11-drv-glint-1.2.5-2.fc16.x86_64
xorg-x11-drv-hyperpen-1.4.1-2.fc16.x86_64
xorg-x11-drv-i128-1.3.4-9.fc16.x86_64
xorg-x11-drv-i740-1.3.2-9.fc16.x86_64
xorg-x11-drv-intel-2.19.0-3.fc16.x86_64
xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64
xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64
xorg-x11-drv-mga-1.4.13-8.fc16.x86_64
xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64
xorg-x11-drv-mutouch-1.3.0-2.fc16.x86_64
xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64
xorg-x11-drv-nv-2.1.18-8.fc16.x86_64
xorg-x11-drv-nvidia-304.37-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-304.37-1.fc16.x86_64
xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64
xorg-x11-drv-penmount-1.5.0-3.fc16.x86_64
xorg-x11-drv-qxl-0.0.21-13.fc16.x86_64
xorg-x11-drv-r128-6.8.1-11.fc16.x86_64
xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64
xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64
xorg-x11-drv-savage-2.3.3-1.fc16.x86_64
xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64
xorg-x11-drv-sis-0.10.3-7.fc16.x86_64
xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64
xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64
xorg-x11-drv-trident-1.3.4-7.fc16.x86_64
xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64
xorg-x11-drv-vesa-2.3.0-9.fc16.x86_64
xorg-x11-drv-vmmouse-12.7.0-2.fc16.x86_64
xorg-x11-drv-vmware-11.0.3-6.fc16.x86_64
xorg-x11-drv-void-1.4.0-2.fc16.x86_64
xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64
xorg-x11-fonts-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-14-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-14-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-15-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-15-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-misc-7.5-4.fc15.noarch
xorg-x11-fonts-truetype-1.0.2-1.fc16.noarch
xorg-x11-fonts-Type1-7.5-4.fc15.noarch
xorg-x11-font-utils-7.5-6.fc15.x86_64
xorg-x11-proto-devel-7.6-12.fc16.noarch
xorg-x11-resutils-7.5-2.fc15.x86_64
xorg-x11-server-common-1.11.4-3.fc16.x86_64
xorg-x11-server-utils-7.5-7.fc16.x86_64
xorg-x11-server-Xephyr-1.11.4-3.fc16.x86_64
xorg-x11-server-Xorg-1.11.4-3.fc16.x86_64
xorg-x11-utils-7.5-3.fc16.x86_64
xorg-x11-xauth-1.0.6-1.fc16.x86_64
xorg-x11-xinit-1.3.1-1.fc16.x86_64
xorg-x11-xkb-utils-7.5-5.fc16.x86_64
xorg-x11-xtrans-devel-1.2.6-2.fc15.noarch
3.4.9-1.fc16.x86_64
nvidia 11244439 57
i2c_core 33895 3 nvidia,videodev,i2c_i801
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 304.37 (mockbuild@builder1.ovh.rpmfusion.lan) Tue Aug 14 06:37:18 CEST 2012

# RPM Fusion - nvidia-xorg.conf
#

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Lenovo Group Limited"
HorizSync 56.5 - 67.8
VertRefresh 50.0 - 60.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro 2000M"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
NHOjar is offline   Reply With Quote

Old 08-25-12, 08:47 AM   #9
NHOjar
Registered User
 
Join Date: Feb 2012
Posts: 9
Unhappy Re: Nvidia 304.32 new xorg.conf update breaks panning

I have tested the application of panning without also configuring Twinview [2 screens] and it seems that panning is somehow broken with respect to some applications of fedora:-
a. Docky
b. Wallpaper backdrop

Even with one screen, I do see an enabled extra panned area but neither Docky nor Wallpaper
cover the new area.

I have tested this using the laptop screen only and using the external monitor only.

Has anyone been able to get panning to work properly with the newer Nvidia 304.3x driver ?
NHOjar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.