Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-26-12, 09:07 AM   #85
bactrimel
Registered User
 
Join Date: Apr 2003
Posts: 20
Default Re: Random crashes, NVRM Xid messages

Quote:
Originally Posted by rockob View Post
I tried booting with thermal.off=1, which disables acpi thermal control (ie so fan control is entirely in the hands of the BIOS), but it didn't make any difference with 304.48 - nvidia still crashed in most games pretty quickly.

However, 304.51 is working much better, touch wood. I haven't had a crash in the last 24 hours launching CodMW2 and CodMW3 from an ext4 partition.

Note though that when I launched CodMW3 from a btrfs partition, 'Hit and Run' still crashed within 20 seconds.

Another (rather radical) solution to try would be to find *all* relevant loaded modules:


lsmod | grep thermal


and then blacklist them by creating a new file in /etc/modprobe.d/ containing lines like this:

blacklist offendingthermalmodule1
blacklist offendingthermalmodule2

etc.

Please note that I have not actually tried this, since just removing thermal monitoring from gkrellm and rebooting appears to fix the problem (using 304.51).
__________________
CentOS 6 + KDE 4
GeForce GTS 450
bactrimel is offline   Reply With Quote
Old 09-26-12, 07:17 PM   #86
rockob
Registered User
 
Join Date: Nov 2008
Posts: 95
Default Re: Random crashes, NVRM Xid messages

Ok, lsmod doesn't find any modules matching 'thermal'.

Apart from the almost immediate nvidia crash yesterday when I ran it from a btrfs partition, it crashed once more later on after approx 20 minutes of playing CoDMW1 (running from an ntfs partition and using kernel 3.6-rc7, if that's relevant). Generally, 304.51 does seem to be more stable than earlier 30x releases. (I'm not using the thermal.off=1 boot parameter because it didn't make any difference earlier.)

My guess would be that the nvidia module isn't handling interrupts properly (since it does sometimes report an interrupt issue and, if not, why would disabling acpi thermal control or running off different partitions make a difference?) but hopefully they made some changes in 304.51 that have alleviated the situation. Maybe they actually tested it on a newer kernel this time?
rockob is offline   Reply With Quote
Old 09-27-12, 04:16 AM   #87
bactrimel
Registered User
 
Join Date: Apr 2003
Posts: 20
Default Re: Random crashes, NVRM Xid messages

Just in case this hasn't been already mentioned in this thread: before ending up with the 'permanent' fix I've noticed that enabling MSI had a noticeable positive effect on system stability. For reference, the way to enable it is to change/add:

/etc/modprobe.d/nvidia.conf

with the following line:

options nvidia NVreg_EnableMSI=1

and then restart nvidia kernel module.
__________________
CentOS 6 + KDE 4
GeForce GTS 450
bactrimel is offline   Reply With Quote
Old 10-02-12, 05:07 AM   #88
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: Random crashes, NVRM Xid messages

I always get the same Xid error message:

Code:
Sep 30 19:35:14 andy-Inspiron-1520 kernel: [62458.990142] NVRM: Xid (0000:01:00): 13, 0003 00000000 00008297 00000f10 44610000 00000040
Fortunately my system does not crash completely but just hangs until I switch to tty and back to the desktop again. After that everything is normal again except for issues with suspend and resume.

In my case it seems to be related to Gnome Shell as it only happens when the overview mode opens up or closes. I think it started after I upgraded to Ubuntu 12.04. Disabling thermal monitoring with thermal.off=1 or enabling MSI for my GF 8600m GT did not help.
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 10-02-12, 08:36 AM   #89
bactrimel
Registered User
 
Join Date: Apr 2003
Posts: 20
Default Re: Random crashes, NVRM Xid messages

There is a rather involved way to force a NVRM: Xid and partial desktop freeze on an otherwise stable KDE4, by exploiting a nasty bug in nedit with ARGB visuals.

In every case, I was able to revive the desktop by toggling composite off-on, using the KDE4 hotkey (Alt-Shift-F12). I suspect there is a way to perform a similar toggle in Gnome.
__________________
CentOS 6 + KDE 4
GeForce GTS 450
bactrimel is offline   Reply With Quote
Old 10-03-12, 06:33 AM   #90
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: Random crashes, NVRM Xid messages

Quote:
Originally Posted by bactrimel View Post
In every case, I was able to revive the desktop by toggling composite off-on, using the KDE4 hotkey (Alt-Shift-F12). I suspect there is a way to perform a similar toggle in Gnome.
As far as I know there is no way to toggle compositing as gnome shell always relys on full hardware acceleration and compositing. I'm wondering whether this issue only occurs on my setup.
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 10-04-12, 04:27 AM   #91
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: Random crashes, NVRM Xid messages

I don't use compiz. For what concerns metacity, compositing can be toggled via the configuration editor (apps/metacity/general) or from the command line, e.g. gconftool-2 -s --type boolean /apps/metacity/general/compositing_manager false/true. I use a shell script to turned it off/on when watching movies. It is straightforward to define a hotkey for that.
stecklum is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.