Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-07-12, 12:49 PM   #1
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Unable to disable vsync for XGL

I have been running pretty old 270.x drivers because the newer ones changed the behavior where vsync is enabled by default now (NOOOO).

I have a triple monitor setup at work and it syncs to my lowest refresh rate monitor which is only 48Hz which is horrible for the other two (67Hz and 60 Hz).

I have tried adding:

nvidia-settings --load-config-only

to my xinitrc and also in kdm's kdmrc file I tried adding:

# Additional environment variables KDM should pass on to all programs it runs.
# LD_LIBRARY_PATH and XCURSOR_THEME are good candidates;
# otherwise, it should not be necessary very often.
# Default is ""
ExportList=__GL_SYNC_TO_VBLANK=0

I wonder if its not taking effect as maybe these things environment variables dont work until after X is loaded? That is a problem as XGL is openGL based and what everything runs under and is pretty much the main process which is running =(

Nothing seems to work. beryl bench is still showing 48 FPS which is driving me nuts. With steam for linux coming out I really want to use newer drivers now. Anyone have any ideas on getting around this? An option in /etc/X11/xorg.conf would have been nice for over-riding this default =(
Xevious is offline   Reply With Quote
Old 11-07-12, 05:30 PM   #2
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Unable to disable vsync for XGL

I have even verified the environment variables are being set but vsync is still being enabled. Using the old driver I get 200-300 FPS after the first boot and with the newer ones I am stuck at 48 FPS:

Code:
root@sigoto: 03:27 PM :~# ps aux | grep X | grep -v grep | grep -v Box
root     17205 24.1  5.0 1385100 1257364 ?     R    15:22   1:12 /usr/bin/Xgl.actual -accel xv:fbo -accel glx:pbuffer -nolisten tcp -fullscreen -br +xinerama -nolisten tcp -dpi 75 :0 vt7 -auth /var/run/xauth/A:0-dH33XM
root     17218  0.9  0.1 111704 45912 tty7     Ss+  15:23   0:02 /usr/bin/Xorg -br vt7 -auth /tmp/.Xgl-auth-68Xx9z -nolisten tcp :93 -terminate
root@sigoto: 03:27 PM :~# cat /proc/17205/environ  | awk -F'_GL' '{print "__GL"$2}' | cut -c 1-21
__GL_SYNC_TO_VBLANK=0
root@sigoto: 03:28 PM :~# cat /proc/17218/environ  | awk -F'_GL' '{print "__GL"$2}' | cut -c 1-21
__GL_SYNC_TO_VBLANK=0
Any other way to disable vertical sync other than environment variables? They don't appear to always work with everything.
Xevious is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.