Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-14-04, 02:58 AM   #1
hansv
Registered User
 
Join Date: Jan 2004
Posts: 4
Unhappy I'm not getting GLX effects

I'm using SUSE90 and a Geforce 2 MX100/200 card. The driver is installed correctly (I'm getting a NVIDIA screen before/when X starts), but the 3D effects are not working. My XF86Config file does nog contain the line LOAD "GLX" but when I change my config file the X server does not start at all.

Maybe someone has a working configuration file or any idea at all.

THX
hansv is offline   Reply With Quote
Old 01-14-04, 06:13 AM   #2
daclink
Registered User
 
Join Date: Apr 2003
Posts: 23
Default

I would have thought you would need the line
Load "glx"

anyway post XF86Config that way someone might be able to spot the problem.

DaClink
daclink is offline   Reply With Quote
Old 01-14-04, 02:30 PM   #3
coolbiz
Registered User
 
Join Date: Jul 2003
Location: Äänekoski, Finland
Posts: 1
Default suse9.0, cannot enable OpenGl acceleration, gf2 gts

I have similar problem with suse 9.0. I installed driver as directed, but sax says that you have to install original binary driver (which I did earlier) and wont enable 3d.. nvidia logo is also visible (about half a second or so, earlier had second to one and a half second..)

GeForce 2 GTS, agp

********* XF86Config *******************
# /.../
# SaX generated XFree86 config file
# Created on: 2004-01-13T17:50:54+0200.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "glx"
Load "speedo"
Load "freetype"
Load "v4l"
Load "extmod"
Load "type1"
Load "dbe"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fi"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
EndSection
Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 340 250
HorizSync 28-95
Identifier "Monitor[0]"
ModelName "D1226H"
Option "DPMS"
VendorName "DELL"
VertRefresh 50-160
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1600x1200" 184.66 1600 1712 1888 2144 1200 1201 1204 1248
[removed n+1 modeline for readers sake]
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce2 GTS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
Attached Files
File Type: log xfree86.0.log (31.2 KB, 149 views)
coolbiz is offline   Reply With Quote
Old 01-15-04, 03:22 AM   #4
hansv
Registered User
 
Join Date: Jan 2004
Posts: 4
Cool THX I will try this

I will try this config file (maybe I will make some changes) if it doesn't work I drop my XF86Config so that someone else can help me...

Thanks .
hansv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Maximus Fires Up Visual Effects In Men in Black 3 News Archived News Items 0 06-26-12 06:00 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
CSS filter effects get GPU-accelerated in Chrome News Archived News Items 0 06-05-12 01:20 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GLX bug? (1.0-3123) marc NVIDIA Linux 2 09-21-02 04:58 PM

All times are GMT -5. The time now is 08:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.