Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-13-04, 07:14 PM   #1
sdave1284
Registered User
 
Join Date: Jan 2004
Posts: 5
Default Lid close and resolution problem

I recently put linux on my laptop and i've gotten everything to work, even the wide screen drivers from nvidia. I have a GeForce4 4200 Go and every time I close my lid, the screen resolution is messed up when its opened back up. Also it does not turn the screen off. Any help would be great.
sdave1284 is offline   Reply With Quote
Old 01-14-04, 12:12 PM   #2
k3ant
GeForce 4 420 Go & FX5200
 
k3ant's Avatar
 
Join Date: May 2003
Location: Lansford, Pa. USA
Posts: 25
Default

What version of the nVidia driver are you using???

I have Fedora Core 1 installed on a Gateway M500 laptop which uses an nVidia GeForce4 420 Go w/32MB RAM video card that ONLY works fully with the 4363 version of the driver! With all of the other versions between 4363 and 5328 have problems with the ttys. With version 5328 the ttys do work but display the text 2 lines too low - on a full screen the prompt is actually off screen. Too the text is not displayed properly - like it's chopped off in some areas of each character. But with the version 4363 installed, everything works!

Consider giving it a try - it may work for you!

BTW, I can close and open the lid on this system with no ill effects at all with the video...
__________________
Mike
k3ant is offline   Reply With Quote
Old 01-14-04, 02:04 PM   #3
sdave1284
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

I have the 64 MB one but should be the same and i'm using Red Hat 9. I'm using the newest version so maybe I'll try the version you recommend. Thanks. I'll let you know what heppens.
sdave1284 is offline   Reply With Quote
Old 01-14-04, 02:36 PM   #4
k3ant
GeForce 4 420 Go & FX5200
 
k3ant's Avatar
 
Join Date: May 2003
Location: Lansford, Pa. USA
Posts: 25
Default

Just be aware - RHL9 does NOT have the acpi support that Fedora Core 1 has!

I started out with Red Hat Linux 9 and for a time I had both distros installed at the same time. I wanted to get a feel for FC1 before dumping RHL9. While I have warm feelings for RHL9, I would be hard pressed to leave FC1 to go back to it!!!

I'm not saying if you go to FC1 your acpi issues will be solved - they will not be as acpi support is still in beta and has a long way to go. (For instance, on my Gateway M500 I do have a battery capacity readout and two temperature readouts working.) Plus, depending on the laptop you use, you may need to do additional work - installing a DSDT file, etc.

Here is a link where you may be able to find some help:

http://linux-on-laptops.com/

Sir, I wish you lotsa luck in your acpi efforts...
__________________
Mike
k3ant is offline   Reply With Quote
Old 01-14-04, 03:38 PM   #5
sdave1284
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

Well actually power management isnt a huge deal because i'm running linux RH9 off an USB2 external HD which needs external power itself. I use Win XP more and am just getting into Linux so i'll be working on it with an outlet near by so i'm not really worried about it. The screen resolution messing up if I close the screen does get annoying though so thats why I want to get that at least working. The ACPI does work on my notbook with certain kernel versions that I would have to reconfigure which I may do at a later time if I decide to get a pocket HD or a second internal drive but for now i'm just fine with RH9. I have a Latitude D800 by the way. I just want to get this darn screen res problem fixed. Thanks for the info.
sdave1284 is offline   Reply With Quote
Old 01-16-04, 12:35 PM   #6
sdave1284
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

Mike,
Thanks! It worked perfect. That was the exact problem. It doesnt like the newer drivers. 3d works and everything. Thanks again!

Dave
sdave1284 is offline   Reply With Quote
Old 01-16-04, 05:18 PM   #7
k3ant
GeForce 4 420 Go & FX5200
 
k3ant's Avatar
 
Join Date: May 2003
Location: Lansford, Pa. USA
Posts: 25
Default

Glade to hear it Dave!

I still hold out hope of using a newer version - some day - but until then, 4363 will do just fine.

Enjoy!
__________________
Mike
k3ant is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.