Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-07-04, 04:05 PM   #49
silversun
Registered User
 
Join Date: Apr 2003
Posts: 16
Default samsung x10

people with a samsung x10 should remember, that the good old driver version 4191 works with the laptop when loading the kernel module NVreg_Mobile=4 NVreg_SoftEDIDs=0
the drivers don't work perfectly, but OpenGL works and the TV out, too.

Cheers, Rolf
silversun is offline   Reply With Quote
Old 01-09-04, 04:13 AM   #50
dsanta
Registered User
 
Join Date: Jan 2004
Location: Lausanne - Switzerland
Posts: 1
Default Cannot switch to external monitor with 1.0-5328

I tried the latest driver (1.0-5328) on my Dell Inspiron 8500 laptop (GeForce4 Ti 4200 Go) and it does not let me switch between the internal LCD and external CRT anymore. When I press the Fn+F8 key combo to switch, I only get a mode switch but the image stays on the LCD. I watched the XFree86 log file and it appears that the driver does not detect the attached monitor when Fn+F8 is pressed.

With 1.0-4496 everything works fine. When the Fn+F8 key is pressed the attached monitor is detected and a new mode list is created (seen by watching the XFree86 log).

Is this a know issue? Any workarounds available?

I'm running Fedora Core 1 with the latest kernel (2.4.22-1.2140.nptl)

BTW I reported this problem to linux-bugs@nvidia.com
dsanta is offline   Reply With Quote
Old 01-09-04, 02:22 PM   #51
nyeby
Registered User
 
Join Date: Jan 2004
Posts: 3
Default no 3D acceleration on Mandrake

I am running Mandrake Linux 9.2 on a AMD Athlon XP 2000+, 512Mb DDR333, ASUS A7V8X and a Nvidia Geforce2 MX 400 64Mb.
On the same computer i have RedHat9 and the GF2 is running well with the latest drivers. The problem is that on Mandrake 9.2 i am unable to have 3D aceleration and i don't understand why! I used the nvidia installer with no problems at all, edited XF86Config-4:

Drivers "nv"

to

Drivers "nvidia"

and maintained Load "glx" #3D support

(as described on the readme file).


When X is booting up i get the NVIDIA logo like on RH9, but when i try to run TUX i get very slow graphics.

------------------------------
command: glxgears gives me:

29 frames in 5.0 seconds = 5.800 FPS
28 frames in 5.0 seconds = 5.600 FPS

------------------------------
command: cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

-------------------------------
command: glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce2 MX/AGP/SSE/3DNOW!/forceSW
OpenGL version string: 1.4.1 NVIDIA 53.28
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_S3_s3tc,
GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,
GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
GL_EXT_paletted_texture, GL_EXT_point_parameters, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
GL_EXT_vertex_array, GL_IBM_rasterpos_clip,
GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,
GL_NV_fence, GL_NV_fog_distance, GL_NV_light_max_exponent,
GL_NV_packed_depth_stencil, GL_NV_pixel_data_range, GL_NV_point_sprite,
GL_NV_register_combiners, GL_NV_texgen_reflection,
GL_NV_texture_env_combine4, GL_NV_texture_rectangle,
GL_NV_vertex_array_range, GL_NV_vertex_array_range2, GL_NV_vertex_program,
GL_NV_vertex_program1_1, GL_NVX_ycrcb, GL_SGIS_generate_mipmap,
GL_SGIS_multitexture, GL_SGIS_texture_lod, GL_SUN_slice_accum
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x2a 24 tc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2e 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x2f 24 dc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x31 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x32 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x33 24 dc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x34 24 dc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x35 24 dc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x36 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x37 24 dc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x38 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None



but on RH9 i have no problems at all!

Please HELP!!!!!
__________________
AMD Athlon XP2000+
ASUS A7V8X
512Mb DDR333
Mandrake 9.2 (download edition)
Nvidia Geforce2 MX400 64Mb AGP
nyeby is offline   Reply With Quote
Old 01-10-04, 05:32 PM   #52
acrux
ISF Napoli
 
acrux's Avatar
 
Join Date: Oct 2003
Location: IT
Posts: 17
Default 5328 on GF4 Ti 4400 and kernel 2.4.24

with this new driver i've seen in OpenGL applications my FPS go down... i'm returned to 44.96 release.

greetz,

Acrux
acrux is offline   Reply With Quote
Old 01-11-04, 11:31 AM   #53
utiel
Registered User
 
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default Re: 5328 on GF4 Ti 4400 and kernel 2.4.24

Quote:
Originally posted by acrux
with this new driver i've seen in OpenGL applications my FPS go down... i'm returned to 44.96 release.

greetz,

Acrux
I have found that new drivers have VSYNC enabled.
If your monitor have 75hz of VSYNC, you only get 75 fps in "glxgears -fps"

Try This:
Code:
export __GL_SYNC_TO_VBLANK=0
bash-2.05b$ export __GL_SYNC_TO_VBLANK=0
bash-2.05b$ glxgears -fps
1410 frames in 5.0 seconds = 282.000 FPS
1407 frames in 5.0 seconds = 281.400 FPS

.... Now, without setting __GL_SYNC_TO_VBLANK

bash-2.05b$ unset __GL_SYNC_TO_VBLANK
bash-2.05b$ glxgears -fps
319 frames in 5.0 seconds = 63.800 FPS
370 frames in 5.0 seconds = 74.000 FPS
373 frames in 5.0 seconds = 74.600 FPS
327 frames in 5.0 seconds = 65.400 FPS
-------------------

You can put your new environment variable in your .bashrc file or /etc/profile and it will work when you restart your machine
utiel is offline   Reply With Quote
Old 01-12-04, 07:15 AM   #54
Marcus-sp
Registered User
 
Join Date: Jan 2004
Posts: 3
Thumbs down BUGS

This drivers don't work whith redhat 9 anb geForce FX5600.

Here are the best drivers:

http://public.pny.com/quadro/FX3000g/Linux/
Marcus-sp is offline   Reply With Quote
Old 01-12-04, 07:55 AM   #55
Troydm
Registered User
 
Join Date: Jan 2004
Posts: 1
Default

I have a problem with NVIDIA-Linux-x86-1.0-5328 Drivers
I have an NVIDIA GeForce 3 Ti 200 card
I am using Suse 9 Linux and AGP mode is not working at all !!!

A had a RedHat 9 with 4436 drivers and everything worked properly
but as soon as I switched to 5328 drivers OpenGL applications
runned slowly under NvAGP 3 mode so I set NvAGP option to 0(PCI mode)

Currenty I switched to Suse 9 and AGP mode still is not working
Sax2 crashes when I configure my card with NvAGP 3 mode
So I configure Sax2 with NvAGP 0 and everything works properly
but I am curious why is not AGP mode working ???
Troydm is offline   Reply With Quote
Old 01-13-04, 05:54 PM   #56
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default

Well just a big THANX to NVIDIA for the new drivers... they work great here with the minion.de patches on 2.6 (but I'd like to see official support for 2.6 by NVIDIA)...

anyway thanx again...

(GeForceFX5900 with NForce2ultra)
kmare is offline   Reply With Quote

Old 01-16-04, 12:37 AM   #57
Roy1.8T
Registered User
 
Join Date: Jan 2004
Posts: 4
Default

For those of you who are successfully installing the driver without getting errors but who have really slow performance, try setting the AGP option to use the nVidia one. By default, the drivers will try to use your distro's AGPGART.

My scores jumped from around 160 FPS to 900 FPS using glxgears. Also my CPU usage dropped in half.

Config:

Dual AMD Tyan Tiger MP
GeForce FX5200 128MB
Fedora Core 1 (original kernel etc.)

Nothing else mentioned made any difference except the above. Good luck everyone!



Roy
Roy1.8T is offline   Reply With Quote
Old 01-16-04, 11:09 PM   #58
Roy1.8T
Registered User
 
Join Date: Jan 2004
Posts: 4
Default

Small update.

For another small speed boost (for some of you, this may be crucial), try:

rpm -e --nodeps XFree86-Mesa-libGL

This will (cleanly) remove the TLS so's and ensure that you're using the nVidia drivers.

My FPS jumped up from ~900 to ~1000 FPS.

Good luck all,


Roy
Roy1.8T is offline   Reply With Quote
Old 01-17-04, 02:51 AM   #59
Roy1.8T
Registered User
 
Join Date: Jan 2004
Posts: 4
Default

Played around with the drivers some more and noticed something which might be of use to some of you.

I got to a point where the GLX modules weren't loading (like in many of the posts I see). Started going over the changes that I made and figured it out. I was running WineX and set LD_ASSUME_KERNEL=xxx to get around the localdomain/socket error.

As soon as I removed this and reinstalled the drivers (this step might not be necessary), everything was back to normal.

I suggest including the kernel variable that as part of your startup command for WineX instead of adding it to your bash_profile as I had.

Good luck all,


Roy
Roy1.8T is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Day of Defeat: Source and Half-Life 2: Deathmatch Updates Released News Archived News Items 0 06-11-12 09:50 PM
CUVILib v1.2 released News Archived News Items 0 05-17-12 07:40 AM
295.49 (long-lived branch release) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-03-12 10:42 AM
SOF2 1.02 Patch Released! PsychoSy Gaming Central 5 10-17-02 05:08 AM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM

All times are GMT -5. The time now is 06:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.