Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-29-03, 03:59 PM   #13
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default arg...

You have agpgart, but loading it fails becoze... there is somewhere a pb...
We need to know more... do the following steps in order:
1- try to load the agpgart module with #modprobe agpgart
2 - Then post here the output of the following command:
#cd /var/log;grep -ie '*agp*' -R * &>~/system-agp.log

The last command will create a system-agp.log file in your home directory, post this file to this forum.

We may learn why you agpgart module is not loading.
XoD is offline   Reply With Quote
Old 08-29-03, 04:31 PM   #14
hacnslash
Registered User
 
Join Date: Jun 2003
Posts: 24
Default

here's what happens when i try to load it:

modprobe agpgart
/lib/modules/2.4.20/kernel/drivers/char/agp/agpgart.o: init_module: No such device
/lib/modules/2.4.20/kernel/drivers/char/agp/agpgart.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/kernel/drivers/char/agp/agpgart.o: insmod /lib/modules/2.4.20/kernel/drivers/char/agp/agpgart.o failed
/lib/modules/2.4.20/kernel/drivers/char/agp/agpgart.o: insmod agpgart failed

and the file that is created in my home dir is totally empty, nothing, nada, zilch is in it

edit: ok, so if i type in dmsg after trying to load agpgart, i find this in the output:

agpgart: Unsupported Via chipset (device id: 3116), you might want to try agp_try_unsupported=1.
agpgart: no supported devices found.

i guess agpgart doesn't support the km266 either?!?

Last edited by hacnslash; 08-29-03 at 04:35 PM.
hacnslash is offline   Reply With Quote
Old 08-29-03, 05:34 PM   #15
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default found it...

You found what I was looking for...
Well... your chipset seems not to be properly supported... so... you can try to update the kernel and the modules of your distro and expect your chipset to be supported. For instance try to go up to 2.4.21 or 2.4.22 kernel and modules...

The cheap fix would be to follow the log file advise... so try this:
#insmod agpgart agp_try_unsupported=1
#modprobe nvidia
#startx

Check out the dmesg output after that, if it still does not work.
XoD is offline   Reply With Quote
Old 08-30-03, 10:45 AM   #16
hacnslash
Registered User
 
Join Date: Jun 2003
Posts: 24
Default

yeah, i tryied the "unsupported" option, didn't work, and after some more online research i found out that the chipset isn't supported, but that somebody had a kernel patch for teh 2.4.20 kernel (which im using) and it worked, i haven't found any downloads of it, but if i do i'll post em here.


nevermind what i wrote above, i tried to load the agpgart module with the unsupported option with X started, and it didn't work, but without X started it DOES work. check this out:

cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

now to do some research on fast writes and SBA to find out what they are

Last edited by hacnslash; 08-30-03 at 10:51 AM.
hacnslash is offline   Reply With Quote
Old 08-30-03, 10:51 AM   #17
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Indeed...

I heard of it too, but I though the module option would have been enough...
XoD is offline   Reply With Quote
Old 08-30-03, 11:10 AM   #18
hacnslash
Registered User
 
Join Date: Jun 2003
Posts: 24
Default

well, now i only need to get agpgart to load with that option automactically, can i do this in modules.conf?
hacnslash is offline   Reply With Quote
Old 08-30-03, 11:35 AM   #19
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Well...

http://linux.ctyme.com/man/man1754.htm
XoD is offline   Reply With Quote
Old 08-30-03, 12:19 PM   #20
hacnslash
Registered User
 
Join Date: Jun 2003
Posts: 24
Default

thanks man, i guess this is what i should use:

install module command

Execute command instead of the default insmod when installing the specified module.

thanks again for everything.
hacnslash is offline   Reply With Quote

Old 08-30-03, 07:13 PM   #21
hacnslash
Registered User
 
Join Date: Jun 2003
Posts: 24
Default

hmm, i wonder why agpgart doesn't officially support the km266 chipset?! i mean, it works perfectly, its fast, and there have been no problems with it. i give agpgart and the 4496 driver 2 thumbs
hacnslash is offline   Reply With Quote
Old 01-30-04, 02:21 PM   #22
lachlan
Registered User
 
Join Date: Jan 2004
Posts: 21
Default

I obviously have a similar problem. I'm get X lockups sometimes, and I think it might be related.

I see this from dmesg:

0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336 Wed Jan 14 18:29:26 PST 2004
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 941M
agpgart: unsupported bridge
agpgart: no supported devices found.
0: NVRM: AGPGART: unable to retrieve symbol table

...but /proc/driver/nvidia/agp/status says that I am enabled:

Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

Other info:

I am running kernel version: 2.4.20-8
With a "Fancy Force" (MX440SE 64MB AGP Video Card I think)
and an ASUS A7N8X-X motherboard (which has **** onboard sound that I am nto using)
AMD 2600
1GB of RAM

anyone have any ideas?
lachlan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.