Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-31-04, 06:40 AM   #1
b165
Registered User
 
Join Date: Jan 2004
Posts: 2
Default Debian+5336+2.6.0 = black screen

Hello,
i've tried to install new nvidia drivers on stable 2.6.0.
First of all installer couldn't find kernel sources.

--kernel-source-path=/usr/src/linux-2.6.0
&
--kernel-name=`uname -r`

helped.

But there was problem with module load (depmod & QM_MODULES)

I've updated module-init-tools (apt-get install module-init-tools) and it helped.

Now I can run the installer without any switches. But I still can't start XWindow system.

In xfree86.log ewerything seems look fine, but after initialization there is black screen with few noise dots in left-upper corner.

I've read forum and driver reinstall (installer --unistall + ...) should help, but for me it doesn't work

Hardware: nforce2 + fx5200.

Please, help
b165 is offline   Reply With Quote
Old 01-31-04, 11:15 AM   #2
b165
Registered User
 
Join Date: Jan 2004
Posts: 2
Default

I've got solution

In /etc/X11/XConfig-4 i've added line:

Section "Device"
Option "NvAgp" "0"

and it works quite fine

But I don't know what it really means. Does it disable Agp advantages?
b165 is offline   Reply With Quote
Old 01-31-04, 11:30 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

It costs performance; which AGP GART driver did you use, Linux AGPGART or NVIDIA's internal AGP GART driver? In case of the former, it may help to switch to NVIDIA's builtin driver (making sure that Linux AGPGART is neither statically linked into the kernel nor loaded as a module).
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 12:17 PM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 07:24 PM

All times are GMT -5. The time now is 04:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.