Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-04, 05:02 PM   #1
talanari
Registered User
 
Join Date: Feb 2004
Posts: 1
Default Driver causes screen to flicker

PROBLEM:

I am having trouble with nVIDIA's Linux driver causing the screen on my notebook
to periodically flicker.

I am using a custom modeline for my notebook, since it has a non-standard native
resolution. To produce the modeline and get the OpenGL acceleration I need, I
am using nVIDIA's Linux driver. Unfortunately, it causes the screen to flicker
at seemingly random intervals. If I let the computer just sit, it seems to be
fine; however, once I start performing tasks and moving the mouse, at random
intervals the screen will flicker.

The flicker is usually too fast to describe; however, sometimes it can be made
out. There appears to be white lines. Each is 1 pixel high, equal length and
spaced at even intervals. It appears to be a timing issue, as if the remainder
from some calculation is accumulating and visually displaying itself when it has
accumulated enough to overflow the calculation.

ATTEMPTED SOLUTIONS:

I have spent a substantial amount of time trying to resolve the issue. Since it
appears to be a timing issue, I have tested numerous modelines. I have
generated some using online modeline generators and some by hand using the
XFree86 Video Timings HOWTO. Different modelines do affect the frequency of the
flicker and the length of the white lines. I have settled on my hand generated
modelines, since they produce the best results and the refresh rates closest to
the screen's capabilities.

Inability to resolve the issue with accurate modelines led me to try the open
source driver by changing 'Driver "nvidia"' in the 'Device' section to 'Driver
"nv"' Interestingly enough, this seemed to eliminate the flickering.
Unfortunately, I need the nvidia driver to get the desired OpenGL performance,
so this workaround can only be used to help track down the source of the
problem.

I know of two other individuals who have the same notebook and are also running
Linux on it. Both have experienced the same behavior. One is running an older
version of Redhat. He was able to eliminate the flickering by using the
1.0-4363 driver; however, I cannot use that version on Fedora.

COMPUTER:

The notebook is a HP zd7020us. I am running Redhat's Fedora Core 1 with the
2.4.22-1.2149.nptl kernel and nVIDIA's linux driver version 1.0-5336. The
modeline that I am currently using is

ModeLine "1440x900" 104.76 1440 1472 1872 1904 900 903 904 917 # 55.0kHz, 60.0Hz

This is the notebook's display's native resolution and maximum refresh rates.
The video card is a nVIDIA GeForce4 (FX) 448/5600 Go with 64MB of video RAM.


If anyone has any ideas, or has/is experiencing the same behavior, please let me
know. Thank you.
__________________
Thank you for your time and help,
Tom Lanari
talanari is offline   Reply With Quote
Old 02-10-04, 09:00 PM   #2
bforsberg
Registered User
 
Join Date: Oct 2003
Posts: 2
Default

We are having a similiar problem although ours is with Stereo. We are using an FX 1000 card and in stereo we will see what appears to be the vertical retrace missing the swaping of the left and right buffers from time to time. This causes a flicker like effect. It occurs when we have alot of display activity in another window happening. I was interested in your report because to get optimum performance we are using custom mode lines as well. We have not been able to find a fix yet.

Bruce
bforsberg is offline   Reply With Quote
Old 02-11-04, 06:17 PM   #3
dinzy
Registered User
 
Join Date: Feb 2004
Posts: 1
Default

I had the same problem as you. Everyone with the zd7000 series is having it with drivers newer than 4336 ( www.zd7000forums.com)

The solution is to install the 4336 driver set. To do this you will need to have the source installed so the nvidia driver can build the installer for your kernel. The source should be available through redhats update app)

I just solved the problem on my machine last night running Mandrake with a 2.4.22 kernel. Install the source to the default source directory. I forget what that is exactly and I am not at my linux machine to check but if you run the NVIDIA_Installer.run with the switch --advanced-options ( check readme for correct syntax search the readme file for the term kernel-install and you will see it) You can then use the switch to point to your source or put the source in the default directory( I had to do this for some reason). The installer should work once it can find the kernel headers and you will have the old drivers running w/o any flicker.

If that fails then you can manually compile the driver for your kernel. The driver will work on any 2.4 kernel its just that since it is old the installer can not handle kernels that were compiled after april 03. I hope this help somewhat. I had very little idea what i was doing but I got it to work eventually.
dinzy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 10:55 AM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 03:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.