Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-08-04, 02:54 PM   #1
cowchaser
Registered User
 
Join Date: Nov 2002
Location: Eastern Shore of Virgina
Posts: 9
Send a message via AIM to cowchaser
Unhappy Fedora & Tnt2

I have been using NVIDIA Drivers for several years with great results with Red Hat 7.3 and 8.0 on my Athlon 1400 and a TNT2 video card. I recently updated to Fedora Core 1 and installed the driver I was using with RH 8.0 (I do not remember witch version) and it seemed to work fine. Tux Racer is the only thing I tried and it seemed to run normally. When the new 1.0-5336 driver came out, I downloaded and installed and unfortunately deleted the old one. Every thing seemed to go fine with the install except it is very slow, I get 75.000 FPS with glxgears. I have searched this forum and several others including a general google Internet search. I have tried installing with RPMs and the normal NVIDA installer. I have tried removing and or renaming the Mesa libraries. Everything I have tried has given me the same result of 75.000 FPS. I did find one post that mentioned that he saw a decrease in speed from a previous driver to the new 1.0-5336 with Fedora and his TNT2 card. So with all that said my question is, What kind of speed, FPS, should I be expecting with Fedora and a TNT2 video card? Do the newer drivers give a decrease in performance with this card? If so, what older version should I use to get the best performance?
System information:
Video Card: TNT2/TNT2 Pro] rev 17 with 32 MB
Driver Version: 1.0-5336 installed from RPMS
Distribution: Fedora Core 1
Video bios revision: 02.05.01.00.00
Processor: AMD Athlon 1400
Motherboard: ASUS A7M266

XF86Config attached
Attached Files
File Type: txt xf86config.txt (3.1 KB, 173 views)
__________________
Roger Skildum
cowchaser is offline   Reply With Quote
Old 02-09-04, 05:56 PM   #2
mlmitton
Registered User
 
Join Date: Dec 2003
Posts: 12
Default

I don't think I can be of much help. It seems like you know what you're doing. So I'll just mention that I had a problem when I tried updating to the latest drivers, which I thought was also giving me very poor performance. It turns out that I had a daemon running (Red Carpet) that was taking 100% of the CPU. I had 4 hours of installing, reinstalling, reverting, before I finally checked the system monitor and found the problem.
mlmitton is offline   Reply With Quote
Old 02-09-04, 06:19 PM   #3
dpw2atox
Registered User
 
Join Date: May 2003
Posts: 170
Default

I have the same problem. Im running Fedora Core 1 w/ XFree86-4.3.0-45.0.1 from rawhide and the 53.36 nvidia drivers on 2.6.2 with a geforce fx 5600 and I get a constant 75fps. This did not happen with any other driver releases. It does not seem to be causing any real problems though so im just leaving it and waiting for the next driver release.
dpw2atox is offline   Reply With Quote
Old 02-09-04, 06:50 PM   #4
CrLf
Linux Power!
 
Join Date: Dec 2002
Location: Lisbon, Portugal, E.U.
Posts: 61
Default

Quote:
Originally posted by dpw2atox
I have the same problem. Im running Fedora Core 1 w/ XFree86-4.3.0-45.0.1 from rawhide and the 53.36 nvidia drivers on 2.6.2 with a geforce fx 5600 and I get a constant 75fps. This did not happen with any other driver releases. It does not seem to be causing any real problems though so im just leaving it and waiting for the next driver release.
"__GL_SYNC_TO_VBLANK=0 glxgears" also gives 75fps?
CrLf is offline   Reply With Quote
Old 02-09-04, 10:53 PM   #5
ocilent1
Registered User
 
Join Date: Jan 2004
Posts: 19
Angry

You are havng the exact same issue as me. I get around 75fps on my TNT2 card as well. I have been talking to MANY people that also have TNT2 cards and they are all experiencing the same very poor performance with the latest 5336 drivers.

The last set of drivers that actually worked normally were the 'leaked' 4620 drivers. Every release after that has given my TNT2 card grief. I have replicated this problem now on several machines at work with TNT2 cards. So it is definately a driver issue and not 'config' problems.

Time to fix this NVIDIA. Just about every computer here at my work uses a TNT2 chip so you can't dump driver support for these chips yet!!!
ocilent1 is offline   Reply With Quote
Old 02-12-04, 04:15 AM   #6
punky
Registered User
 
Join Date: Jan 2004
Posts: 5
Angry

(sorry for my english)
i just want to tell you that i have the same problems with my tnt2M64 and drivers 5336 ( about 85 fps in glxgears )
and a little bit better with the 4496: 150fps
could you tell me your 'high score' , and the best driver release number for this card please???
thx
punky is offline   Reply With Quote
Old 02-14-04, 08:47 AM   #7
cowchaser
Registered User
 
Join Date: Nov 2002
Location: Eastern Shore of Virgina
Posts: 9
Send a message via AIM to cowchaser
Smile TNT2 and NVIDIA Drivers

I backed up to the 4496 drivers and went from 75.000 fps to 645.000 fps. Not sure if that is the best I could expect but at least Tux Racer seems to run normally. It is too bad that NVIDIA seems to have neglected support for the older TNT2 cards. I am sure I am not the only person that still are using this card and have no desire to upgrade. I had always been very happy with the TNT2 card but if NVIDA is going to do quit supporting this card what is saying that they are not going to quit supporting a new NVIDIA card that I might buy to replace in a few years. Defiantly going to make me think twice about buying a NVIDIA card in the future.
__________________
Roger Skildum
cowchaser is offline   Reply With Quote
Old 02-17-04, 10:08 PM   #8
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Thumbs down Same problem here, TNT2 and 5336 = BAD

I am also seeing the same problem. 4496 driver works OK, 5336 driver slows down about 90% (on this machine, 650fps with 4496, 60fps with 5336). Backing out to 4496 corrects the problem.

The 5536 driver looks broken for this card.
macemoneta is offline   Reply With Quote

Old 02-18-04, 04:21 PM   #9
CrLf
Linux Power!
 
Join Date: Dec 2002
Location: Lisbon, Portugal, E.U.
Posts: 61
Default

People! Just read the posts before you post... All those values are refresh rate values (60, 75, 85). The new drivers seem to default to vsync enabled on TNT2 cards.

Try "__GL_SYNC_TO_VBLANK=0 glxgears" and see for yourselves (I did and I went from 85 to 235... yay!).

If it works (it should), just add "export __GL_SYNC_TO_VBLANK=0" to some initialization script (/etc/bashrc, .bashrc, .bash_profile or whatever).

Downgrading... people just like the easiest solutions.
CrLf is offline   Reply With Quote
Old 02-18-04, 05:26 PM   #10
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Default __GL_SYNC_TO_VBLANK=0

Thanks CrLf, that did the trick. I did read ALL the related forum posts first. The only mention of this setting in the forums, is in these threads:

1.0-5328 released:
http://www.nvnews.net/vbulletin/show...NCTOVBLANK%3D0

How to disable vsync (problems with the 5200 card, not TNT2):
http://www.nvnews.net/vbulletin/show...NCTOVBLANK%3D0

Turning OFF vsync (Quake 3 problem resolution):
http://www.nvnews.net/vbulletin/show...NCTOVBLANK%3D0

It's unlikely that anyone searching for problems with the TNT2 and 5336 release will be able to find this solution, except in this thread. It would have been nice if NVIDIA had included mention of the change in the release notes. Instead, the release notes specifically indicate that the setting DOESN"T APPLY to the TNT2:

"Setting the environment variable __GL_SYNC_TO_VBLANK to a non-zero value
will force glXSwapBuffers to sync to your monitor's vertical refresh rate
(perform a swap only during the vertical blanking period) on GeForce or
newer hardware (ie: everything but TNT/TNT2 products)."

The release notes need a BOLD statement AT THE TOP, whenever a change like this is made, so that people at least have a chance to find it.
macemoneta is offline   Reply With Quote
Old 02-19-04, 06:02 PM   #11
cowchaser
Registered User
 
Join Date: Nov 2002
Location: Eastern Shore of Virgina
Posts: 9
Send a message via AIM to cowchaser
Smile _GL_SYNC_TO_VBLANK=0

Thanks CrLf, looks like that fixed it for me also. Even though the answer may have been in the posts, a person needed to know what the problem is in order to find the answer. I searched for days, and even found a mention of "_GL_SYNC_TO_VBLANK=0" but not in relationship to a TNT2 video card. I even emailed linux-bugs@nvidia.com. They asked for more information and said that they had some reports of problems with this card but never suggested the answer.
Thanks again
__________________
Roger Skildum
cowchaser is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 173.14.35: Fedora 17 x86 terribly slow Mr Wolf NVIDIA Linux 25 07-02-12 01:44 AM
NVidia - TNT2 M64 - X Hangs themann NVIDIA Linux 3 09-01-02 02:16 PM
TNT2 M64 vs Voodoo3 3000 AGP Jake Other Desktop Graphics Cards 11 08-25-02 04:18 AM
TNT2 M64 and Direct3D drivers? Mist NVIDIA Windows Graphics Drivers 1 08-13-02 11:29 PM
rh 7.3 and tnt2 problems moodfarm NVIDIA Linux 2 08-12-02 11:37 AM

All times are GMT -5. The time now is 01:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.