Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-19-04, 08:46 PM   #1
FlipmodePlaya
Registered User
 
Join Date: Feb 2004
Posts: 6
Default SuSE 9 with 5900 FX Problem.

I eMailed SuSE for support, but it doesn't look like they will respond.

I'm trying to install the 1.0-5336 drivers for Linux IA32 on SuSE 9, with a 2.4.x kernel. I downloaded the .run script and ran it, following the special SuSE instructions (here ), and everything seemed to go fine. It says to configure SaX afterwards with the command 'sax2 -m 0=nvidia'. When doing so, I get an error advising me of how to fix it. it suggests that the card (5900, in this case) is not supported, that I selected the wrong module (the '0=nvidia' seems to be right, the site it directs me to seems to confirm that), to check the log for clues, and to seek help from SuSE (as I did, with no reply).

As far as I can tell, everything but 3D (possibly OpenGL?) stuff is working. For instance, when trying to run 'glxgears' I get the following error:

Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

Running 'cat /proc/driver/nvidia/agp/status' I get this response:

Status: Disabled

Not sure if it's relevant, but whenever I enter the 'Graphics card and monitor' module in YaST I get a dialogue asking me to configure my display. After doing so, the dialogue comes up again. It doesn't have my monitor model, or even manufacturer, as an option, but it seems to work anyway. After all, I'm able to type this at the computer I'm having the problems on.

I've attached the log found at '/var/log/SaX.log'. Thank you in advance to anyone that can help.
FlipmodePlaya is offline   Reply With Quote
Old 02-19-04, 09:14 PM   #2
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Of course the FX5900 is supported in SuSE 9 as it is in Sax and what error do you get when you run sax2 -m 0=nvidia?

It maybe that your motherboard chipset is not supported as cat /proc/driver/nvidia/agp/status says you have no agp.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 02-19-04, 09:56 PM   #3
FlipmodePlaya
Registered User
 
Join Date: Feb 2004
Posts: 6
Default

Everything was working fine before I updated the drivers in SuSE, and it was working well on a MEPIS partition as well. The following is what I get when I try to configure SaX:

SaX: initializing please wait...
SaX: startup

xc: sorry could not start configuration server
xc: this could have the following reasons:

- the card is still not supported. To get
further information about the driver status
please have a look at:

http://www.xfree86.org/4.2.0/Status.html

- the card was not detected correctly. In
this case please get the information which
XFree86 module provide support for the card
and set the module using the following
command:

sax2 -m 0=<name of the module>

Note: 0 is a digit not a letter
Note: Information about modules are
provided on the mentioned WWW-Page

- the card was detected but the server fails
to start in spite of the detection. In this
case something more serious had happened.
Please have a look at the log file:

/var/log/SaX.log

xc: if you can not determine the cause
please get in contact with:

<support@suse.de>

Please include the log file and a detailed
description into your e-mail

xc: abort...
FlipmodePlaya is offline   Reply With Quote
Old 02-19-04, 10:07 PM   #4
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Well your card is supported(sax2 says FX5900) and I would'nt bother with that xfree86 link as SuSE runs a modified version of xfree86 4.3.You could edit your XF86Config to what nvidia say as they have one to go by rather than going through sax2.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 02-19-04, 10:14 PM   #5
FlipmodePlaya
Registered User
 
Join Date: Feb 2004
Posts: 6
Default

That sounds like a resonable solution, but I'm not sure what you mean by 'what nvidia say'. What should I put in the XFree86 config?
FlipmodePlaya is offline   Reply With Quote
Old 02-19-04, 10:28 PM   #6
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Have a look in /usr/share/doc/NVIDIA_GLX-1.0, you should see a XF86Config sample from nvidia, also read the readme in that directory(or on nvidia's site) which is very useful. Make sure you backup your XF86config just incase.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 02:30 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 11:19 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 01:42 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.