Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-21-04, 10:18 AM   #1
Sothoth
Registered User
 
Join Date: Feb 2004
Posts: 17
Default vesafb framebuffer, XFree86 4.3.0, nVidia 5336 problem

Hi!

I'm a Debian Sid user. I was XFree86 4.2.x, nVidia 5336 driver and vesafb frame buffer in the console. All working fine.

Recently I upgraded to XFree86 4.3.0. Now, I have a problem:

1. The system starts in framebuffer console. The Tux logo, the kernel messages and the starting messages appears perfectly.
2. The system goes then into graphics mode (in X-Window) fine.
3. When I go back to console with Ctrl-Alt-F1... ¬°oops! The screen appears totally horrible, tottaly unreadable (flashing squares with different colors, lines and dots...).

In one sentence: The X-Window crashes the framebuffer console.

If I change:

Section "Device"
[...]
Driver "nvidia"
[...]
EndSection

to

Section "Device"
[...]
Driver "nv"
[...]
EndSection

then the problem disappears. Therefore, the problem is in the nVidia driver, and not in the XFree86 generic driver.

Now I can't get both framebuffer console and 3D accelerated X-Window system working together.

Any solutions? Thanks a lot!
Sothoth is offline   Reply With Quote
Old 02-21-04, 10:53 AM   #2
Sothoth
Registered User
 
Join Date: Feb 2004
Posts: 17
Default SOLUTION! (At least, for me)

The solution was to add a line:

Option "IgnoreDisplayDevices" "TV"

into the corresponding Section "Device", as I read in this forum.

Thanks a lot for all!

P.S.: Why it solves the problem?
Sothoth is offline   Reply With Quote
Old 02-22-04, 11:51 AM   #3
teyu
Registered User
 
Join Date: Feb 2004
Posts: 1
Default

This is the solution I use as well. But there is a problem with it I haven't found a solution to. By using the option to ignore the tv as a display device, it disables the tv output on the card instead of ignoring it. When I then switch to a virtual terminal or exit from X, it does not re-enable the tv ouput. So i can no longer get a console display on my tv.

Now this would not normally be a problem, but I use my tv out for playing movies, and as a workaround want to use mplayer's ability to display to the framebuffer. But that does no good if the driver, instead of actually ignoring the display device, disables it.
teyu is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 10:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.