Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-21-04, 06:12 PM   #1
OwlManAtt
Registered User
 
Join Date: Feb 2004
Posts: 5
Default nVidia Graphics Drivers, GeForce FX 5200, Asus P4S8X-X Problem - Solution

I think I've found a confliction between the nVidia driversm the GeForce FX 5200, and the Asus P4S8X-X Motherboard.

You see, when you boot X under the nvidia driver, the screen would be a garbled load of nothing, and the system would totaly hang.

Since I spent weeks trying to get the nVidia drivers to work by playing with stuff on the software end, someone suggested to play with the BIOS. I changed the AGP speed from 8x to 4x, and disabled fast write (not sure which setting did it), the driver worked.

Just thought I'd share the solution, in hopes someone out there might be able to get their card working. Enjoy.
OwlManAtt is offline   Reply With Quote
Old 02-21-04, 06:38 PM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default

Hi,

you could try to run testgart before starting X.

I have the same problem with an K7S8X. X hangs at first startup, is killable with sysrq-e, and if started again, it will work flawless.
Instead of starting X, testgart will do it too.
energyman76b is offline   Reply With Quote
Old 02-22-04, 05:05 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Do you see the same problems with NVIDIA's builtin AGP GART driver?
zander is offline   Reply With Quote
Old 02-22-04, 01:37 PM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default

Hi,

if you talk to me, I am using kernel AGPGART, because he SiS746FX is not supported by the nvidia AGPGART.
energyman76b is offline   Reply With Quote
Old 02-22-04, 01:46 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

@energyman76b: I meant Ow|ManAtt, since he's using a supported chipset (SiS 648); your problem sounds bizarre, it'd be good if somebody investigated it more closely.
zander is offline   Reply With Quote
Old 02-22-04, 01:55 PM   #6
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default

Hi,

just got mail from someone who read my cry for help on lkml.

A two-line mini-patch, that solved the hanging-at-startup for 648(FX) chips, solved my hanging too!

http://marc.theaimsgroup.com/?l=linu...2145507744&w=2
energyman76b is offline   Reply With Quote
Old 02-22-04, 04:35 PM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Excellent.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 09:43 AM

All times are GMT -5. The time now is 02:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.