Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-11-02, 08:01 PM   #1
Ishtari
Guest
 
Posts: n/a
Angry Bttv...

I bought one gig of memory today, after which I had a total of 1,3 gigs of ram... anyways, After I enabled highmem support in the kernel, xawtv refused to start saying something about bttv memory allocation failure etc etc... without highmem support everything runs fine except that I am only using 1 gig of the 1,3 gigs of ram I have! What does all this have to do with nvidia? well... highmem support and bttv work together if the NVdriver module hasn't been loaded...

Any thoughts?
  Reply With Quote
Old 10-12-02, 10:54 AM   #2
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

"... without highmem support everything runs fine except that I am only
using 1 gig of the 1,3 gigs of ram I have! ..."


Disable highmem support and try the kernel command line option
' mem=1280M ' . Take a look in the man page of bootparam
by entering "man bootparam". It should be possible to write this option
in your boot loader config file.

If this does not work try the following:

Under the kernel config option "high memory support" for compiling
your Linux kernel 2.4.x select "4 G".

And under "user address space size" select "2 G".
Klaus-P is offline   Reply With Quote
Old 10-13-02, 02:12 PM   #3
Ishtari
Guest
 
Posts: n/a
Default

"Disable highmem support and try the kernel command line option
' mem=1280M ' "

Didn't work


"Under the kernel config option "high memory support" for compiling
your Linux kernel 2.4.x select "4 G".

And under "user address space size" select "2 G". "

Where can you set the "user address space size"?
I can't seem to find it
  Reply With Quote
Old 10-14-02, 04:37 AM   #4
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

I've run "make config", take a look at the last
two lines. It's kernel 2.4.18 on my machine.

# cd /usr/src/linux
linux:/usr/src/linux # make config
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
/bin/sh scripts/Configure arch/i386/config.in
#
# Using defaults found in .config
#
*
* Code maturity level options
*
Prompt for development and/or incomplete code/drivers (CONFIG_EXPERIMENTAL) [Y/n/?]
*
* Loadable module support
*
Enable loadable module support (CONFIG_MODULES) [Y/n/?]
Set version information on all module symbols (CONFIG_MODVERSIONS) [N/y/?]
Kernel module loader (CONFIG_KMOD) [Y/n/?]
*
* Processor type and features
*
Processor family (386, 486, 586/K5/5x86/6x86/6x86MX, Pentium-Classic, Pentium-MMX, Pentium-Pro/Celeron/Pentium-II, Pentium-III/Celeron/Coppermine, Pentium-4, K6/K6-II/K6-III, Athlon/Duron/K7, Elan, Crusoe, Winchip-C6, Winchip-2, Winchip-2A/Winchip-3, CyrixIII/C3) [586/K5/5x86/6x86/6x86MX]
defined CONFIG_M586
Toshiba Laptop support (CONFIG_TOSHIBA) [M/n/y/?]
Dell laptop support (CONFIG_I8K) [M/n/y/?]
/dev/cpu/microcode - Intel IA32 CPU microcode support (CONFIG_MICROCODE) [M/n/y/?]
/dev/cpu/*/msr - Model-specific register support (CONFIG_X86_MSR) [M/n/y/?]
/dev/cpu/*/cpuid - CPU information support (CONFIG_X86_CPUID) [M/n/y/?]
High Memory Support (off, 4GB, 64GB) [4GB]
defined CONFIG_HIGHMEM4G
User address space size (3GB, 2GB, 1GB, 3.5GB) [3GB]
defined CONFIG_1GB
Klaus-P is offline   Reply With Quote
Old 10-14-02, 12:48 PM   #5
Ishtari
Guest
 
Posts: n/a
Talking

It works !!!

Thanks for the help...
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
bttv and xawtv freeze drifter NVIDIA Linux 7 09-17-02 10:52 PM

All times are GMT -5. The time now is 03:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.