Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-02-04, 02:25 AM   #1
Lunar
Registered User
 
Lunar's Avatar
 
Join Date: Apr 2003
Location: Texas
Posts: 55
Send a message via ICQ to Lunar Send a message via AIM to Lunar
Default Xandros and nVidia?

I am running an FX 5900 and Xandros 2.0.

I have XFree 86 4 and I am trying to install the latest drivers for my card. It is seen as a Vesa right now. I tried the .run but it couldn't find my kernel source to compile a new kernel. So I directed it to my kernel source directory.

Now it tells me it can't find the nvidia header or something like that. I tried to do a make install and found out that I have no usr/src/nv directory. Is this my problem. And if so, how do i fix it?
Lunar is offline   Reply With Quote
Old 03-02-04, 02:29 AM   #2
Lunar
Registered User
 
Lunar's Avatar
 
Join Date: Apr 2003
Location: Texas
Posts: 55
Send a message via ICQ to Lunar Send a message via AIM to Lunar
Default

To further explain here is what I get from the make install:

lunar@LINUXBOX:~/NVIDIA-Linux-x86-1.0-5336-pkg1$ make install
cd usr/src/nv; make install
make[1]: Entering directory `/home/lunar/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv'
./conftest.sh: line 190: conftest.c: Permission denied
Unable to determine kernel version.
make[1]: *** [select_makefile] Error 1
make[1]: Leaving directory `/home/lunar/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv'
make: *** [kernel_module_install] Error 2
Lunar is offline   Reply With Quote
Old 03-02-04, 02:35 AM   #3
Lunar
Registered User
 
Lunar's Avatar
 
Join Date: Apr 2003
Location: Texas
Posts: 55
Send a message via ICQ to Lunar Send a message via AIM to Lunar
Default

Nm on the usr/src/nv directory thing. Figured out that it was talking about in it's own directory. LOL
Lunar is offline   Reply With Quote
Old 03-02-04, 12:49 PM   #4
Lunar
Registered User
 
Lunar's Avatar
 
Join Date: Apr 2003
Location: Texas
Posts: 55
Send a message via ICQ to Lunar Send a message via AIM to Lunar
Default

Does anyone have any suggestions at all?
Lunar is offline   Reply With Quote
Old 03-06-04, 01:40 AM   #5
lizard
Registered User
 
Join Date: Feb 2004
Posts: 1
Default

Hope you've sorted out your prob. You can find the answer at the Xandros froum - it is hidden in one of the xandros administrator's guides. I cannot remember the exact solution as I'm using Mepis now but the basic problem is that Xandros adds X1 or similar to the end of it's kernel header. run uname -r and you'll see. You have to do something with extraversion to enable the source that you installed have the same header but I cannot remember what.

As I said the answer is definitely in the Xandros forum.
lizard is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.