Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-29-04, 11:55 AM   #1
mbekkail
Registered User
 
Join Date: Feb 2004
Posts: 2
Default Suse 9.0 and NVidia NIC installation problem

Hi,

README at nvidia.com says regarding source rpm installation that I should type:

rpm - - rebuild nforce{package na****-1.0-1.src.rpm

to install the package NVIDIA_nforce-1.0-0261.src.rpm

I typed:

rpm --rebuild NVIDIA_nforce-1.0-0261.src.rpm

and get a list of options for rpm, rebuild is not one of them. The only option that is similar is –rebuilddb

I tried it too,

rpm --rebuilddb NVIDIA_nforce-1.0-0261.src.rpm

Computer does something for few seconds and them gives me no information whatsoever regarding the place where SRPM was compiled to. I browsed /usr/src/ directory but could not find anything either.


So, the README (which accompanies the driver) does not work and I have no idea what to do. Please refer me to working instructions on how to install the driver. I have Kernel 2.4.21 and should be fine given that you provide special instructions for Kernels that precede 2.4.20

Also, here is what I got by using rpmbuild command instead of rebuild as stated in readme

mbekkali@linux:~> su

Password:

linux:/home/mbekkali # cd Linux

linux:/home/mbekkali/Linux # dir

total 110652

drwxr-xr-x 2 mbekkali users 288 2004-02-24 15:19 .

drwxr-xr-x 24 mbekkali users 1360 2004-02-24 15:54 ..

-r-xr-xr-x 1 root root 92517 2004-02-24 10:45 NVIDIA_nforce-1.0-0261.src.rpm

-r-xr-xr-x 1 mbekkali users 57486 2004-02-06 08:19 NVIDIA_nforce-1.0-0261.suse90.i586.rpm

-r-xr-xr-x 1 root root 378880 2003-05-06 12:39 NVIDIA_nforce-1.0-0261.tar[1]

-r-xr-xr-x 1 root root 87301 2004-02-24 10:44 NVIDIA_nforce-1.0-0261.tar.gz

-r-xr-xr-x 1 root root 112567600 2004-02-07 11:57 Suse Linux Wine Rack.rar

linux:/home/mbekkali/Linux # rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm Installing NVIDIA_nforce-1.0-0261.src.rpm

warning: user buildmeister does not exist - using root

warning: group adm does not exist - using root

warning: user buildmeister does not exist - using root

warning: group adm does not exist - using root

warning: user buildmeister does not exist - using root

warning: group adm does not exist - using root

warning: user buildmeister does not exist - using root

warning: group adm does not exist - using root

warning: user buildmeister does not exist - using root

warning: group adm does not exist - using root

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.16528

+ umask 022

+ cd /usr/src/packages/BUILD

+ echo '---- Copying Sources ----'

---- Copying Sources ----

+ cd /usr/src/packages/BUILD

+ rm -rf nforce

+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvnet.tgz

+ tar -xvvf -

drwxr-xr-x buildmeister/adm 0 2003-05-06 12:36:14 nforce/ drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:37 nforce/nvnet/

-r--r--r-- buildmeister/adm 16904 2003-05-06 12:39:37 nforce/nvnet/adapter.h

-r--r--r-- buildmeister/adm 794 2003-05-06 12:39:37 nforce/nvnet/basetype.h

-r--r--r-- buildmeister/adm 6752 2003-05-06 12:39:37 nforce/nvnet/nvnet.h

-r--r--r-- buildmeister/adm 4437 2003-05-06 12:39:37 nforce/nvnet/os.h

-r--r--r-- buildmeister/adm 4749 2003-05-06 12:39:37 nforce/nvnet/phy.h

-r--r--r-- buildmeister/adm 37870 2003-05-06 12:39:37 nforce/nvnet/nvnet.c

-rw-r--r-- buildmeister/adm 21504 2003-05-06 12:39:37 nforce/nvnet/nvnetlib.o

-r--r--r-- buildmeister/adm 3088 2003-05-06 12:39:37 nforce/nvnet/Makefile

+ STATUS=0

+ '[' 0 -ne 0 ']'

+ cd nforce

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chown -Rhf root .

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chgrp -Rhf root .

+ /bin/chmod -Rf a+rX,g-w,o-w .

+ cd /usr/src/packages/BUILD

+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvaudio.tgz

+ tar -xvvf -

drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/ drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/nvaudio/

-r--r--r-- buildmeister/adm 2522 2003-05-06 12:39:38 nforce/nvaudio/Makefile

-r--r--r-- buildmeister/adm 58241 2003-05-06 12:39:38 nforce/nvaudio/nvcrush.c

-r--r--r-- buildmeister/adm 32174 2003-05-06 12:39:38 nforce/nvaudio/nvhw.c

-r--r--r-- buildmeister/adm 33857 2003-05-06 12:39:38 nforce/nvaudio/nvmain.c

-r--r--r-- buildmeister/adm 8314 2003-05-06 12:39:38 nforce/nvaudio/nvrec.c

-r--r--r-- buildmeister/adm 26382 2003-05-06 12:39:38 nforce/nvaudio/nvspdif.c

-r--r--r-- buildmeister/adm 14709 2003-05-06 12:39:38 nforce/nvaudio/nvwavout.c

-r--r--r-- buildmeister/adm 4546 2003-05-06 12:39:38 nforce/nvaudio/chaninfo.h

-r--r--r-- buildmeister/adm 5065 2003-05-06 12:39:38 nforce/nvaudio/nvhw.h

-r--r--r-- buildmeister/adm 1570 2003-05-06 12:39:38 nforce/nvaudio/nvioctl.h

-r--r--r-- buildmeister/adm 1392 2003-05-06 12:39:38 nforce/nvaudio/nvrec.h

-r--r--r-- buildmeister/adm 1618 2003-05-06 12:39:38 nforce/nvaudio/nvspdif.h

-r--r--r-- buildmeister/adm 1499 2003-05-06 12:39:38 nforce/nvaudio/nvwavout.h

+ STATUS=0

+ '[' 0 -ne 0 ']'

+ cd nforce

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chown -Rhf root .

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chgrp -Rhf root .

+ /bin/chmod -Rf a+rX,g-w,o-w .

+ cd /usr/src/packages/BUILD

+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvmaster.tgz

+ tar -xvvf -

drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:36 nforce/

-r--r--r-- buildmeister/adm 1091 2003-05-06 12:39:36 nforce/Makefile

-r--r--r-- buildmeister/adm 5404 2003-05-06 12:39:36 nforce/NVLicense.txt

-r--r--r-- buildmeister/adm 18007 2003-05-06 12:39:36 nforce/GNULicense.txt

-r--r--r-- buildmeister/adm 23612 2003-05-06 12:39:36 nforce/ReleaseNotes.html

+ STATUS=0

+ '[' 0 -ne 0 ']'

+ cd nforce

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chown -Rhf root .

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chgrp -Rhf root .

+ /bin/chmod -Rf a+rX,g-w,o-w .

+ cd /usr/src/packages/BUILD

+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvgart.tgz

+ tar -xvvf -

drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/ drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/nvgart/

-r--r--r-- buildmeister/adm 590 2003-05-06 12:39:38 nforce/nvgart/Makefile

-r--r--r-- buildmeister/adm 1231 2003-05-06 12:39:38 nforce/nvgart/README

-r--r--r-- buildmeister/adm 14033 2003-05-06 12:39:38 nforce/nvgart/linux-2.4.20-agpgart.diff

+ STATUS=0

+ '[' 0 -ne 0 ']'

+ cd nforce

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chown -Rhf root .

++ /usr/bin/id -u

+ '[' 0 = 0 ']'

+ /bin/chgrp -Rhf root .

+ /bin/chmod -Rf a+rX,g-w,o-w .

+ exit 0

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.16528

+ umask 022

+ cd /usr/src/packages/BUILD

+ cd nforce

+ echo '---- Building Drivers ----'

---- Building Drivers ----

+ make

/var/tmp/rpm-tmp.16528: line 24: make: command not found

error: Bad exit status from /var/tmp/rpm-tmp.16528 (%build)





RPM build errors:

user buildmeister does not exist - using root

group adm does not exist - using root

user buildmeister does not exist - using root

group adm does not exist - using root

user buildmeister does not exist - using root

group adm does not exist - using root

user buildmeister does not exist - using root

group adm does not exist - using root

user buildmeister does not exist - using root

group adm does not exist - using root

Bad exit status from /var/tmp/rpm-tmp.16528 (%build) linux:/home/mbekkali/Linux #



Seems to me that SRPM was not compiled either since rpm generates bad exit error. That is why asked before if the driver works at all.


PS. Someone said that Linux is 98% ready to be adopted to desktop, but it is 2% that kill. Very true in my case so far.
mbekkail is offline   Reply With Quote
Old 03-06-04, 01:37 PM   #2
GamblerFEXonlin
polygons are fun!
 
GamblerFEXonlin's Avatar
 
Join Date: Jul 2002
Posts: 187
Send a message via ICQ to GamblerFEXonlin
Default

Hello!

I downloaded SuSE 9.0 NVIDIA_nforce-1.0-0261.suse90.i586.rpm from http://www.nvidia.com/object/linux_nforce_1.0-0261 and just double-clicked the .rpm file and clicked a "install button (dont remember exactly name) and it installed fine i think.

Except the NIC wont work, but USB works and no longer hang during boot.

MSI K7N Delta (i think).
GamblerFEXonlin is offline   Reply With Quote
Old 03-07-04, 09:22 AM   #3
Inferno
Registered User
 
Join Date: Mar 2004
Posts: 4
Send a message via ICQ to Inferno
Default

Hello,

i have a problem with the installation of the ethernet nvidia drivers. I downloaded the nvidia.src.rpm and rebuild it with my kernel, but the ethernet driver doesn't work.

When i write insmod nvnet.o, suse load the driver and my ethernet work.

My question: how can i load the driver at startup ???


sorry for my bad english

Last edited by Inferno; 03-07-04 at 01:47 PM.
Inferno is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 08:37 AM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 07:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.