Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-14-02, 07:36 PM   #1
corrosion
Registered User
 
Join Date: Sep 2002
Posts: 5
Exclamation aahh!

i always had a problem with nvidia drivers in one of my machines. it haves a geforce2mx (hercules prophet 4500 i think im not at home now).
the fonts systems become GIANT and it is not related to font antialias or similar. I have a very similar machine with another nvidia but it is a Riva TNT2 M64 or similar name... but this machine does not have problems with nvidia drivers.
PLEASE is someone there who knows how to solve this problem??
corrosion is offline   Reply With Quote
Old 10-15-02, 08:56 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It's a monitor DPI thing. I had the same problem when I switched from driver build 769 to whichever build was after that one. With 769 and earlier, the nVidia X driver didn't report the DPI properly (and I thought it was just fine the way it was... whatever), so KDE 2 thought it was 75DPI. So its 14-point font was just about the right size for a window title.

When I went from 769 to whatever the next release was, the X driver did start reporting the DPI properly (it was closer to 100DPI than 75), so all of a sudden the KDE 2 14-point font got gigantic. So I made KDE use its 8-point font instead, which ended up being just about the right size.

Of course, I've since stopped using KDE, but DPI was my problem. Maybe it's something similar there? Can you make your desktop environment (or window manager, whichever one you run) use a smaller font for decorations?

You might also try looking at your font path (xset q | grep X11R6 should tell you the current font path), and seeing whether the 75DPI font directory is in front of or behind the 100DPI font directory. Moving it behind the 100DPI directory (which is accomplished by removing it and then adding it at the end of the path) should help:

xset fp- /usr/X11R6/lib/fonts/75dpi/
xset fp+ /usr/X11R6/lib/fonts/75dpi/


If the xset q command doesn't print anything, then you're probably using xfs, the X font server. There's probably documentation somewhere on how to change which directories xfs looks for fonts in, and in which order, but I don't know where it would be, or how to do it. I don't use xfs...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-15-02, 01:46 PM   #3
corrosion
Registered User
 
Join Date: Sep 2002
Posts: 5
Default

thnx a lot bwkaz
im going to try what you say. unfortunately i cant do it now im going to work xD
im impatient to see the results
corrosion is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.