Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-11-04, 01:13 PM   #1
sdinucci
Registered User
 
Join Date: Mar 2004
Posts: 3
Unhappy Red Hat Fedora 2.6.3 kernel and NVIDIA 5336 Driver

I am having a problem running the NVIDIA 5336 driver under Red Hat Fedora on a 2.6.3 kernel. The version of XFree is 4.3. I load the kernel without any problems. I change the XF86Config file based on the readme file (Driver "nvidia", remove - Load "dri" & Load "GLcore, Add - Load "glx"). At the point where the X Server loads the screen goes blank and the system hangs. I can run the NVIDIA 5336 driver under a 2.6.1 kernel. There is nothing in the boot log.

Has anyone gotten around this issue or know how to install/configure the driver or XFree?

Scott
sdinucci is offline   Reply With Quote
Old 03-11-04, 08:08 PM   #2
kemical
Registered User
 
Join Date: Mar 2004
Posts: 5
Send a message via AIM to kemical
Default

couple things, do you have nvidia support enabled in your updated kernel?

and did you try running xf86config to generate a fresh config and try from there?

also, when you compiled the kernel did you remove and install nvidia driver again? due to recompiling you have to recompile the nvidia module again as well.. same goes for alsa if anyone is curious.
__________________
...kemical .. .. .
kemical is offline   Reply With Quote
Old 03-11-04, 09:35 PM   #3
tete
Registered User
 
Join Date: Mar 2004
Location: Seattle, Wa, USA
Posts: 2
Default

My issue is i can get the splashscreen but then it dumps X. The only thing I get in my log is warnings about some obsure resolutions are not supported but no actual errors. Works fine in Slackware, Debian, and Mandrake though. The only solution I have heard so far is to find or build your own source rpms for the glx and kernel. If i find a solution I'll post again.
__________________
"It's not stupid, Its advanced" -Invader Zim
tete is offline   Reply With Quote
Old 03-12-04, 07:12 AM   #4
sdinucci
Registered User
 
Join Date: Mar 2004
Posts: 3
Default

I am new to Linux so here is a basic question...........

Where do I look to see if NVIDIA support is enabled within a kernel?
sdinucci is offline   Reply With Quote
Old 03-12-04, 01:59 PM   #5
kemical
Registered User
 
Join Date: Mar 2004
Posts: 5
Send a message via AIM to kemical
Default

both of you post your /etc/X11/XF86Config files
__________________
...kemical .. .. .
kemical is offline   Reply With Quote
Old 03-12-04, 04:00 PM   #6
tete
Registered User
 
Join Date: Mar 2004
Location: Seattle, Wa, USA
Posts: 2
Default

Here is mine...
I also found this link, unfortunatly its all in dutch but I'll try it when I get the chance
http://projects.tuxed.net/fedora/howto/

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you


# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1600x1200"
HorizSync 31.5 - 90.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
__________________
"It's not stupid, Its advanced" -Invader Zim

Last edited by tete; 03-12-04 at 04:17 PM.
tete is offline   Reply With Quote
Old 03-12-04, 04:49 PM   #7
sdinucci
Registered User
 
Join Date: Mar 2004
Posts: 3
Default

Here is mine... Also, there was a message on the Fedora test site I tried related to
CONFIG_4K_STACKS.

'CONFIG_4KSTACKS is the likely suspect, minion.de says it's not compatible
with the driver and the latest kernels have that enabled. '

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 1702FP (Digital)"
DisplaySize 340 270
HorizSync 30.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
Option "NvAGP" "0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

#Section "DRI"
# Group 0
# Mode 0666
#EndSection

Last edited by sdinucci; 03-12-04 at 09:06 PM.
sdinucci is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM

All times are GMT -5. The time now is 06:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.